Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 575978 - dev-java/oracle-jdk-bin-1.8.0.74: can't play videos with JavaFX
Summary: dev-java/oracle-jdk-bin-1.8.0.74: can't play videos with JavaFX
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-29 10:07 UTC by aditsu
Modified: 2016-02-29 10:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
test program (URL version) (VideoTest.java,722 bytes, text/x-java)
2016-02-29 10:10 UTC, aditsu
Details
test program (file version) (VideoTest.java,700 bytes, text/x-java)
2016-02-29 10:17 UTC, aditsu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aditsu 2016-02-29 10:07:02 UTC
I tried to use JavaFX to play a video file, but got this error:

MediaException: UNKNOWN : com.sun.media.jfxmedia.MediaException: Could not create player!

It happens with every file I tried (except unsupported formats). The same code (with the same files) is working perfectly fine in windows.
Upon debugging, I found that a MediaError with code 265, name "ERROR_MEDIA_AUDIO_FORMAT_UNSUPPORTED", is internally reported in GSTMedia.init()

I tried a few different audio codecs, and even removed the audio completely, but still got the same error every time.
Comment 1 aditsu 2016-02-29 10:10:56 UTC
Created attachment 426966 [details]
test program (URL version)

Here is a simple program you can use for testing. The file I used is from http://download.oracle.com/otndocs/products/javafx/oow2010-2.flv (Oracle's own sample video). You could also try to load it directly from the URL, but that seems to freeze the program in my case.
Comment 2 aditsu 2016-02-29 10:16:13 UTC
Comment on attachment 426966 [details]
test program (URL version)

Oops, I uploaded the URL version by accident
Comment 3 aditsu 2016-02-29 10:17:29 UTC
Created attachment 426974 [details]
test program (file version)

This is the code I intended to upload the first time.
Comment 4 James Le Cuirot gentoo-dev 2016-02-29 10:22:38 UTC
As discussed on IRC, this is probably because we don't install the ffmpeg helper libraries. That's because they always lag too far behind the ffmpeg versions we have in the tree.

One option might be to force the helper libraries to use the system version anyway so it at least has a chance of working. On the other hand, that could possibly bring down the whole JVM.

The best solution would be to package OpenJFX so that we can properly link against our own ffmpeg but don't expect that in a hurry.

Thanks for the test program, that's very helpful.
Comment 5 aditsu 2016-02-29 10:32:13 UTC
Thanks, any solution would be fine, as long as it doesn't break other things. Just wanted to report this so we have a record. Let me know if I can help.