Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 575056 - media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r5 : /.../gstffmpegcodecmap.c:1761:45: error: parameter 1 ('pix_fmt') has incomplete type
Summary: media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r5 : /.../gstffmpegcodecmap....
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords: NeedPatch
: 576688 601946 602304 602366 603832 607180 (view as bug list)
Depends on: 594878
Blocks: ffmpeg-3
  Show dependency tree
 
Reported: 2016-02-18 14:18 UTC by Toralf Förster
Modified: 2017-02-16 01:18 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,42 bytes, text/plain)
2016-02-18 14:18 UTC, Toralf Förster
Details
environment (environment,112.11 KB, text/plain)
2016-02-18 14:18 UTC, Toralf Förster
Details
media-plugins:gst-plugins-ffmpeg-0.10.13_p201211-r5:20160217-220037.log (media-plugins:gst-plugins-ffmpeg-0.10.13_p201211-r5:20160217-220037.log,47.50 KB, text/plain)
2016-02-18 14:18 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-02-18 14:18:03 UTC
     enum AVCodecID codec_id, gboolean encode)
          ^
/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r5/work/gst-ffmpeg-0.10.13_p201211/ext/ffmpeg/gstffmpegcodecmap.c:1761:45: error: parameter 1 ('pix_fmt') has incomplete type
 gst_ffmpeg_pixfmt_to_caps (enum PixelFormat pix_fmt, AVCodecContext * context,
                                             ^
/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r5/work/gst-ffmpeg-0.10.13_p201211/ext/ffmpeg/gstffmpegcodecmap.c: In function 'gst_ffmpeg_pixfmt_to_caps':


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-desktop-unstable_20160121-225036) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="mmx sse sse2 pax_kernel -cdinstall -oci8 -bindist -aes-ni alisp avcodec bzip2 cairo cgi cgoups corefonts dbus -designer dot -drmkms ecc eglfs -evdev -ffmpeg -fontconfig gles2 gnuplot gstreamer gtk icu imap isag kvm -mdnsresponder-compat mikmod mssql objc ogg opengl pcre16 pkcs11 policykit postproc -qt5 -sockets source spice ssh-askpass ssse3 svg swscale system-icu uxa vaapi vorbis wma xslt xvfb zenmap"

  -----------------------------------------------------------------
Portage 2.2.27 (python 2.7.11-final-0, default/linux/amd64/13.0/desktop, gcc-5.3.0, glibc-2.22-r2, 4.3.5-hardened-r2 x86_64)
=================================================================
System uname: Linux-4.3.5-hardened-r2-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16164680 total,   1592352 free
KiB Swap:   16777212 total,  16710888 free
Timestamp of repository gentoo: Wed, 17 Feb 2016 19:22:31 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.4 [disabled]
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo, 3.5.1-r2::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.4.3::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.5::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.2.4-r1::gentoo, 4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/grs/systems.conf /etc/stunnel/stunnel.conf /opt/openfire/resources/security/ /usr/lib64/fax /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb /var/lib/i2pd/certificates /var/lib/redmine/config /var/rancid/.cloginrc /var/spool/fax/etc /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --deep --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alisp alsa amd64 avcodec berkdb bluetooth branding bzip2 cairo cdda cdr cgi cgoups cli consolekit corefonts cracklib crypt cups cxx dbus dot dri dts dvd dvdr ecc eglfs emboss encode exif fam firefox flac fortran gdbm gif glamor gles2 gnuplot gpm gstreamer gtk iconv icu imap ipv6 isag jpeg kvm lcms ldap libnotify mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mssql multilib ncurses nls nptl objc ogg opengl openmp pam pango pax_kernel pcre pcre16 pdf pkcs11 png policykit postproc ppds qt3support qt4 readline sdl seccomp session source spell spice sse sse2 ssh-askpass ssl ssse3 startup-notification svg swscale system-icu tcpd tiff truetype udev udisks unicode upower usb uxa vaapi vorbis wma wxwidgets x264 xattr xcb xml xslt xv xvfb xvid zenmap zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-02-18 14:18:08 UTC
Created attachment 425810 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-02-18 14:18:10 UTC
Created attachment 425812 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-02-18 14:18:13 UTC
Created attachment 425814 [details]
media-plugins:gst-plugins-ffmpeg-0.10.13_p201211-r5:20160217-220037.log
Comment 4 Pacho Ramos gentoo-dev 2016-03-07 15:30:12 UTC
*** Bug 576688 has been marked as a duplicate of this bug. ***
Comment 5 cristiano04 2016-05-20 01:25:55 UTC
https://bugzilla.gnome.org/show_bug.cgi?id=766687
Comment 6 Pacho Ramos gentoo-dev 2016-05-23 08:47:30 UTC
(In reply to cristiano04 from comment #5)
> https://bugzilla.gnome.org/show_bug.cgi?id=766687

upstream is not supporting gst-0.10 for ages then, I doubt they will provide any fix :(

For now we have being able to keep this working with newer versions because of patches from different downstreams, but, currently, it looks like none is available yet since other distributions are moving out of gst-0.10 too
Comment 7 cristiano04 2016-06-09 13:58:04 UTC
(In reply to Pacho Ramos from comment #6)
> (In reply to cristiano04 from comment #5)
> > https://bugzilla.gnome.org/show_bug.cgi?id=766687
> 
> upstream is not supporting gst-0.10 for ages then, I doubt they will provide
> any fix :(
> 
> For now we have being able to keep this working with newer versions because
> of patches from different downstreams, but, currently, it looks like none is
> available yet since other distributions are moving out of gst-0.10 too

Out of curiosity (because I am genuinely ignorant about gst), what is the rationale for using gst 0.10?
Comment 8 Pacho Ramos gentoo-dev 2016-06-11 10:16:43 UTC
There are still many reverse dependencies for it, then, we cannot remove gst-0.10 yet
Comment 9 Michael Palimaka (kensington) gentoo-dev 2016-12-08 06:14:04 UTC
*** Bug 601946 has been marked as a duplicate of this bug. ***
Comment 10 Pacho Ramos gentoo-dev 2016-12-11 10:15:05 UTC
*** Bug 602304 has been marked as a duplicate of this bug. ***
Comment 11 Mike Gilbert gentoo-dev 2016-12-11 18:52:01 UTC
*** Bug 602366 has been marked as a duplicate of this bug. ***
Comment 12 Ian Kumlien 2016-12-11 23:25:58 UTC
It seems like the last release of gst-plugin-ffmpeg is 1.10.0 and it's ~1 month old

While this package hasn't been updated since 2012?
Comment 13 Oleh 2016-12-14 15:21:24 UTC
while, i agree that gst-0.10 have to die, but this particular bug can be easily fixed by restricting ffmpeg dep to =media-video/ffmpeg-2.8*. users that have to deal with gst-plugins-ffmpeg-0.10* because of reverse deps must manually downgrade to 2.8.10.
Comment 14 Fred Krogh 2016-12-14 16:47:21 UTC
Just downgraded to ffmpeg-2.8.10 and finally --depclean works.  Thanks for posting this.
Comment 15 Craig Andrews gentoo-dev 2016-12-22 17:43:16 UTC
pull request changing the dependency to restrict to ffmpeg-2*: https://github.com/gentoo/gentoo/pull/3215
Comment 16 Brandon Penglase 2016-12-25 03:53:25 UTC
(In reply to Oleg from comment #13)
> while, i agree that gst-0.10 have to die, but this particular bug can be
> easily fixed by restricting ffmpeg dep to =media-video/ffmpeg-2.8*. users
> that have to deal with gst-plugins-ffmpeg-0.10* because of reverse deps must
> manually downgrade to 2.8.10.

I just tried to downgrade, but I'm yelled at by both mplayer, VLC, and some others that need either >=3.0 or ":0/55.57.57="
Comment 17 Michael Palimaka (kensington) gentoo-dev 2016-12-28 17:33:29 UTC
*** Bug 603832 has been marked as a duplicate of this bug. ***
Comment 18 Brian Evans Gentoo Infrastructure gentoo-dev 2017-01-25 14:15:53 UTC
*** Bug 607180 has been marked as a duplicate of this bug. ***
Comment 19 Mart Raudsepp gentoo-dev 2017-02-16 01:18:16 UTC
gst-plugins-ffmpeg is last rited and will go away