Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 56967 - Move version control systems to dev-vcs category
Summary: Move version control systems to dev-vcs category
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Christian Faulhammer (RETIRED)
URL:
Whiteboard:
Keywords:
: 80756 311647 323043 (view as bug list)
Depends on: 307849 308151
Blocks:
  Show dependency tree
 
Reported: 2004-07-13 16:47 UTC by Keri Harris
Modified: 2011-02-10 21:45 UTC (History)
20 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
List of packages to move to dev-vcs including herds/maintainers (vcs-move-jobs.txt,2.51 KB, text/plain)
2010-03-05 01:26 UTC, Sebastian Pipping
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keri Harris gentoo-dev 2004-07-13 16:47:43 UTC
I'm not convinced that a revision control system belongs in app-text. ;)
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2004-07-13 16:52:33 UTC
yes, we know.
Comment 2 Marius Mauch (RETIRED) gentoo-dev 2004-07-13 17:31:41 UTC
Just to explain the LATER: we just can't agree on a name for a new category for rcs, cvs and co.
Comment 3 Christian Faulhammer (RETIRED) gentoo-dev 2010-03-04 15:43:39 UTC
Reopen to unclutter the dev-util category
Comment 4 Dirkjan Ochtman gentoo-dev 2010-03-04 15:47:35 UTC
How long do we have to wait? It looks like pretty much everyone is in agreement...
Comment 5 Christian Faulhammer (RETIRED) gentoo-dev 2010-03-04 15:49:52 UTC
It just has to be done, so time is the problem: I can do the bazaar things, you can start with Mercurial.  Don't forget to make a proper package move!
Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-04 19:02:59 UTC
I will move Subversion.
Comment 7 Sebastian Pipping gentoo-dev 2010-03-04 19:37:32 UTC
dev-vcs category now online.
http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-vcs/
Comment 8 Sebastian Pipping gentoo-dev 2010-03-05 01:26:27 UTC
Created attachment 222133 [details]
List of packages to move to dev-vcs including herds/maintainers

In my eyes these packages should be moved to dev-vcs.
Mailing their maintainers in a minute.
Comment 9 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-03-05 03:48:33 UTC
kdesvn, qgit, qct and hgview (KDE/Qt packages) moved. CC us again if something comes up. thanks
Comment 10 Ulrich Müller gentoo-dev 2010-03-05 06:17:49 UTC
(In reply to comment #8)
> Created an attachment (id=222133) [details]
> List of packages to move to dev-vcs including herds/maintainers

app-text/rcs is missing. I can take of its move (it's maintainer-needed).
Comment 11 Ulrich Müller gentoo-dev 2010-03-05 09:29:12 UTC
*** Bug 80756 has been marked as a duplicate of this bug. ***
Comment 12 Ulrich Müller gentoo-dev 2010-03-05 09:36:40 UTC
More packages that are not in the list:

dev-util/cssc
        <email>jer@gentoo.org</email>
dev-util/cvsweb
        <herd>web-apps</herd>
        (maybe www-apps is more appropriate for this one?)
Comment 13 Christian Faulhammer (RETIRED) gentoo-dev 2010-03-05 10:09:38 UTC
All Bazaar packages done.

(In reply to comment #12)
> dev-util/cvsweb
>         <herd>web-apps</herd>
>         (maybe www-apps is more appropriate for this one?)

 Yes, move it over to www-apps.

Comment 14 Ulrich Müller gentoo-dev 2010-03-05 16:46:25 UTC
(In reply to comment #13)
> > dev-util/cvsweb
> >         <herd>web-apps</herd>
> >         (maybe www-apps is more appropriate for this one?)
> 
>  Yes, move it over to www-apps.

@web-apps: Would you mind if I do this myself?
Comment 15 Serkan Kaba (RETIRED) gentoo-dev 2010-03-05 18:07:42 UTC
statsvn and statcvs are done.
Comment 16 Justin Lecher (RETIRED) gentoo-dev 2010-03-06 12:17:43 UTC
colorcvs done
Comment 17 Dirkjan Ochtman gentoo-dev 2010-03-06 13:23:40 UTC
mercurial, hgsubversion and hg-git are done.
Comment 18 Ulrich Müller gentoo-dev 2010-03-06 13:32:57 UTC
rcs, mcvs, and cvsweb are done.
Comment 19 Ulrich Müller gentoo-dev 2010-03-06 16:02:54 UTC
guilt and stgit are done.
Comment 20 Lennart Kolmodin (RETIRED) gentoo-dev 2010-03-14 12:56:19 UTC
darcs is done.
Comment 21 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-27 17:43:30 UTC
*** Bug 311647 has been marked as a duplicate of this bug. ***
Comment 22 Dirkjan Ochtman gentoo-dev 2010-03-30 11:36:03 UTC
From the attachment, not moved yet:

aegis (maintainer-needed)
cola (dev-zero)
cvs* (all the cvs-utils packages)
easygit (jokey)
fossil (last touched by vapier, no herd or maintainer)
gitosis (robbat2)
gitosis-gentoo (robbat2)
hgsvn (cedk)
qgit (jokey)
rapidsvn (dev-tools, nerdboy)
subversion (arfrever)
svk (maintainer-needed)
svn2cl (dev-tools)
tig (gregkh)
tkcvs (tcltk)
Comment 23 Ulrich Müller gentoo-dev 2010-05-07 21:09:04 UTC
(In reply to comment #22)
> fossil (last touched by vapier, no herd or maintainer)
> svk (maintainer-needed)

I've taken care of these two.
Comment 24 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-06-07 11:38:13 UTC
*** Bug 323043 has been marked as a duplicate of this bug. ***
Comment 25 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-06-07 19:18:55 UTC
+1 to moving:
cvs*
gitosis*
Comment 26 Tiziano Müller (RETIRED) gentoo-dev 2010-06-08 12:24:01 UTC
cola done.
Comment 27 Justin Lecher (RETIRED) gentoo-dev 2010-06-08 12:34:19 UTC
Only dev-util/qgit is missing
Comment 28 Justin Lecher (RETIRED) gentoo-dev 2010-06-08 12:41:25 UTC
I was wrong:

dev-util/subversion
dev-util/svn2cl
dev-util/tig
dev-util/tkcvs
dev-util/rapidsvn
dev-util/qgit
dev-util/hgsvn
dev-util/gitosis-gentoo
dev-util/gitosis
dev-util/easygit
dev-util/cvsutils
dev-util/cvsq
dev-util/cvsps
dev-util/cvsgraph
dev-util/cvsd
dev-util/cvs2cl
dev-util/cvs
Comment 29 Cédric Krier gentoo-dev 2010-06-14 07:20:48 UTC
It is ok if someone moves dev-util/hgsvn
Comment 30 Justin Lecher (RETIRED) gentoo-dev 2010-06-15 08:15:14 UTC
(In reply to comment #29)
> It is ok if someone moves dev-util/hgsvn
> 

done
Comment 31 Greg Kroah-Hartman (RETIRED) gentoo-dev 2010-06-15 16:01:49 UTC
Can someone else please move dev-util/tig?  I'm unable to get to this for a while due to travel.
Comment 32 Justin Lecher (RETIRED) gentoo-dev 2010-06-15 16:15:51 UTC
(In reply to comment #31)
> Can someone else please move dev-util/tig?  I'm unable to get to this for a
> while due to travel.
> 

done
Comment 33 Jonathan Callen (RETIRED) gentoo-dev 2010-06-19 01:15:27 UTC
(In reply to comment #25)
> +1 to moving:
> cvs*

dev-util/cvs* are all done
Comment 34 Sebastian Pipping gentoo-dev 2010-06-19 01:49:39 UTC
(In reply to comment #33)
> dev-util/cvs* are all done

Including CVS itself?  Awesome!
Comment 35 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-06-19 16:28:08 UTC
(In reply to comment #25)
> +1 to moving:
> gitosis*

gitosis and gitosis-gentoo done.
Comment 36 Dirkjan Ochtman gentoo-dev 2010-06-21 00:33:17 UTC
Good progress! Still left:

aegis (maintainer-needed)
easygit (jokey)
qgit (jokey)
rapidsvn (dev-tools, nerdboy)
subversion (arfrever)
svn2cl (dev-tools)
tkcvs (tcltk)
Comment 37 Justin Lecher (RETIRED) gentoo-dev 2010-06-21 09:37:07 UTC
(In reply to comment #36)
> Good progress! Still left:
> 
> aegis (maintainer-needed)
> tkcvs (tcltk)
> 

Will do those.
Comment 38 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-06-22 19:00:55 UTC
subversion renamed.
Comment 39 Ulrich Müller gentoo-dev 2011-02-04 06:56:05 UTC
Still left:

   dev-util/easygit (jokey)
   dev-util/qgit (jokey)
   dev-util/rapidsvn (nerdboy, dev-tools)
   dev-util/rcsi (robbat2, cvs-utils)
   dev-util/svn2cl (dev-tools)

I'll move them to dev-vcs in one week from now, unless someone raises objections.
Comment 40 Ulrich Müller gentoo-dev 2011-02-10 21:45:51 UTC
(In reply to comment #39)
>    dev-util/easygit (jokey)
>    dev-util/qgit (jokey)
>    dev-util/rapidsvn (nerdboy, dev-tools)
>    dev-util/rcsi (robbat2, cvs-utils)
>    dev-util/svn2cl (dev-tools)

All done. Closing.