Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 566052 - www-apps/drupal - Add post-install note about Apache and PHP configuration
Summary: www-apps/drupal - Add post-install note about Apache and PHP configuration
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Web Application Packages Maintainers
URL: https://www.drupal.org/node/2501851#c...
Whiteboard:
Keywords:
: 565848 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-17 12:43 UTC by Dennis Schridde
Modified: 2020-09-07 16:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2015-11-17 12:43:19 UTC
Could you please add a line to the post-install information that Drupal upstream only supports Apache (and a few others) as webserver, and also does not support something like php-fpm out of the box?

I ran into an issue with Lighttpd (https://www.drupal.org/node/2501851#comment-10569956), because it does not use the .htaccess files (which set some PHP options for mod_php), which resulted in warnings, which are then propagated to hard-to-debug initialisation errors.

Thus I think that something like the following would help new users:
einfo "Beware: The default setup of Drupal supports only the Apache httpd out of the box. If you use another webserver, you'll have to port the various .htaccess files to it. You are on your own!"

Maybe you could also add a link to the requirements file: https://www.drupal.org/requirements

Reproducible: Always
Comment 1 Dennis Schridde 2015-11-20 12:25:17 UTC
*** Bug 565848 has been marked as a duplicate of this bug. ***
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2015-11-22 23:46:00 UTC
Drupal can be run on other web servers, besides apache.
I suppose we could add something along the following in pkg_postinst.

To run Drupal on a web server[1] other than apache, one needs to do some work, mostly related to adding the configuration in the .htaccess files to the web server config files and enabling redirection.
For lighttpd you may want to check [2][3] and for nginx [4][5].

 [1] - https://www.drupal.org/requirements/webserver
 [2] - https://groups.drupal.org/lighttpd
 [3] - https://www.drupal.org/node/43782
 [4] - https://www.drupal.org/node/1030854
 [5] - https://www.nginx.com/resources/wiki/start/topics/recipes/drupal/
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2015-12-05 18:40:02 UTC
18:36 < gentoovcs> jmbsvicetto → repo/gentoo (www-apps/drupal/files/) Add some warnings for those running drupal with a web server other than apache - fixes bug 566052.
18:36 < willikins> gentoovcs: https://bugs.gentoo.org/566052 "www-apps/drupal - Add post-install note about Apache"; Gentoo Linux, Applications; CONF; devurandom:web-apps

I've went ahead and added the above text to postinstall-en.txt.
if you feel this isn't enough to address your concerns feel free to reopen the bug and to propose an alternate text / solution.
Comment 5 Dennis Schridde 2016-01-03 14:51:08 UTC
PHP-FPM supports user.ini files with per-directory settings: http://php.net/manual/en/configuration.file.per-user.php

Information about this mechanism could be added to the post-install notes, too.

My .user.ini file currently looks like this:
always_populate_raw_post_data = -1
assert.active = Off
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2020-09-07 16:15:07 UTC
(In reply to Dennis Schridde from comment #5)
> PHP-FPM supports user.ini files with per-directory settings:
> http://php.net/manual/en/configuration.file.per-user.php
> 
> Information about this mechanism could be added to the post-install notes,
> too.
> 
> My .user.ini file currently looks like this:
> always_populate_raw_post_data = -1
> assert.active = Off

I've added a note to postinstall based on your comment.
The always_populate_raw_post_data option was removed on PHP-7.0
https://www.php.net/manual/en/ini.core.php
I'll let users decide about assert on their own.
Comment 7 Larry the Git Cow gentoo-dev 2020-09-07 16:15:15 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/dev/jmbsvicetto.git/commit/?id=7a1cf7e99eb018b180ca758928cfbdbbfb189dbb

commit 7a1cf7e99eb018b180ca758928cfbdbbfb189dbb
Author:     Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
AuthorDate: 2020-09-07 16:14:17 +0000
Commit:     Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
CommitDate: 2020-09-07 16:14:17 +0000

    Update postinstall for Drupal.
    
    Bug: https://bugs.gentoo.org/566052
    Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>

 www-apps/drupal/files/postinstall-en.txt | 4 ++++
 1 file changed, 4 insertions(+)
Comment 8 Larry the Git Cow gentoo-dev 2020-09-07 16:22:30 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1400d72e567e9c8936e4746c30eb58ed2cc50385

commit 1400d72e567e9c8936e4746c30eb58ed2cc50385
Author:     Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
AuthorDate: 2020-09-07 16:16:38 +0000
Commit:     Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
CommitDate: 2020-09-07 16:16:38 +0000

    www-apps/drupal: Update postinstall.
    
    Fixes: https://bugs.gentoo.org/566052
    Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>

 www-apps/drupal/files/postinstall-en.txt | 4 ++++
 1 file changed, 4 insertions(+)