Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 565848 - www-apps/drupal-8.0.0_rc4 - Drupal\Core\Config\UnmetDependenciesException
Summary: www-apps/drupal-8.0.0_rc4 - Drupal\Core\Config\UnmetDependenciesException
Status: RESOLVED DUPLICATE of bug 566052
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL: https://www.drupal.org/node/2501851
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-15 17:38 UTC by Dennis Schridde
Modified: 2015-11-20 12:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2015-11-15 17:38:39 UTC
The following error message was generated by Drupal 8.0.0_rc4, but the very same also happens with RC1.

I installed Drupal using webapp-config (but did not copy the services.yml file as mentioned in the post-install documentation, because the /sites/default directory is writable by the webserver and the file is not described in the official Drupal installation documentation) and then went to the site mentioned in the post-install documentation. I entered the DB username/password and was greeted with this error message:
```
An AJAX HTTP error occurred.
HTTP Result Code: 200
Debugging information follows.
Path: ${INSTALL_LOCATION}/core/install.php?langcode=en&profile=standard&id=1&op=do_nojs&op=do
StatusText: OK
ResponseText: 
Deprecated:  Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
Warning:  Cannot modify header information - headers already sent in Unknown on line 0
RuntimeException: Failed to start the session because headers have already been sent by "" at line 0. in Symfony\Component\HttpFoundation\Session\Storage\NativeSessionStorage->start() (line 144 of ${DOCUMENT_ROOT}/d8/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php).
```

The "error page" linked to contained this:
```
Drupal\Core\Config\UnmetDependenciesException: Configuration objects (block.block.bartik_account_menu, block.block.bartik_branding, block.block.bartik_breadcrumbs, block.block.bartik_content, block.block.bartik_footer, block.block.bartik_help, block.block.bartik_local_actions, block.block.bartik_local_tasks, block.block.bartik_main_menu, block.block.bartik_messages, block.block.bartik_page_title, block.block.bartik_powered, block.block.bartik_search, block.block.bartik_tools, block.block.seven_breadcrumbs, block.block.seven_content, block.block.seven_help, block.block.seven_local_actions, block.block.seven_login, block.block.seven_messages, block.block.seven_page_title, block.block.seven_primary_local_tasks, block.block.seven_secondary_local_tasks, block_content.type.basic, comment.type.comment, contact.form.feedback, core.entity_form_display.block_content.basic.default, core.entity_form_display.comment.comment.default, core.entity_form_display.node.article.default, core.entity_form_display.node.page.default, core.entity_form_display.user.user.default, core.entity_view_display.block_content.basic.default, core.entity_view_display.comment.comment.default, core.entity_view_display.node.article.default, core.entity_view_display.node.article.rss, core.entity_view_display.node.article.teaser, core.entity_view_display.node.page.default, core.entity_view_display.node.page.teaser, core.entity_view_display.user.user.compact, core.entity_view_display.user.user.default, editor.editor.basic_html, editor.editor.full_html, field.field.block_content.basic.body, field.field.comment.comment.comment_body, field.field.node.article.body, field.field.node.article.comment, field.field.node.article.field_image, field.field.node.article.field_tags, field.field.node.page.body, field.field.user.user.user_picture, field.storage.node.comment, field.storage.node.field_image, field.storage.node.field_tags, field.storage.user.user_picture, filter.format.basic_html, filter.format.full_html, filter.format.restricted_html, node.type.article, node.type.page, rdf.mapping.comment.comment, rdf.mapping.node.article, rdf.mapping.node.page, rdf.mapping.taxonomy_term.tags, taxonomy.vocabulary.tags) provided by standard have unmet dependencies in Drupal\Core\Config\UnmetDependenciesException::create() (line 89 of core/lib/Drupal/Core/Config/UnmetDependenciesException.php).

Drupal\Core\Config\UnmetDependenciesException::create('standard', Array)
Drupal\Core\Config\ConfigInstaller->checkConfigurationToInstall('module', 'standard')
Drupal\Core\ProxyClass\Config\ConfigInstaller->checkConfigurationToInstall('module', 'standard')
Drupal\Core\Extension\ModuleInstaller->install(Array, )
Drupal\Core\ProxyClass\Extension\ModuleInstaller->install(Array, )
install_install_profile(Array)
install_run_task(Array, Array)
install_run_tasks(Array)
install_drupal(Object)
```

# ROOT=... emerge --info drupal php                                                                                                                                                                          
Portage 2.2.20.1 (python 2.7.10-final-0, hardened/linux/amd64/selinux, gcc-4.8.5, glibc-2.21-r1, 4.1.4-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.1.4-hardened-x86_64-AMD_Athlon-tm-_64_Processor_3700+-with-gentoo-2.2
KiB Mem:     2046976 total,    320300 free
KiB Swap:    4194300 total,   4093164 free
Timestamp of repository gentoo: Sun, 15 Nov 2015 05:15:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p39::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10::gentoo, 3.4.3::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /var/cache/portage/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage
    priority: -1000

local
    location: /var/cache/portage/local
    masters: gentoo local

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -mtune=generic -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-pipe -mtune=generic -O2"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --nospinner --usepkg --buildpkg --binpkg-respect-use --binpkg-changed-deps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j2"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 audit berkdb bzip2 caps cli cracklib crypt cxx dri gdbm gpg hardened iconv ipv6 jit justify luajit lz4 lzma lzo mmx mmxext modules multilib ncurses nls nptl open_perms openmp pam pax_kernel pcre pie readline sctp seccomp selinux session sse sse2 ssl ssp systemd tcpd udev unconfined unicode urandom vhosts xattr xtpax xz zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext sse sse2 sse3" DRACUT_MODULES="lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

www-apps/drupal-8.0.0_rc1::gentoo was built with the following:
USE="accelerator mysql vhosts -postgres -sqlite -uploadprogress" ABI_X86="64"


www-apps/drupal-8.0.0_rc4::local was built with the following:
USE="accelerator mysql vhosts -postgres -sqlite -uploadprogress" ABI_X86="64"


dev-lang/php-5.6.14::gentoo was built with the following:
USE="bcmath berkdb bzip2 cgi cli crypt ctype curl exif fileinfo filter fpm ftp gd gdbm hash iconv imap intl ipv6 json kerberos ldap mysql mysqli nls opcache pdo phar posix readline (selinux) session simplexml snmp sockets sqlite ssl systemd threads tokenizer unicode xml xmlrpc xmlwriter zip zlib -apache2 -calendar -cdb -cjk -debug -embed -enchant (-firebird) -flatfile (-frontbase) -gmp -inifile -iodbc -ldap-sasl -libedit -libmysqlclient -mhash -mssql -oci8-instant-client -odbc -pcntl -postgres -qdbm -recode -sharedmem -soap -spell -sybase-ct -sysvipc -tidy -truetype -vpx -wddx -xmlreader -xpm -xslt" ABI_X86="64"
Comment 1 Dennis Schridde 2015-11-15 19:49:01 UTC
Upstream "issue": https://www.drupal.org/node/2501851
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2015-11-17 10:31:53 UTC
I've had a few issues with the 8.0 series on install and mostly on update, but I've never hit this issue.
I see from the upstream bug report that you've been able get it working for you.
What was the issue?
Comment 3 Dennis Schridde 2015-11-20 12:24:22 UTC
(In reply to Jorge Manuel B. S. Vicetto from comment #2)
> I've had a few issues with the 8.0 series on install and mostly on update,
> but I've never hit this issue.
> I see from the upstream bug report that you've been able get it working for
> you.
> What was the issue?

The issue was that `always_populate_raw_post_data` needs to be set to -1 in php.ini [1,2]. If one uses Apache + mod_php, the included .htaccess files would do that automatically (if such overrides are allowed in the server config).

I am using Lighttpd + PHP-FPM, however, so neither were the .htaccess files interpreted (Lighttpd), nor would they have had any effect (PHP-FPM). I needed to set the variable manually.

While doing that, I also ported (parts of) the rest of the .htaccess file, because Drupal would e.g. refuse to work without URL rewriting.

[1]: https://www.drupal.org/node/2456025
[2]: https://www.drupal.org/node/2485847
Comment 4 Dennis Schridde 2015-11-20 12:25:17 UTC
The solution is described in bug #566052.

*** This bug has been marked as a duplicate of bug 566052 ***