Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 558228 - media-plugins/audacious-plugins-3.6.2-r1 - gl-spectrum.cc:176:23: error: 'glColor3f' was not declared in this scope
Summary: media-plugins/audacious-plugins-3.6.2-r1 - gl-spectrum.cc:176:23: error: 'glC...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
: 566454 (view as bug list)
Depends on:
Blocks: 561242
  Show dependency tree
 
Reported: 2015-08-20 08:32 UTC by jannis
Modified: 2017-12-24 21:52 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (einfo,24.85 KB, text/plain)
2015-08-20 08:32 UTC, jannis
Details
build.log (build.log,54.10 KB, text/plain)
2015-08-20 08:33 UTC, jannis
Details
media-plugins:audacious-plugins-3.7.1-r1:20170513-095935.log (media-plugins:audacious-plugins-3.7.1-r1:20170513-095935.log,60.78 KB, text/plain)
2017-05-13 10:30 UTC, Jeroen Roovers (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2015-08-20 08:32:24 UTC
media-plugins/audacious-plugins-3.6.2-r1 fails to compile. See attached build.log and emerge --info

Reproducible: Always
Comment 1 jannis 2015-08-20 08:32:48 UTC
Created attachment 409540 [details]
emerge --info
Comment 2 jannis 2015-08-20 08:33:17 UTC
Created attachment 409542 [details]
build.log
Comment 3 Attila Tóth 2015-08-27 12:01:26 UTC
I confim this bug.
I'd like to add, that it only occurs with USE qt5 - the use flag activates some opengl code.
Comment 4 jannis 2015-08-27 21:11:02 UTC
(In reply to Attila Tóth from comment #3)
> I confim this bug.
> I'd like to add, that it only occurs with USE qt5 - the use flag activates
> some opengl code.

What are your USE-flags on Qt5's qtgui, qtwidgets and qtopengl? I had +gles2 there but removed it due to #558356. It seems to be the same here since now it emerges fine on my system.
Comment 5 Tony Vroon gentoo-dev 2015-08-28 08:09:35 UTC
(In reply to jannis from comment #4)
> What are your USE-flags on Qt5's qtgui, qtwidgets and qtopengl? I had +gles2
> there but removed it due to #558356. It seems to be the same here since now
> it emerges fine on my system.

So it is not a missing dependency on dev-qt/qtopengl but something more subtle? Can you express that as a DEPEND string please?
Comment 6 Attila Tóth 2015-08-28 11:34:49 UTC
(In reply to jannis from comment #4)
> (In reply to Attila Tóth from comment #3)
> > I confim this bug.
> > I'd like to add, that it only occurs with USE qt5 - the use flag activates
> > some opengl code.
> 
> What are your USE-flags on Qt5's qtgui, qtwidgets and qtopengl? I had +gles2
> there but removed it due to #558356. It seems to be the same here since now
> it emerges fine on my system.

Thanks for the dime.
You are right about I have gles2 enabled in qtgui and related other packages. Currently I'm struggling with kde4 vs kde5 blockers and haven't reached the point to hit #558356. There have been some problems with gles2 before and inconclusive information can be gathered about its status in various projects. I go on and try to disable gles2, and sort my kde blockers out. I retry enabling qt5 for audacious-plugins later.
Comment 7 jannis 2015-08-28 14:54:08 UTC
(In reply to Tony Vroon from comment #5)
> (In reply to jannis from comment #4)
> > What are your USE-flags on Qt5's qtgui, qtwidgets and qtopengl? I had +gles2
> > there but removed it due to #558356. It seems to be the same here since now
> > it emerges fine on my system.
> 
> So it is not a missing dependency on dev-qt/qtopengl but something more
> subtle? Can you express that as a DEPEND string please?

Should be something like "qt5? ( dev-qt/qtgui:5[-gles2] )"
Comment 8 Attila Tóth 2015-08-28 22:45:29 UTC
(In reply to jannis from comment #4)
> (In reply to Attila Tóth from comment #3)
> > I confim this bug.
> > I'd like to add, that it only occurs with USE qt5 - the use flag activates
> > some opengl code.
> 
> What are your USE-flags on Qt5's qtgui, qtwidgets and qtopengl? I had +gles2
> there but removed it due to #558356. It seems to be the same here since now
> it emerges fine on my system.

I'd like to confirm, that by disabling USE gles2 for qtgui and related packages, I could successfully emerge audacious-plugins with USE qt5.
Comment 9 wjn 2015-11-08 12:39:18 UTC
 I met the same trouble.
I patched like below, compiling became to success.

--- src/gl-spectrum-qt/gl-spectrum.cc.orig	2015-11-08 20:23:48.365692141 +0900
+++ src/gl-spectrum-qt/gl-spectrum.cc	2015-11-08 20:24:56.260684278 +0900
@@ -32,6 +32,9 @@
 #include <QGLWidget>
 #include <QGLFunctions>
 
+#include <GL/glu.h>
+#include <GL/glut.h>
+
 #define NUM_BANDS 32
 #define DB_RANGE 40
Comment 10 Tony Vroon gentoo-dev 2015-11-23 17:57:05 UTC
*** Bug 566454 has been marked as a duplicate of this bug. ***
Comment 11 Paolo Pedroni 2016-01-19 14:18:27 UTC
(In reply to wjn from comment #9)
>  I met the same trouble.
> I patched like below, compiling became to success.
> 
> --- src/gl-spectrum-qt/gl-spectrum.cc.orig	2015-11-08 20:23:48.365692141
> +0900
> +++ src/gl-spectrum-qt/gl-spectrum.cc	2015-11-08 20:24:56.260684278 +0900
> @@ -32,6 +32,9 @@
>  #include <QGLWidget>
>  #include <QGLFunctions>
>  
> +#include <GL/glu.h>
> +#include <GL/glut.h>
> +
>  #define NUM_BANDS 32
>  #define DB_RANGE 40

This patch fixes compilation of audacious-plugins-3.7.1 for me.

+1 ;-)
Comment 12 Nuno Alexandre 2016-12-16 21:08:14 UTC
Filed a pull request here:
https://github.com/gentoo/gentoo/pull/3011

Also fixes the jack-ng issue with gcc-5.x
Comment 13 Jeroen Roovers (RETIRED) gentoo-dev 2017-05-13 10:30:11 UTC
Created attachment 472488 [details]
media-plugins:audacious-plugins-3.7.1-r1:20170513-095935.log

[ebuild  N    ~] media-plugins/audacious-plugins-3.7.1-r1::gentoo  USE="adplug alsa ffmpeg mp3 nls qt5 sid vorbis -aac -bs2b -cdda -cue -flac -fluidsynth (-gnome) -gtk -gtk3 -http -jack -lame (-libnotify) -libsamplerate (-lirc) -mms -pulseaudio -scrobbler -sdl -sndfile -wavpack" 0 KiB
Comment 14 Larry the Git Cow gentoo-dev 2017-12-24 21:52:23 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bf878c27023b60b95dc0ed7fbece859ea3b385e7

commit bf878c27023b60b95dc0ed7fbece859ea3b385e7
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2017-12-24 21:43:10 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2017-12-24 21:52:03 +0000

    media-plugins/audacious-plugins: Remove old
    
    Closes: https://bugs.gentoo.org/558228
    Closes: https://bugs.gentoo.org/562094
    Closes: https://bugs.gentoo.org/564498
    Closes: https://bugs.gentoo.org/584392
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 media-plugins/audacious-plugins/Manifest           |   6 -
 .../audacious-plugins-3.6.2-r1.ebuild              | 133 ----------------
 .../audacious-plugins-3.7.1-r1.ebuild              | 173 --------------------
 .../audacious-plugins-3.7.1.ebuild                 | 152 ------------------
 .../audacious-plugins-3.8.2.ebuild                 | 175 ---------------------
 .../files/audacious-plugins-3.7.1-gl-jack.patch    |  24 ---
 profiles/package.mask                              |   1 -
 7 files changed, 664 deletions(-)