Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 554032 - sys-devel/crossdev: add musl support to config.site
Summary: sys-devel/crossdev: add musl support to config.site
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: musl-porting 553988
  Show dependency tree
 
Reported: 2015-07-05 18:05 UTC by A. Wilcox (awilfox)
Modified: 2016-06-02 15:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Add musl libc support to config.site. (0001-Add-musl-libc-support-to-config.site.patch,898 bytes, patch)
2015-07-05 18:05 UTC, A. Wilcox (awilfox)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description A. Wilcox (awilfox) 2015-07-05 18:05:28 UTC
The attached patch adds musl support to config.site.

I enjoy playing around with porting and running Gentoo on various bits of hardware I have around the house.  Some of these machines relics (old Pentium i586), some of them are very powerful (quad-core ARM, dual PPC G4, dual-core MIPS).  I have been toying with using the musl libc on the older machines.  However, I need a separate config.site for musl as it has some pretty wild differences compared to glibc and putting them in the default 'linux' file doesn't make much sense.

As I pin down further what are red herrings and what are actually necessary, I may follow this up with another patch adding my linux-musl and i386-linux-musl files.

Reproducible: Always

Steps to Reproduce:
1. # crossdev powerpc-apple-linux-gnu 
2. # crossdev i586-pc-linux-musl
3. Try to emerge, say, sed on the musl one (or almost half of @system).  It needs ac_use_included_regex=yes in the autoconf site include.  But glibc does not need it.

Actual Results:  
Packages such as procps, sed, coreutils won't merge on musl due to needing specific definitions in the autoconf site include.

Expected Results:  
The ability to merge @system.
Comment 1 A. Wilcox (awilfox) 2015-07-05 18:05:47 UTC
Created attachment 406212 [details, diff]
Add musl libc support to config.site.