Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 553988 - sys-devel/crossdev: gl_cv_func_re_compile_pattern_working=yes in config.site is wrong for musl C library
Summary: sys-devel/crossdev: gl_cv_func_re_compile_pattern_working=yes in config.site ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on: 554032
Blocks: crossdev-bugs
  Show dependency tree
 
Reported: 2015-07-05 15:14 UTC by Felix Janda
Modified: 2018-01-06 18:07 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Janda 2015-07-05 15:14:46 UTC
sys-apps/coreutils does not cross-emerge on musl profiles because
working re_compile_pattern support is falsely detected,
re_compile_pattern is declared in none of musl's headers and therefore
compilation later fails on src/csplit.c. The wrong detection is due to
a gl_cv_func_re_compile_pattern_working=yes in
/usr/share/crossdev/include/site/linux , which is included by
/usr/share/config.site.


Reproducible: Always




Please remove gl_cv_func_re_compile_pattern_working=yes from
/usr/share/crossdev/include/site/linux . This avoids wrong detection
of re_compile_pattern at the cost of coreutils possibly unnecessarily
including regex compability code.
Comment 1 Felix Janda 2017-12-31 11:48:59 UTC
Moving gl_cv_func_re_compile_pattern_working=yes from site/linux to
site/linux-gnu. (This makes sense because re_compile_pattern is
part of the GNU regex functions.)


In the other direction, I would like to request
bash_cv_job_control_missing=present to be moved from site/linux-gnu
to site/linux. bash without job control is pretty broken.
Comment 2 Larry the Git Cow gentoo-dev 2017-12-31 13:50:52 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/crossdev.git/commit/?id=3d324730ce8cb004f74ba38b2d5acf70dfbeff77

commit 3d324730ce8cb004f74ba38b2d5acf70dfbeff77
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2017-12-31 13:49:17 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2017-12-31 13:49:17 +0000

    site/linux: move bash_cv_job_control_missing=present from linux-gnu
    
    glibc, musl, uclibc and uclibc-ng all define needed signals
    and syscalls needed for job control.
    
    Reported-by: Felix Janda
    Bug: https://bugs.gentoo.org/553988
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 wrappers/site/linux     | 3 +++
 wrappers/site/linux-gnu | 1 -
 2 files changed, 3 insertions(+), 1 deletion(-)

https://gitweb.gentoo.org/proj/crossdev.git/commit/?id=83bad0ad7e2f38025749cfe6f469619e4f62bf63

commit 83bad0ad7e2f38025749cfe6f469619e4f62bf63
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2017-12-31 13:38:19 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2017-12-31 13:38:19 +0000

    sire/linux: remove gl_cv_func_re_compile_pattern_working=yes from musl
    
    re_compile_pattern is present in glibc, uclibc, uclibc-ng, but not musl
    
    Reported-by: Felix Janda
    Bug: https://bugs.gentoo.org/553988
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 wrappers/site/linux        | 1 -
 wrappers/site/linux-gnu    | 5 +++++
 wrappers/site/linux-uclibc | 5 +++++
 3 files changed, 10 insertions(+), 1 deletion(-)}
Comment 3 Sergei Trofimovich (RETIRED) gentoo-dev 2017-12-31 13:52:34 UTC
(In reply to Felix Janda from comment #1)
> Moving gl_cv_func_re_compile_pattern_working=yes from site/linux to
> site/linux-gnu. (This makes sense because re_compile_pattern is
> part of the GNU regex functions.)
> 
> 
> In the other direction, I would like to request
> bash_cv_job_control_missing=present to be moved from site/linux-gnu
> to site/linux. bash without job control is pretty broken.

Makes sense! Thank you!

re_compile_pattern() seems to be present in both glibc and uclibc. I've pushed it to both.

Pushed both commits to =sys-devel/crossdev-99999999. Will close the bug when new crossdev release is cut.
Comment 4 Larry the Git Cow gentoo-dev 2018-01-06 18:07:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fa9f067257d25779630a5818d8fc3702eaf90e62

commit fa9f067257d25779630a5818d8fc3702eaf90e62
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-01-06 18:07:33 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-01-06 18:07:43 +0000

    sys-devel/crossdev: bump up to 20180105
    
    Closes: https://bugs.gentoo.org/643162
    Closes: https://bugs.gentoo.org/553988
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 sys-devel/crossdev/Manifest                 |  1 +
 sys-devel/crossdev/crossdev-20180105.ebuild | 35 +++++++++++++++++++++++++++++
 2 files changed, 36 insertions(+)