Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 553596 - dev-ml/parmap-1.0_rc6 build failure during install phase
Summary: dev-ml/parmap-1.0_rc6 build failure during install phase
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Team for the ML programming language family
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2015-06-29 20:59 UTC by Rémi Cardona
Modified: 2015-07-14 08:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.31 KB, text/plain)
2015-07-03 05:47 UTC, Rémi Cardona
Details
files/parmap-1.0_rc6-fix-bashisms.patch (parmap-1.0_rc6-fix-bashisms.patch,432 bytes, patch)
2015-07-12 22:00 UTC, Rémi Cardona
Details | Diff
parmap-1.0_rc6.ebuild.patch (parmap-1.0_rc6.ebuild.patch,882 bytes, patch)
2015-07-12 22:04 UTC, Rémi Cardona
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2015-06-29 20:59:07 UTC
>>> Source compiled.
>>> Test phase [not enabled]: dev-ml/parmap-1.0_rc6

>>> Install parmap-1.0_rc6 into /var/tmp/portage/dev-ml/parmap-1.0_rc6/image/ category dev-ml
make -j4 OCAMLLIBDIR=lib64/ocaml MANDIR=/var/tmp/portage/dev-ml/parmap-1.0_rc6/image//usr/share/man/man3o DESTDIR=/var/tmp/portage/dev-ml/parmap-1.0_rc6/image//usr install 
ocamlfind ocamlopt -shared -o parmap.cmxs bytearray_stubs.o setcore_stubs.o bytearray.cmx parmap_utils.cmx parmap.cmx
ocamlfind remove parmap
 * ACCESS DENIED:  unlink:       /usr/lib64/ocaml/stublibs/dllparmap_stubs.so.owner
ocamlfind: /usr/lib64/ocaml/stublibs/dllparmap_stubs.so.owner: Permission denied
Makefile:34: recipe for target 'install' failed
make: *** [install] Error 2

Reproducible: Always
Comment 1 Alexis Ballier gentoo-dev 2015-06-30 10:00:25 UTC
please attach the full build log; nothing in the makefile shows that 'install' should call 'uninstall' first :/ (which is what is happening here)
Comment 2 Rémi Cardona gentoo-dev 2015-07-03 05:47:28 UTC
Created attachment 406102 [details]
build.log
Comment 3 Rémi Cardona gentoo-dev 2015-07-03 05:49:31 UTC
I have also tried rebuilding the few ocaml libs and programs I have with USE=-ocamlopt, but it still fails the same way.
Comment 4 Alexis Ballier gentoo-dev 2015-07-03 13:30:52 UTC
hmmm, can you try with /bin/sh as bash ?
Comment 5 Rémi Cardona gentoo-dev 2015-07-04 13:27:44 UTC
Good catch, I completely missed configure almost-failing-but-not-quite.

I tried fixing the obvious == into =, but it still fails elsewhere. Rerunning eautoreconf fails due to missing macros (notably AC_PROG_OCAML).

I guess the best fix is to call econf with CONFIG_SHELL=/bin/bash
Comment 6 Alexis Ballier gentoo-dev 2015-07-04 16:56:50 UTC
(In reply to Rémi Cardona from comment #5)
> I tried fixing the obvious == into =, but it still fails elsewhere.
> Rerunning eautoreconf fails due to missing macros (notably AC_PROG_OCAML).

this is dev-ml/ocaml-autoconf

> I guess the best fix is to call econf with CONFIG_SHELL=/bin/bash


yep could be the easiest thing to do, but if you/we have an upstreamable fix it's much better :)
Comment 7 Rémi Cardona gentoo-dev 2015-07-06 06:33:13 UTC
Ah! Thanks for the pointers, I'll take another swing at it then!
Comment 8 Rémi Cardona gentoo-dev 2015-07-12 22:00:57 UTC
Created attachment 406624 [details, diff]
files/parmap-1.0_rc6-fix-bashisms.patch

Here's the upstream patch. The "==" was fairly obvious, but it took me a bit longer to figure out that "&>" isn't kosher in POSIX. This seems to work ok with both bash and dash.
Comment 9 Rémi Cardona gentoo-dev 2015-07-12 22:04:11 UTC
Created attachment 406626 [details, diff]
parmap-1.0_rc6.ebuild.patch

And here's the ebuild patch. I'm not 100% confident about the autotools eclass part, I'm not quite sure about the WANT_* variables. Maybe you'll have a better clue.
Comment 10 Alexis Ballier gentoo-dev 2015-07-13 13:36:21 UTC
great, thanks; could you please send a pull request at https://github.com/rdicosmo/parmap ?

for WANT_* variables, they default to 'latest' which is the best choice; those variables are there when packages that require older versions and for which it is not easy to port them
Comment 11 Rémi Cardona gentoo-dev 2015-07-13 19:45:23 UTC
Damn! I thought I could weasel out of going to upstream with the patch! :p

Anyway: https://github.com/rdicosmo/parmap/pull/36

Cheers
Comment 12 Alexis Ballier gentoo-dev 2015-07-14 08:45:09 UTC
+  14 Jul 2015; Alexis Ballier <aballier@gentoo.org> parmap-1.0_rc6.ebuild,
+  +files/parmap-1.0_rc6-fix-bashisms.patch:
+  Fix bashisms in configure, bug #553596 by Rémi Cardona.
+


thanks a lot!