Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 548926 - games-rpg/eternal-lands version bump request
Summary: games-rpg/eternal-lands version bump request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Richard Freeman
URL:
Whiteboard:
Keywords: PullRequest
: 549794 (view as bug list)
Depends on:
Blocks: games.eclass
  Show dependency tree
 
Reported: 2015-05-08 17:26 UTC by Joan Ibanez
Modified: 2019-05-23 02:39 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
working eternal-lands-data ebuild (eternal-lands-data-1.9.4.ebuild,3.31 KB, text/plain)
2015-05-18 20:37 UTC, Richard Freeman
Details
patch for eternal-lands (eternal-lands-1.9.4-defaults.patch,9.96 KB, patch)
2015-05-18 20:37 UTC, Richard Freeman
Details | Diff
eternal-lands-data-1.9.4.ebuild (eternal-lands-data-1.9.4.ebuild,3.31 KB, text/plain)
2015-05-18 20:38 UTC, Richard Freeman
Details
eternal-lands-1.9.4-defaults.patch (eternal-lands-1.9.4-defaults.patch,9.96 KB, patch)
2015-05-18 20:38 UTC, Richard Freeman
Details | Diff
eternal-lands-1.9.4-glbuild.patch (eternal-lands-1.9.4-glbuild.patch,806 bytes, patch)
2015-05-18 20:39 UTC, Richard Freeman
Details | Diff
eternal-lands-1.9.4-makefile.patch (eternal-lands-1.9.4-makefile.patch,5.29 KB, patch)
2015-05-18 20:39 UTC, Richard Freeman
Details | Diff
eternal-lands-1.9.4.ebuild (eternal-lands-1.9.4.ebuild,3.02 KB, text/plain)
2015-05-18 20:40 UTC, Richard Freeman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joan Ibanez 2015-05-08 17:26:35 UTC
The eternal lands client and data needs to be upgraded to version 1.9.4.
Current portage version(1.9.3) cannot log into server anymore.
TIA.

Reproducible: Always
Comment 1 Richard Freeman gentoo-dev 2015-05-08 18:29:37 UTC
Thanks for the heads-up.  I don't see anyplace where the linux data files are offered in zip format.  The ebuild might need to be adjusted to use the Mac version.  Either that or I'll need to find a way to extract the linux Nixstaller script, preferably without running it.
Comment 2 Roman Gruber 2015-05-09 18:26:38 UTC
Mister burn, one of the moderators on this game compiles for opensuse the client from the git repository. => http://www.eternal-lands.com/forum/index.php?showtopic=59101

Therefore I highly recommned that gentoo also goes for the git way. 

http://www.eternal-lands.com/page/download.php
=> https://github.com/raduprv/Eternal-Lands
Comment 3 Richard Freeman gentoo-dev 2015-05-09 19:23:43 UTC
(In reply to Roman Gruber from comment #2)
> Mister burn, one of the moderators on this game compiles for opensuse the
> client from the git repository. 

Does the git repository contain all the data files, or just the game binary?

The license does not authorize redistribution of the data files as far as I can tell.  So, we can only use whatever they make available.
Comment 4 Roman Gruber 2015-05-18 08:31:27 UTC
I tried to build the client from git. It builds wiht current gcc 4.8.x

I got an error that the data path was missing and the configs.

Seems to be only the client. Somewhere there needs to be configured for data path and home directory => /home/$user/.elc

AFAIK client is open source! Burn the moderator of this game builds teh client for opensuse. So i highly doubt there are legal issues redistributing the client. you can see his screenshots on the offical forums on the links above i provided earlier.
Comment 5 Roman Gruber 2015-05-18 08:36:31 UTC
I asked the game owner on the offical forum, see

http://www.eternal-lands.com/forum/index.php?showtopic=59980

radu => entropy => game owner of eternal lands afaik.
Comment 6 Richard Freeman gentoo-dev 2015-05-18 12:37:57 UTC
(In reply to Roman Gruber from comment #5)
> I asked the game owner on the offical forum, see
> 
> http://www.eternal-lands.com/forum/index.php?showtopic=59980
> 
> radu => entropy => game owner of eternal lands afaik.

I'll go ahead and reply there, but the post may have made the issue moot (I have to examine the link when I get a chance to confirm).

First, there are no issues with redistributing the client.  That has always been open source.  I haven't tested building it, but I don't anticipate issues with that.  Gentoo redistributes the client already, and official policy would allow us to continue to do so.

The problem was with the game data, not the client.  Nothing in the license file permits redistribution of it.  If you feel that it does, please cite the specific language in the license which does so (and be careful to review the definitions section when you do (hint)).

In the past the solution was to build the client from source, and to install the data directly from the authors website without redistributing it (something Gentoo's PMs can handle, but most other distros cannot, because we separate the install script (ebuild) from the files to be installed (distfiles), and we control copyright on the ebuild).  However, there was no apparent version of the data files in zip/etc format being hosted with their switch to an installer.

If that forum post contains the proper data files and is legally hosted then I can update the ebuild to use it, and the change will be pretty transparent to users.  I'll try to take a look at it ASAP, as I realize you're all stuck without a client in the meantime, unless you install the blob yourselves.  

The forum post talks of issues with building without the data files installed - that shouldn't be a problem for us.  We split the data and client into separate packages already, so the former can be installed before we build the latter.
Comment 7 Richard Freeman gentoo-dev 2015-05-18 19:56:15 UTC
*** Bug 549794 has been marked as a duplicate of this bug. ***
Comment 8 Richard Freeman gentoo-dev 2015-05-18 20:37:17 UTC
Created attachment 403578 [details]
working eternal-lands-data ebuild
Comment 9 Richard Freeman gentoo-dev 2015-05-18 20:37:53 UTC
Created attachment 403580 [details, diff]
patch for eternal-lands
Comment 10 Richard Freeman gentoo-dev 2015-05-18 20:38:34 UTC
Created attachment 403582 [details]
eternal-lands-data-1.9.4.ebuild
Comment 11 Richard Freeman gentoo-dev 2015-05-18 20:38:56 UTC
Created attachment 403584 [details, diff]
eternal-lands-1.9.4-defaults.patch
Comment 12 Richard Freeman gentoo-dev 2015-05-18 20:39:10 UTC
Created attachment 403586 [details, diff]
eternal-lands-1.9.4-glbuild.patch
Comment 13 Richard Freeman gentoo-dev 2015-05-18 20:39:27 UTC
Created attachment 403588 [details, diff]
eternal-lands-1.9.4-makefile.patch
Comment 14 Richard Freeman gentoo-dev 2015-05-18 20:40:56 UTC
Created attachment 403590 [details]
eternal-lands-1.9.4.ebuild

I'm attaching a working eternal-lands-data ebuild, and a non-working eternal-lands ebuild.  I need to continue to fix the build system for eternal lands, find missing deps, etc.

If somebody does have the build system working on Gentoo that might be useful to know.
Comment 15 Jakub Klawiter 2015-06-21 15:40:40 UTC
it's not working but it is working… 

what i did:

1. # ebuild eternal-lands-1.9.4.ebuild compile
NOT WORKING

2. 
# cd /var/tmp/portage/games-rpg/eternal-lands-1.9.4/work/Eternal-Lands-1.9.4
# make -f Makefile.linux
# cd /var/tmp/portage/games-rpg/eternal-lands-1.9.4/
# chmod o+rx work

$ cd /var/tmp/portage/games-rpg/eternal-lands-1.9.4/work/Eternal-Lands-1.9.4
$ ./el

and now it is working!
Comment 16 Pacho Ramos gentoo-dev 2018-05-01 17:31:43 UTC
It seems current ebuilds rely on games group for autoupdating... even the data package that doesn't use games.eclass . I guess that will need to change when games.eclass is completely removed and games group not used for that purposes :/
Comment 17 Richard Freeman gentoo-dev 2019-04-19 18:04:49 UTC
I haven't used this software in ages, and I'm not sure what the current state of the software is in Gentoo.

I'm probably going to drop maintainership, but that would leave it solely in the games project and I'm not sure that anybody else is actually going to pick it up.

If somebody intends to maintain this, please feel free to replace me in metadata.  Failing that, if this still works and is in use please at least speak up.

If I don't get confirmation from some user that the package at least works, and nobody else steps up to maintain, then I'll probably mask this for removal to see if that gets any attention, and if not go ahead and remove so as to not create work for treecleaners.
Comment 18 Larry the Git Cow gentoo-dev 2019-04-24 12:29:12 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ea03f024868d1a33a24d19c742244127db781f9f

commit ea03f024868d1a33a24d19c742244127db781f9f
Author:     Richard Freeman <rich0@gentoo.org>
AuthorDate: 2019-04-24 12:24:38 +0000
Commit:     Richard Freeman <rich0@gentoo.org>
CommitDate: 2019-04-24 12:28:43 +0000

    games-rpg/eternal-lands: mask for removal with deps
    
    Bug: https://bugs.gentoo.org/548926
    Signed-off-by: Richard Freeman <rich0@gentoo.org>

 profiles/package.mask | 8 ++++++++
 1 file changed, 8 insertions(+)
Comment 19 Bernd 2019-04-24 20:30:45 UTC
(In reply to Richard Freeman from comment #17)
> If I don't get confirmation from some user that the package at least works,
> and nobody else steps up to maintain, then I'll probably mask this for
> removal to see if that gets any attention, and if not go ahead and remove so
> as to not create work for treecleaners.

Just read your post on gentoo-dev mailing list. I used to play and helped with the game about 10 years ago and lately tried to install the current ebuild again which didn't work out.

Checking the website, the game looks still active, with current version being 1.9.5.

I'd like to proxy-maintain the package as you have asked in your mailing and see if I can come up with a working ebuild again, as I definitely like to see the game stay in the tree.

Might take a little time though, as I'm busy with other things too.
Comment 20 Larry the Git Cow gentoo-dev 2019-05-23 02:29:16 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4db23dbb1a7127733ef0a4849824f133c58b8506

commit 4db23dbb1a7127733ef0a4849824f133c58b8506
Author:     Stefan Strogin <steils@gentoo.org>
AuthorDate: 2019-05-16 03:41:49 +0000
Commit:     Stefan Strogin <steils@gentoo.org>
CommitDate: 2019-05-23 02:27:36 +0000

    games-rpg/eternal-lands: bump version to 1.9.5.3
    
    No longer depends on games-rpg/eternal-lands-data.
    Provide a launcher that downloads game data into $HOME on the first
    start. It will make auto updates easier and not violating Gentoo
    policies.
    
    Closes: https://bugs.gentoo.org/548926
    Closes: https://bugs.gentoo.org/652690
    Closes: https://bugs.gentoo.org/672238
    Closes: https://github.com/gentoo/gentoo/pull/12014
    Package-Manager: Portage-2.3.66, Repoman-2.3.12
    Signed-off-by: Stefan Strogin <steils@gentoo.org>

 games-rpg/eternal-lands/Manifest                   |  1 +
 .../eternal-lands/eternal-lands-1.9.5.3.ebuild     | 76 ++++++++++++++++++
 games-rpg/eternal-lands/files/el-wrapper           | 53 +++++++++++++
 .../files/eternal-lands-1.9.5.3-build.patch        | 70 +++++++++++++++++
 .../files/eternal-lands-1.9.5.3-minizip.patch      | 90 ++++++++++++++++++++++
 5 files changed, 290 insertions(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=07cf2e3583f03a085553297181a42df39c427946

commit 07cf2e3583f03a085553297181a42df39c427946
Author:     Stefan Strogin <steils@gentoo.org>
AuthorDate: 2019-05-16 04:10:22 +0000
Commit:     Stefan Strogin <steils@gentoo.org>
CommitDate: 2019-05-23 02:28:02 +0000

    games-rpg/eternal-lands: remove rich0@ from maintainers
    
    Bug: https://bugs.gentoo.org/548926
    Package-Manager: Portage-2.3.66, Repoman-2.3.12
    Signed-off-by: Stefan Strogin <steils@gentoo.org>

 games-rpg/eternal-lands/metadata.xml | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1f69d223ede5fc43b5f73a61b192e1d1d67091fc

commit 1f69d223ede5fc43b5f73a61b192e1d1d67091fc
Author:     Stefan Strogin <steils@gentoo.org>
AuthorDate: 2019-05-16 04:00:11 +0000
Commit:     Stefan Strogin <steils@gentoo.org>
CommitDate: 2019-05-23 02:28:02 +0000

    package.mask: resurrect games-rpg/eternal-lands
    
    Revert ea03f024 "games-rpg/eternal-lands: mask for removal with deps"
    The package has been updated. The upstream is active.
    
    Bug: https://bugs.gentoo.org/548926
    Signed-off-by: Stefan Strogin <steils@gentoo.org>

 profiles/package.mask | 8 --------
 1 file changed, 8 deletions(-)
Comment 21 Stefan Strogin gentoo-dev 2019-05-23 02:39:51 UTC
Sorry for the delay.
Testing is appreciated. You can comment here if everything works for you (or does not).