Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 544038 - dev-java/concurrent-util: masked for removal
Summary: dev-java/concurrent-util: masked for removal
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Java team
URL:
Whiteboard: Removal on 21/03
Keywords: PMASKED
: 550138 (view as bug list)
Depends on: 546288 546496 546498 546500 546502 546504 546506
Blocks:
  Show dependency tree
 
Reported: 2015-03-21 17:44 UTC by William L. Thomson Jr.
Modified: 2016-03-03 13:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (build.log,3.67 KB, text/plain)
2015-05-18 08:52 UTC, stieizc.33
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William L. Thomson Jr. 2015-03-21 17:44:27 UTC
This package has been in the JDK since 1.5. There is no reason for this package to still exist. Upstream has been dead for a VERY long time because its in the JDK.

http://gee.cs.oswego.edu/dl/classes/EDU/oswego/cs/dl/util/concurrent/intro.html
Comment 1 William L. Thomson Jr. 2015-04-13 23:09:07 UTC
Added dependent bugs that will block this one, need to be resolved before this package can be removed.
Comment 2 stieizc.33 2015-05-18 08:52:47 UTC
Created attachment 403526 [details]
full build log
Comment 3 stieizc.33 2015-05-18 08:55:39 UTC
Hope you will resolve the bugs soon, cause it fails to build on my machine with jdk 1.8:
GENTOO_VM=oracle-jdk-bin-1.8  CLASSPATH="" JAVA_HOME="/opt/oracle-jdk-bin-1.8.0.45"
JAVACFLAGS="-source 1.2 -target 1.2" COMPILER="javac"

The error is:
compile:
    [javac] Compiling 92 source files to /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build/classes
    [javac] /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/src/java/EDU/oswego/cs/dl/util/concurrent/ConcurrentHashMap.java:678: error: remove(Object,Object) in ConcurrentHashMap cannot implement remove(Object,Object) in Map
    [javac]   protected Object remove(Object key, Object value) {
    [javac]                    ^
    [javac]   attempting to assign weaker access privileges; was public
    [javac] 1 error

Let me know if you need more information
Comment 4 Patrice Clement gentoo-dev 2015-05-18 09:14:44 UTC
There's nothing for you to do. This package is in the process of being removed. So grin and bear it for the time being.
Comment 5 Patrice Clement gentoo-dev 2015-05-27 07:55:15 UTC
*** Bug 550138 has been marked as a duplicate of this bug. ***
Comment 6 John L. Poole 2015-06-01 14:08:37 UTC
I tried to install netbeans which requires about 122 packages including dev-java/concurrent-util-1.3.4-r1.  My attempt to install netbeans is blocked unless someone can suggest a work-around.

It's not that I like java, but I have a complicated open source project that is regrettably netbeans-based.
Comment 7 Patrice Clement gentoo-dev 2015-06-01 14:26:13 UTC
Hi John

Which version of netbeans are you trying to emerge? We have netbeans-8.0.2 in the tree and it has been marked stable a couple of weeks ago.

If it helps, consider downgrading your JDK to version 1.7 before emerging netbeans (and this package) and switching it back to 1.8 once you're done.
Comment 8 John L. Poole 2015-06-01 14:52:00 UTC
Hi Patrick,

Thank you for the rapid response.  Update -  I'm not prevented from work, the netbeans project can compile and run from the command line.  So, netbeans becomes a nice-to-have, but not critical.

Here's what I was atempting to emerge:
[ebuild  N     ] dev-util/netbeans-8.0.2  USE="-doc" LINGUAS="-af -ar -bg -ca -cs -de -el -es -fr -gl -hi_IN -id -it -ja -ko -lt -nl -pl -pt_BR -pt_PT -ro -ru -si -sq -sr -sv -ta_IN -tl -tr -vi -zh_CN -zh_TW" NETBEANS_MODULES="apisupport java javafx profiler websvccommon -cnd -dlight -enterprise -ergonomics -extide -groovy -javacard -mobility -php -webcommon" 

No rush on part, the unfortunate part about development environments such as net beans is that they dull the ability to be versatile.  Let me know if you need any files and/or output.
Comment 9 James Le Cuirot gentoo-dev 2015-06-01 15:19:30 UTC
I'm a little confused because even when passing -e to emerge, I cannot see concurrent-util anywhere in the dependency list. Please post the full output of emerge -pt netbeans.
Comment 10 James Le Cuirot gentoo-dev 2015-06-01 15:49:34 UTC
Never mind, reran it on my stable system and now I see it. So basically some stuff needs to be stabilised to close this out. I'm trying to leave this stuff to the others because I've enough to deal with already but I'll see if there's a quick way out of this.
Comment 11 Toralf Förster gentoo-dev 2015-08-07 17:56:13 UTC
 * Package:    dev-java/concurrent-util-1.3.4-r1
 * Repository: gentoo
 * Maintainer: java@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
 * Using: oracle-jdk-bin-1.8
>>> Unpacking source...
>>> Unpacking gentoo-concurrent-util-1.3.4.tar.bz2 to /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work
>>> Source unpacked in /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work
>>> Compiling source in /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4 ...
Rewriting attributes
Rewriting ./build.xml
 * Disabling all optional ANT_TASKS
Buildfile: /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build.xml

init:
    [mkdir] Created dir: /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build
    [mkdir] Created dir: /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build/classes
    [mkdir] Created dir: /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build/demo
    [mkdir] Created dir: /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build/javadoc
    [mkdir] Created dir: /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build/lib

compile:
    [javac] Compiling 92 source files to /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build/classes
    [javac] /var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/src/java/EDU/oswego/cs/dl/util/concurrent/ConcurrentHashMap.java:678: error: remove(Object,Object) in ConcurrentHashMap cannot implement remove(Object,Object) in Map
    [javac]   protected Object remove(Object key, Object value) {
    [javac]                    ^
    [javac]   attempting to assign weaker access privileges; was public
    [javac] 1 error

BUILD FAILED
/var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4/build.xml:25: Compile failed; see the compiler error output for details.

Total time: 2 seconds
 * ERROR: dev-java/concurrent-util-1.3.4-r1::gentoo failed (compile phase):
 *   eant failed
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 3934:  Called java-pkg-2_src_compile
 *   environment, line 1860:  Called eant 'jar' '-f' 'build.xml'
 *   environment, line  652:  Called die
 * The specific snippet of code:
 *       ant ${antflags} "${@}" || die "eant failed"
 * 
 * If you need support, post the output of `emerge --info '=dev-java/concurrent-util-1.3.4-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-java/concurrent-util-1.3.4-r1::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=oracle-jdk-bin-1.8  CLASSPATH="" JAVA_HOME="/opt/oracle-jdk-bin-1.8.0.51"
JAVACFLAGS="-source 1.2 -target 1.2" COMPILER="javac"
and of course, the output of emerge --info =concurrent-util-1.3.4
 * The complete build log is located at '/var/log/portage/dev-java:concurrent-util-1.3.4-r1:20150807-161256.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4'
 * S: '/var/tmp/portage/dev-java/concurrent-util-1.3.4-r1/work/concurrent-util-1.3.4'

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-gnome-unstable_20150731-133239) at a hardened host acting as a tinderbox.

Portage 2.2.20 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/gnome, gcc-4.9.3, glibc-2.21-r1, 4.0.8-hardened x86_64)
=================================================================
System uname: Linux-4.0.8-hardened-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16164692 total,   1337640 free
Comment 12 Patrice Clement gentoo-dev 2015-10-18 16:33:44 UTC
monsieurp@epsilon ~/gentoo/dev-java/ehcache $ grep SLOT *.ebuild
ehcache-1.1-r1.ebuild:SLOT="0"
ehcache-1.1-r2.ebuild:SLOT="0"
ehcache-1.2.4-r3.ebuild:SLOT="1.2"
ehcache-1.2.4-r4.ebuild:SLOT="1.2"
monsieurp@epsilon ~/gentoo/dev-java/ehcache $ grep concurrent-util *.ebuild
ehcache-1.1-r1.ebuild:          dev-java/concurrent-util
ehcache-1.1-r2.ebuild:          dev-java/concurrent-util:0
ehcache-1.1-r2.ebuild:JAVA_GENTOO_CLASSPATH="commons-collections,concurrent-util,commons-logging"

[13:05:29] [ monsieurp ] !rdep dev-java/concurrent-util
[13:05:30] [ willikins ] Reverse RDEPEND for dev-java/concurrent-util: dev-java/colt-1.2.0-r2 dev-java/ehcache-1.1-r1 dev-java/ehcache-1.1-r2 dev-java/fec-1.0.4-r1

[18:29:08] [ monsieurp ] !rdep dev-java/ehcache
[18:29:10] [ willikins ] Reverse RDEPEND for dev-java/ehcache: dev-java/hibernate-3.1.3-r5

monsieurp@epsilon ~/gentoo/dev-java/hibernate $ grep ehcache hibernate-3.1.3-r5.ebuild 
dev-java/ehcache:1.2
dom4j-1,ehcache-1.2,oscache,proxool,swarmcache-1.0

ehcache:0 is useless. Let's see it off:

commit 1b0b36b (HEAD, master)
Author: Patrice Clement <monsieurp@gentoo.org>
Date:   Sun Oct 18 16:31:32 2015 +0000

    dev-java/ehcache: Clean up SLOT:0 ebuilds as they're not used in the tree and rely on dev-java/conccurent-util. Fixes bug 544038.
    
    Package-Manager: portage-2.2.20.1
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 delete mode 100644 dev-java/ehcache/ehcache-1.1-r1.ebuild
 delete mode 100644 dev-java/ehcache/ehcache-1.1-r2.ebuild
Comment 13 Patrice Clement gentoo-dev 2015-10-18 16:36:26 UTC
I have stabilised colt in order to drop the version relying on concurrent-util:

* commit 89fa9f8
| Author: Patrice Clement <monsieurp@gentoo.org>
| Date:   Sun Oct 18 16:17:45 2015 +0000
|
|     dev-java/colt: Clean up old.
|
|     Package-Manager: portage-2.2.20.1
|     Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
|
|  delete mode 100644 dev-java/colt/colt-1.2.0-r2.ebuild
|
* commit c289243
| Author: Patrice Clement <monsieurp@gentoo.org>
| Date:   Sun Oct 18 16:17:24 2015 +0000
|
|     dev-java/colt: Stable for amd64. Stable for x86 using the ALLARCHES policy.
|
|     Package-Manager: portage-2.2.20.1
|     Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
|
|

At this point, we've only got dev-java/fec-1.0.4-r1 still needing this library. I'm waiting for a week then I'll stabilise fec-1.0.4-r2, remove -r1 and mask concurrent-util.
Comment 14 Patrice Clement gentoo-dev 2016-02-21 16:54:24 UTC
+# Patrice Clement <monsieurp@gentoo.org> (21 Feb 2016)
+# Part of the JDK since 1.5. No reason to exist anymore.
+# Removal in 30 days. See bug #544038.
+dev-java/concurrent-util
+
Comment 15 James Le Cuirot gentoo-dev 2016-03-03 13:19:14 UTC
It's gone.