Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 546288 - dev-java/aspectwerkz: masked for removal
Summary: dev-java/aspectwerkz: masked for removal
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on: 538862 551400 551524
Blocks: 203268 EAPI1Removal 544038
  Show dependency tree
 
Reported: 2015-04-11 21:00 UTC by Patrice Clement
Modified: 2015-07-15 11:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrice Clement gentoo-dev 2015-04-11 21:00:45 UTC
I will use this bug as a scratch pad for myself. 

dev-java/aspectwerkz has to go. Upstream is dead since 2005 and it hasn't been updated since. Further, it uses a very old EAPI so yet another reason to kill it without further ado. However, it as a revdep on dev-java/cglib:2.2

[18:29:28] [ +wltjr ] !rdep dev-java/aspectwerkz
[18:29:30] [  willikins ] wltjr: Reverse RDEPEND for dev-java/aspectwerkz: dev-java/cglib-2.0.2-r2 dev-java/cglib-2.1.3

So basically the goal here is:
- to get rid of dev-java/aspectwerkz
- while at it, remove old versions of dev-java/cglib:2.2 (they too have an old EAPI)
- .. which means we have to look up dev-java/cglib:2.2 reverse deps and bump them to cglib:3 (already stable), here's the list
 * These packages depend on dev-java/cglib-2.2:
dev-java/castor-0.9.9.1-r6 (dev-java/cglib:2)
dev-java/castor-1.1.1-r2 (=dev-java/cglib-2.1*)
dev-java/commons-digester-3.2 (dev-java/cglib:2.2)
dev-java/commons-pool-2.2 (dev-java/cglib:3)
dev-java/easymock-3.2-r1 (dev-java/cglib:2.2)
dev-java/guice-2.0 (dev-java/cglib:2.2)
dev-java/guice-3.0 (dev-java/cglib:2.2)
dev-java/hibernate-3.1.3-r3 (dev-java/cglib:2.2)
dev-java/jackson-databind-2.5.1 (test ? dev-java/cglib:2.2)
dev-java/jmock-1.1.0-r2 (=dev-java/cglib-2.0*)
dev-java/jmock-1.2.0 (dev-java/cglib:2.2)
dev-java/netbeans-java-7.2 (dev-java/cglib:2.2)
                           (dev-java/cglib:2.1)
dev-java/netbeans-java-8.0.2 (dev-java/cglib:2.2)
                             (dev-java/cglib:2.1)
dev-java/spin-1.5 (=dev-java/cglib-2.1*)
dev-java/spring-core-3.2.4 (dev-java/cglib:3)
dev-java/xstream-1.3.1-r1 (dev-java/cglib:2.2)

Not trivial but it's necessary to remove old cruft so that we have a consistent set of libraries (and up-to-date!) in the tree.


Reproducible: Always
Comment 1 James Le Cuirot gentoo-dev 2015-04-11 21:17:53 UTC
The good news is you can almost strike jackson-databind off that list. They updated to cglib-3 in 2.5.2 and then removed the dependency altogether in git master.
Comment 2 Patrice Clement gentoo-dev 2015-04-11 21:59:40 UTC
+*castor-0.9.9.1-r7 (11 Apr 2015)
+*castor-1.1.1-r3 (11 Apr 2015)
+
+  11 Apr 2015; Patrice Clement <monsieurp@gentoo.org> +castor-0.9.9.1-r7.ebuild,
+  +castor-1.1.1-r3.ebuild:
+  EAPI 5 bump and SLOT bump from dev-java/cglib:2.2 to :3 wrt bug 546288.
+
Comment 3 Patrice Clement gentoo-dev 2015-04-11 21:59:51 UTC
+*commons-digester-3.2-r1 (11 Apr 2015)
+
+  11 Apr 2015; Patrice Clement <monsieurp@gentoo.org>
+  +commons-digester-3.2-r1.ebuild, commons-digester-3.2.ebuild:
+  Bump SLOT dep dev-java/cglib:2.2 to :3 wrt bug 546288. Drop ppc ppc64 and
+  x86-fbsd keywords.
+
Comment 4 Patrice Clement gentoo-dev 2015-04-11 22:23:58 UTC
+*easymock-3.3.1 (11 Apr 2015)
+
+  11 Apr 2015; Patrice Clement <monsieurp@gentoo.org> +easymock-3.3.1.ebuild,
+  +files/3.3.1-no-android.patch, easymock-3.2-r1.ebuild:
+  Version bump and SLOT change wrt bug 546288.
+

Bumped easymock to its latest version while at it :)
Comment 5 Patrice Clement gentoo-dev 2015-04-11 22:26:08 UTC
+*guice-3.0-r1 (11 Apr 2015)
+*guice-2.0-r1 (11 Apr 2015)
+
+  11 Apr 2015; Patrice Clement <monsieurp@gentoo.org> +guice-2.0-r1.ebuild,
+  +guice-3.0-r1.ebuild, guice-2.0.ebuild:
+  SLOT bump wrt bug 546288.
+
Comment 6 Patrice Clement gentoo-dev 2015-04-11 22:59:08 UTC
jmock-1.x can go. I've filed bugs to stabilise version 2.x. We'll have to clean up its rev deps as well. I'll see about hibernate and netbeans (and maybe spring) on Monday (I have a VM at work) since they pull in a ton of deps.
Comment 7 Patrice Clement gentoo-dev 2015-04-14 19:50:54 UTC
+*spin-1.5-r1 (14 Apr 2015)
+
+  14 Apr 2015; Patrice Clement <monsieurp@gentoo.org> +spin-1.5-r1.ebuild:
+  SLOT bump wrt bug 546288. Drop ppc keywords.
+
Comment 8 Patrice Clement gentoo-dev 2015-04-14 20:14:06 UTC
+*xstream-1.3.1-r2 (14 Apr 2015)
+
+  14 Apr 2015; Patrice Clement <monsieurp@gentoo.org> +xstream-1.3.1-r2.ebuild:
+  SLOT and EAPI bump wrt bug 546288. Drop ppc and ppc64 keywords.
+
Comment 9 Patrice Clement gentoo-dev 2015-04-14 20:23:51 UTC
Packages left:
- dev-java/netbeans-java-7.2 (dev-java/cglib:2.2)
                           (dev-java/cglib:2.1)
- dev-java/netbeans-java-8.0.2 (dev-java/cglib:2.2)
                             (dev-java/cglib:2.1)
- dev-java/hibernate-3.1.3-r3 (dev-java/cglib:2.2)

These three are "fat" customers (they pull in over 80 packages). I'm emerging them in my VM right now. Watch this space.
Comment 10 Patrice Clement gentoo-dev 2015-04-17 08:47:43 UTC
+*hibernate-3.1.3-r4 (17 Apr 2015)
+
+  17 Apr 2015; Patrice Clement <monsieurp@gentoo.org>
+  +hibernate-3.1.3-r4.ebuild:
+  SLOT and EAPI bump wrt bug 546288.
+
Comment 11 Patrice Clement gentoo-dev 2015-04-17 10:03:03 UTC
fordfrog → gentoo-x86 (dev-java/netbeans-java/) dev-java/netbeans-java: changed dep to cglib:3

Thanks. I think we're good now.
Comment 12 Patrice Clement gentoo-dev 2015-04-17 10:04:09 UTC
Items left:

- File stabilisation bugs.
- Clean up cglib-2.x ebuilds.
- Last-rite aspectwerkz.
Comment 13 Miroslav Šulc gentoo-dev 2015-04-17 10:11:25 UTC
(In reply to Patrice Clement from comment #11)
> fordfrog → gentoo-x86 (dev-java/netbeans-java/) dev-java/netbeans-java:
> changed dep to cglib:3
> 
> Thanks. I think we're good now.

there's still netbeans-java-7.2 depending on cglib:2.1 and cglib:2.2 but i hope netbeans:8.0 gets stabilized soon including netbeans-java-8.0.2-r2 which contains the slot change. adding netbeans:8.0 stabilization bug as blocker.
Comment 14 Patrice Clement gentoo-dev 2015-06-14 15:17:47 UTC
# equery d -a dev-java/cglib
 * These packages depend on dev-java/cglib:
dev-java/castor-0.9.9.1-r7 (dev-java/cglib:3)
dev-java/castor-1.1.1-r3 (dev-java/cglib:3)
dev-java/commons-digester-3.2-r1 (dev-java/cglib:3)
dev-java/commons-pool-2.2 (dev-java/cglib:3)
dev-java/easymock-3.2-r1 (dev-java/cglib:3)
dev-java/easymock-3.3.1 (dev-java/cglib:3)
dev-java/guice-2.0-r1 (dev-java/cglib:3)
dev-java/guice-3.0-r1 (dev-java/cglib:3)
dev-java/hibernate-3.1.3-r4 (dev-java/cglib:3)
dev-java/jackson-databind-2.5.1 (test ? dev-java/cglib:2.2)
dev-java/jrobin-1.6.0-r1 (test ? >=dev-java/cglib-3.1:3)
dev-java/netbeans-java-8.0.2-r2 (dev-java/cglib:3)
dev-java/spin-1.5-r1 (dev-java/cglib:3)
dev-java/spring-core-3.2.4 (dev-java/cglib:3)
dev-java/xstream-1.3.1-r3 (dev-java/cglib:3)

I'm gonna go ahead and remove cglib:2.2. The only remaining dep is jackson-databind but looking at the ebuild, I can see they've been restricted so we're safe.
Comment 15 Patrice Clement gentoo-dev 2015-06-14 15:31:21 UTC
+*jackson-databind-2.5.1-r1 (14 Jun 2015)
+
+  14 Jun 2015; Patrice Clement <monsieurp@gentoo.org>
+  +jackson-databind-2.5.1-r1.ebuild, -jackson-databind-2.5.1.ebuild:
+  Update dependency on cglib from 2.2 to 3.
+

I doubled checked with dilfridge who told me to update the dep cause it might break the tree. Now we're good. :)
Comment 16 Patrice Clement gentoo-dev 2015-06-14 15:37:09 UTC
# equery d -a dev-java/aspectwerkz
 * These packages depend on dev-java/aspectwerkz:
dev-java/cglib-2.0.2-r2 (=dev-java/aspectwerkz-2*)
dev-java/cglib-2.1.3 (dev-java/aspectwerkz:2)

+  14 Jun 2015; Patrice Clement <monsieurp@gentoo.org> -cglib-2.0.2-r2.ebuild,
+  -cglib-2.1.3.ebuild, -cglib-2.2.3.ebuild, -cglib-2.2.ebuild:
+  Drop old.
+

Time to kiss aspectwerkz goodbye.
Comment 17 Patrice Clement gentoo-dev 2015-06-14 16:03:22 UTC
# Patrice Clement <monsieurp@gentoo.org> (14 Jun 2015)
# Upstream dead. No update since 2005.
# Masked for removal in 30 days.
dev-java/aspectwerkz

30 days timeout.
Comment 18 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-07-15 11:28:00 UTC
Removed.