Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 540114 - dev-libs/apr with non-bash shell - /usr/share/build-1/libtool: 1: eval: base_compile+= x86_64-pc-linux-gnu-gcc: not found
Summary: dev-libs/apr with non-bash shell - /usr/share/build-1/libtool: 1: eval: base_...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2015-02-15 06:42 UTC by Maciej Piechotka
Modified: 2015-10-17 14:44 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-admin:apache-tools-2.4.12:20150214-222314.log.gz (app-admin:apache-tools-2.4.12:20150214-222314.log.gz,11.85 KB, application/gzip)
2015-02-15 06:42 UTC, Maciej Piechotka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2015-02-15 06:42:38 UTC
Created attachment 396488 [details]
app-admin:apache-tools-2.4.12:20150214-222314.log.gz

Portage 2.2.17 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/gnome, gcc-4.9.2, glibc-2.20-r1, 3.17.0-pf4 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.17.0-pf4-x86_64-Intel-R-_Core-TM-_i7-3820QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    16051364 total,   2369756 free
KiB Swap:   20971484 total,  20836932 free
Timestamp of repository gentoo: Sat, 14 Feb 2015 20:15:01 +0000
sh dash 0.5.8.1
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p33-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.1-r4::gentoo
dev-lang/python:          2.7.9-r2::gentoo, 3.3.5-r1::gentoo, 3.4.2::gentoo
dev-util/cmake:           3.1.0::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.9::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo, 4.9.2::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.5::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.us.gentoo.org/gentoo-portage
    priority: -1000

bumblebee
    location: /var/lib/layman/bumblebee
    masters: gentoo
    priority: 50

gnome
    location: /var/lib/layman/gnome
    masters: gentoo
    priority: 50

haskell
    location: /var/lib/layman/haskell
    masters: gentoo
    priority: 50

rust
    location: /var/lib/layman/rust
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

vala
    location: /var/lib/layman/vala
    masters: gentoo gnome
    priority: 50

x11
    location: /var/lib/layman/x11
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -ggdb -Wa,--compress-debug-sections -fgcse-sm -fgcse-las -fgcse-after-reload -floop-block -floop-interchange -ftree-loop-distribution -floop-strip-mine"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -ggdb -Wa,--compress-debug-sections -fgcse-sm -fgcse-las -fgcse-after-reload -floop-block -floop-interchange -ftree-loop-distribution -floop-strip-mine"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="-j8 --load-average=7"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs clean-logs compress-build-logs compressdebug config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms split-elog splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.hoobly.com/ http://gentoo.mirrors.easynews.com/linux/gentoo/ http://gentoo.llarian.net/"
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=both -Wl,--sort-common -Wl,--no-keep-memory"
MAKEOPTS="-j4 -l7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes alsa amd64 avx berkdb bluetooth branding bzip2 bzr c++0x cairo caps cdda cdr cli clutter colord cracklib crypt cryptsetup cups cxx dbus dconf debugger device-mapper dri dri3 dts dvd dvdr eds egl emacs emboss encode evo exif fam ffmpeg firefox flac flash fontconfig fortran fprint fuse g3dvl gbm gdbm gdm gif git glamor gmp gnome gnome-keyring gnome-online-accounts gnuplot google gpm grilo gsettings gstreamer gtk gtk3 gtkstyle gui iconv inotify introspection iproute2 ipsec ipv6 ipython irc ithreads jabber jemalloc jit jpeg kerberos laptop latex lcms ldap libav libkms libnotify libproxy libsecret llvm lvm lzma mad map mercurial mmx mmxext mng modules mp3 mp4 mpeg multilib nautilus ncurses networking networkmanager nls nptl nsplugin nss ogg opencl opengl openmp oss pam pango parted pch pcre pdf perl pkcs11 plotutils png policykit popcnt ppds profiler pulseaudio python python3 qemu qt4 readline realtime rss samba scanner sdl session smartcard sna socialweb spell spice sqlite sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification steamruntime subversion svg symlink systemd tcpd telepathy theora threads tiff tracker truetype udev udisks unicode upnp upower usb v4l vaapi vala vdpau virt-network virtfs vorbis vpx webkit wxwidgets x264 xattr xcb xcomposite xinerama xml xrandr xv xvid zeitgeist zlib zsh-completion" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" DRACUT_MODULES="caps crypt lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="evdev synaptics mouse mutouch" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en pl en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python3_4 python3_3 python2_7 pypy" QEMU_SOFTMMU_TARGETS="arm x86_64 i386" QEMU_USER_TARGETS="arm x86_64 i386" RUBY_TARGETS="ruby20 ruby21 ruby22" SANE_BACKENDS="gt68xx" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3 3.4"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-admin/apache-tools-2.4.12::gentoo was built with the following:
USE="ssl" ABI_X86="64"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=both -Wl,--sort-common -Wl,--no-keep-memory -Wl,--no-as-needed"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2015-02-15 08:26:25 UTC
Please post your `emerge -vpq dev-libs/apr' output in a comment.
Comment 2 Maciej Piechotka 2015-02-15 10:13:52 UTC
(In reply to Jeroen Roovers from comment #1)
> Please post your `emerge -vpq dev-libs/apr' output in a comment.

[ebuild   R   ] dev-libs/apr-1.5.1-r1  USE="urandom -doc -older-kernels-compatibility -static-libs"
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2015-02-15 10:16:39 UTC
What I don't get is why it has the appropriate shebang pointing to /bin/bash, but *your* system manages to run that through /bin/dash anyway. If you happen to have a /bin/bash -> dash symlink or similar, then this bug report should be considered INVALID.
Comment 4 Maciej Piechotka 2015-02-15 10:19:28 UTC
(In reply to Jeroen Roovers from comment #3)
> What I don't get is why it has the appropriate shebang pointing to
> /bin/bash, but *your* system manages to run that through /bin/dash anyway.
> If you happen to have a /bin/bash -> dash symlink or similar, then this bug
> report should be considered INVALID.

I switch the shell via eselect so had the /bin/bash do point to dash it's not my fault. When I switch to bash via eselect it works.

% ls -l /bin/bash /bin/dash /bin/sh 
-rwxr-xr-x 1 root root 726040 Jan 23 21:09 /bin/bash
-rwxr-xr-x 1 root root 109856 Oct 16 09:15 /bin/dash
lrwxrwxrwx 1 root root      4 Feb 14 22:37 /bin/sh -> dash
% /bin/bash --version
GNU bash, version 4.3.33(1)-release (x86_64-pc-linux-gnu)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

This is free software; you are free to change and redi
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2015-02-18 08:24:23 UTC
(In reply to Maciej Piechotka from comment #4)
> (In reply to Jeroen Roovers from comment #3)
> > What I don't get is why it has the appropriate shebang pointing to
> > /bin/bash, but *your* system manages to run that through /bin/dash anyway.
> > If you happen to have a /bin/bash -> dash symlink or similar, then this bug
> > report should be considered INVALID.
> 
> I switch the shell via eselect so had the /bin/bash do point to dash it's
> not my fault. When I switch to bash via eselect it works.

Um, not as far as I am aware. sh.eselect handles the /bin/sh -> symlink and never sets a /bin/bash symlink target. It may set a /bin/sh -> bash target, but that's different.

I'm CC-ing mgorny for confirmation so that we may know.
Comment 6 Łukasz Stelmach 2015-03-17 18:37:55 UTC
I've got the same problem building apache-tools. My /bin/sh is a symlink to /bin/dash. The actual command that fails is:

/usr/share/build-1/libtool --silent --mode=compile x86_64-pc-linux-gnu-gcc -pthread  -march=nocona -O2 -pipe  -DLINUX -D_REENTRANT -D_GNU_SOURCE    -I. -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/os/unix -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/server/mpm/prefork -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/http -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/filters -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/proxy -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/include -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/generators -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/mappers -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/database -I/usr/include/apr-1 -I/usr/include/db4.8 -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/proxy/../generators -I/usr/include -I/usr/kerberos/include -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/ssl -I/var/tmp/portage/app-admin/apache-tools-2.2.29/work/httpd-2.2.29/modules/dav/main  -prefer-non-pic -static -c htpasswd.c && touch htpasswd.lo

It works if I run it with bash.

/bin/bash /usr/share/build-1/libtool [...]

The libtool script abve comes from dev-libs/apr-1.5.0-r2 in my case. The shebang in the script points to /bin/sh.
Comment 7 Alexander Tsoy 2015-06-03 12:31:58 UTC
You can rebuild apr as a workaround - shebang will be changed to /bin/bash. And I think this bug is a duplicate of bug 528798
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-06-03 19:10:27 UTC
Using pre-generated libtool is just plain broken. That file should be banned immediately.
Comment 9 Alexander Tsoy 2015-06-03 20:42:37 UTC
Unfortunately every package which DEPEND on apr use this pre-generated libtool. =/
Comment 10 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-06-03 20:46:39 UTC
Then every package needs to be fixed. This libtool can get out of sync and break at any random point in time if anything in ebuild environment changes.
Comment 11 Stuart Shelton 2015-10-17 14:36:55 UTC
I'm seeing build failures with:

libtool: Version mismatch error.  This is libtool 2.4.6, but the
libtool: definition of this LT_INIT comes from libtool 2.4.2.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
libtool: and run autoconf again.

... when trying to build apr on a prefix install - does this look like the same issue (e.g. bundled libtool is now out of sync)?
Comment 12 Stuart Shelton 2015-10-17 14:44:19 UTC
Sorry, meant to mention that this was against dev-libs/apr-1.5.2

(In reply to Stuart Shelton from comment #11)
> I'm seeing build failures with:
> 
> libtool: Version mismatch error.  This is libtool 2.4.6, but the
> libtool: definition of this LT_INIT comes from libtool 2.4.2.
> libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
> libtool: and run autoconf again.
> 
> ... when trying to build apr on a prefix install - does this look like the
> same issue (e.g. bundled libtool is now out of sync)?