Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 538862 - =dev-util/netbeans-8.0.2: stabilisation request
Summary: =dev-util/netbeans-8.0.2: stabilisation request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: jdk7-stabilization 509602 549756
Blocks: 429500 435022 479096 491054 546288
  Show dependency tree
 
Reported: 2015-02-04 22:13 UTC by Miroslav Šulc
Modified: 2015-05-21 09:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Šulc gentoo-dev 2015-02-04 22:13:37 UTC
added for tracking when jdk7 gets stabilized
Comment 1 Miroslav Šulc gentoo-dev 2015-04-17 09:14:22 UTC
the blocker is gone now so please stabilize this release of netbeans and its eventual deps not mentioned here:

=dev-java/netbeans-apisupport-8.0.2
=dev-java/netbeans-cnd-8.0.2
=dev-java/netbeans-dlight-8.0.2
=dev-java/netbeans-enterprise-8.0.2
=dev-java/netbeans-ergonomics-8.0.2
=dev-java/netbeans-extide-8.0.2
=dev-java/netbeans-groovy-8.0.2
=dev-java/netbeans-harness-8.0.2
=dev-java/netbeans-ide-8.0.2
=dev-java/netbeans-java-8.0.2-r1
=dev-java/netbeans-javacard-8.0.2
=dev-java/netbeans-javadoc-8.0.2
=dev-java/netbeans-javafx-8.0.2
=dev-java/netbeans-mobility-8.0.2
=dev-java/netbeans-nb-8.0.2
=dev-java/netbeans-php-8.0.2
=dev-java/netbeans-platform-8.0.2
=dev-java/netbeans-profiler-8.0.2
=dev-java/netbeans-webcommon-8.0.2
=dev-java/netbeans-websvccommon-8.0.2
=dev-util/netbeans-8.0.2

thank you.
Comment 2 Miroslav Šulc gentoo-dev 2015-04-17 09:57:13 UTC
i accidentally included one version from my overlay, it should be

=dev-java/netbeans-java-8.0.2

instead, but you can aswell go with =dev-java/netbeans-java-8.0.2-r2 which contains one minor fix and change in dep from cglib:2.1 and cglib:2.2 to cglib:3 which has no effect on netbeans functionality afaik
Comment 3 Agostino Sarubbo gentoo-dev 2015-04-19 13:42:40 UTC
  dependency.bad                11
   dev-java/netbeans-java/netbeans-java-8.0.2-r2.ebuild: RDEPEND: amd64(default/linux/amd64/13.0) ['dev-java/jboss-logging:0']


Please elaborate a repoman-checked list
Comment 4 Miroslav Šulc gentoo-dev 2015-04-19 14:46:44 UTC
i just did full check and this is the only dep that needs to be stabilized. unfurtunately it has a pending bug so netbeans can't be stabilized until the dep is fixed and marked stable. sorry for filing stable request for this package.
Comment 5 Pacho Ramos gentoo-dev 2015-04-21 18:05:54 UTC
UnCCing arches then ;)
Comment 6 Michael Cordingley 2015-05-06 18:16:02 UTC
I'm on amd64 and only have these keywords set:

# Irrelevant, but included for completeness
<=app-emulation/wine-1.8.0
<=www-client/firefox-38.0

=dev-util/netbeans-8.0.2 ~amd64
=dev-java/netbeans-webcommon-8.0.2 ~amd64
=dev-java/netbeans-websvccommon-8.0.2 ~amd64
=dev-java/netbeans-extide-8.0.2 ~amd64
=dev-java/netbeans-nb-8.0.2 ~amd64
=dev-java/netbeans-ide-8.0.2 ~amd64
=dev-java/netbeans-php-8.0.2 ~amd64
=dev-java/netbeans-platform-8.0.2 ~amd64
=dev-java/netbeans-harness-8.0.2 ~amd64

It merged just fine for me without any further dependencies needing to be unmasked. I'd ask that you revisit the possibility of stabilizing this package.

Having had 7.4 and now 8.0 keyworded literally for years now, it would be wonderful to finally be able to run Netbeans without keywords.
Comment 7 Michael Cordingley 2015-05-06 18:54:46 UTC
Nevermind. I am blind, did not see the block link, and apparently do not have that blocking package pulled in as a dependency for my particular set of installed Netbeans packages. Still very much looking forward to the stabilization when it's able to happen. :D
Comment 8 Patrice Clement gentoo-dev 2015-05-17 22:48:55 UTC
Please sort out bug 549756 first and go on with the stabilising. Thank you.
Comment 9 Agostino Sarubbo gentoo-dev 2015-05-21 09:50:42 UTC
amd64 stable
Comment 10 Agostino Sarubbo gentoo-dev 2015-05-21 09:52:19 UTC
x86 stable. Closing.