Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 53741 - driverloader-2.23 (New Package)
Summary: driverloader-2.23 (New Package)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Mobile Herd (OBSOLETE)
Keywords: EBUILD
: 76831 (view as bug list)
Depends on:
Reported: 2004-06-12 14:13 UTC by Jeff Davidson
Modified: 2005-05-01 12:33 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

driverloader-1.72.ebuild (driverloader-1.72.ebuild,2.55 KB, text/plain)
2004-06-12 14:15 UTC, Jeff Davidson
driverloader-2.6-modules.patch (driverloader-2.6-modules.patch,416 bytes, patch)
2004-06-12 14:16 UTC, Jeff Davidson
Details | Diff
driverloader-modules.patch (driverloader-modules.patch,522 bytes, patch)
2004-06-12 14:17 UTC, Jeff Davidson
Details | Diff
linuxant (license) (linuxant,3.14 KB, text/plain)
2004-06-18 15:40 UTC, Jeff Davidson
driverloader-2.23.ebuild (driverloader-2.23.ebuild,1.68 KB, text/plain)
2005-01-06 09:16 UTC, Stefan Schweizer (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Davidson 2004-06-12 14:13:04 UTC

Please find attached driverloader-1.71.ebuild, a license file for driverloader, and 2 patches for module compilation fixes (one for all kernels, one for 2.6).

Driverloader, like ndiswrapper, uses windows drivers to get some wireless devices working in Linux.  The difference between the two is that Driverloader is commercial but generally works much better.  You need to purchase a license to use it ($19.95), and there are 30 day free trials at

This being my first ebuild, I request that everything is checked over for correctness.  In order to compile the module, I used a similar technique from the alsa-driver ebuild - copying over the 2.6 kernel tree into a temp dir for 2.6 compilation (nothing special is done for 2.4).  Odds are, I have a mistake somewhere or a style error in there, please let me know here. :)

Since ndiswrapper is in net-wireless/ndiswrapper, I suggest net-wireless/driverloader.

-Jeff (monkey89 on the forums)

I suggest app-misc/gramps Also, this ebuild depend on Imaging and ReportLab
previously submitted

Comment 1 Jeff Davidson 2004-06-12 14:15:41 UTC
Created attachment 33147 [details]
Comment 2 Jeff Davidson 2004-06-12 14:16:43 UTC
Created attachment 33148 [details, diff]
Comment 3 Jeff Davidson 2004-06-12 14:17:15 UTC
Created attachment 33149 [details, diff]
Comment 4 Jeff Davidson 2004-06-12 14:18:23 UTC
Sorry, a little extra text got into my first post.  Ignore these lines:

I suggest app-misc/gramps Also, this ebuild depend on Imaging and ReportLab
previously submitted


Comment 5 Jeff Davidson 2004-06-18 15:40:54 UTC
Created attachment 33535 [details]
linuxant (license)
Comment 6 Jeff Davidson 2004-06-18 16:14:41 UTC
Ok, there were a few errors I needed to correct in my submissions.

1 - Driverloader has been bumped to 1.72 with minor changes, so I renamed the bug and ebuild files here.  Tested on 2.6, compiles fine, so everything should still be ok.

2 - I forgot to upload the LICENSE file from last time, so it is now in the attached file list.  The file should be named linuxant and placed in the licenses folder.

Please get this ebuild in the tree as soon as possible, I am depending on it to make a livecd so I can do a networked stage 1 install instead of doing offline stage 3's.

Thanks a lot,
-Jeff Davidson
Comment 7 Joel Parker 2004-08-25 11:37:38 UTC
Any progress on this? driverloader 2.05 is out now, as well as the wpa_supplicant. An ebuild for each of these would be much appreciated.
Comment 8 Jeff Davidson 2004-08-28 12:27:28 UTC
Since there haven't been any updates in a while, I'll throw in something.

Releases prior to 2.03 had a bug in 2.6.8+ kernels that can be fixed by adding the following lines before the OsRunThreadSync() function in modules/osservices.c (from the root of the unzipped folder)

static inline _syscall3(pid_t,waitpid,pid_t,pid,int 

Note that I still use 1.71 because the 2.0 releases have a small cosmetic problem with my wireless card (Invalid misc number goes up continuously) and also had sporadic packet loss when I tried 2.04 out, but the ebuild doesn't require much changing.

First of all, eutils should be added to the inherit list for all versions of driverloader so that epatch works.  driverloader-modules.patch still works with some fuzz because the surrounding lines have changed slightly, this can be fixed by redoing the patch with the new code.  However, the driverloader-2.6-modules.patch won't apply because the old KERNELSRC lines have been replaced with DLDR_KERNELSRC lines.  Just make the same changes to the DLDR_KERNELSRC line as would be done to the KERNELSRC lines in the old patch and the patch will work and do what it should.

Can we please get this added to the main tree sometime soon?
Comment 9 Stefan Schweizer (RETIRED) gentoo-dev 2005-01-06 08:55:47 UTC
*** Bug 76831 has been marked as a duplicate of this bug. ***
Comment 10 Stefan Schweizer (RETIRED) gentoo-dev 2005-01-06 09:16:32 UTC
Created attachment 47769 [details]

Please test and comment
Comment 11 Michael E. Adams 2005-01-06 15:14:12 UTC
My bugzilla report was for the new Linuxant driverloader-2.23 for x86-64 which supports only the broadcom chipsets right now. My bugzilla report was marked as a duplicate of this, which it wasn't. I can test this if ~amd64 keywork is added and you tell me how. I have never tested an ebuild that was not emerged the normal way. I would be glad to if you could just give me a summary (please don't just point me to a large document to read) of how. I am eager to learn how so I can help with others - if you could please get me started. Thanks.

Also, you might want to look at Linuxant's for use here. My bugzilla report explained how I got this to work.
Comment 12 Stefan Schweizer (RETIRED) gentoo-dev 2005-01-07 02:59:23 UTC
It was a duplicate of this one, it does not matter that you are on amd64, it is the same package.

echo PORTDIR_OVERLAY="/usr/local/portage" >> /etc/make.conf
mkdir -p /usr/local/portage/net-wireless/driverloader
cd /usr/local/portage/net-wireless/driverloader
echo net-wireless/driverloader ~amd64 >> /etc/portage/package.keywords
emerge -v driverloader --digest

Now it should be installed .. please read the instructions and try to configure and use it.
Comment 13 Michael E. Adams 2005-01-09 12:24:24 UTC
Since I was using my manually installed driverloader to test the driverloader-2.23.ebuild, I couldn't uninstall it before doing the emerge. Everything worked correctly. However, I tried to do a dldrconfig -u to test the uninstall capability and it fails with this error:

dldrconfig -u
Linuxant DriverLoader for Wireless LAN devices, version 2.23

ERROR: Uninstallation failed:

/usr/sbin/dldrconfig: line 2353: cd: /var/tmp/portage/driverloader-2.23/work/driverloader-2.23: No such file or directory

Note that the installation instuctions state that "Once the drivers are uploaded, you should have a new eth0 device..."

This is system depended. For example, my system has an eth2 once the drivers are  loaded.

I think I should re-try this emerge once the uninstall option works. I did not try to unmerge (again, because I am using driverloader) so I don't know yet it it will work. I will try this using my ethernet connection so I can try from scratch.

Note that only the BCMWL564 (Broadcom chipset driver) is available for x86_64 Linux.
Comment 14 Michael E. Adams 2005-01-16 09:17:54 UTC
Note that during boot-up, the following message is displayed. Linuxant says that this can be ignored.

Services 'driverloaderbuild' and 'checkroot' have circular dependency of type 'ibefore';  continuing...

They say they don't know how to prevent this.
Comment 15 Joel Parker 2005-03-17 08:44:07 UTC
You can prevent it by changing "before *" to "before net" or similar in the driverloaderbuild init.d script. I asked Linuxant about this, and they said they tried that, but some people were having problems with it. I believe now it's assigned to runlevel boot anyway.

BTW, 2.26 is out.
Comment 16 Michael E. Adams 2005-03-20 17:21:48 UTC
I just installed driverloader 2.26 from tar. It works perfectly for me and the message I reported in my Additional Comments #14 above is now gone. Looks great.
Comment 17 Joel Parker 2005-03-20 21:47:59 UTC
It's useful to note that there are a few complicating issues surrounding driverloader:

1. Linuxant recommends that you apply the <a href="">16k stack patch</a> (down towards bottom) to the kernel sources and enable it during configuration.

2. There have been many <a href="">problems </a> regarding preemptible kernels and Driverloader. Maybe an alert telling the user about this?
Comment 18 Henrik Brix Andersen 2005-04-30 09:50:50 UTC
Since none of the Gentoo developers are willing to use a a commercial project for a job which can accomplished by an open source project (net-wireless/ndiswrapper), I have to resolve this enhancement request as WONTFIX.
Comment 19 Jeff Davidson 2005-04-30 15:18:40 UTC
Brix, while I personally don't really need this like I did before, I think a lot of people use driverloader because of its ease of use, and because there's actual tech support backing it.  Some people (including me, who when I used ndiswrapper, had very, very annoying bugs) preferred to use this solution, regardless of price.

There's an ebuild already, and a lot of the functionality in driverloader isn't in ndiswrapper, and driverloader tends to have a lot of newer stuff first.  Would it be too bad to add it to the tree for those who might still need it?

Just thought I'd throw that out there.

Comment 20 Henrik Brix Andersen 2005-05-01 02:24:32 UTC
Linuxant currently supports Debian-based and RPM-based distributions - you should contact them for Gentoo support. Sorry...
Comment 21 Joel Parker 2005-05-01 11:15:33 UTC
I'm also not sure I understand...

The reason you gave is that it's a proprietary product that has the same purpose as a free product.

But I notice that you have very up-to-date ebuilds for VMWare (same purpose as qemu), Cedega (wine), and the Cisco VPN Client (vpnclient) with no talk of giving them up for the same reason. The reason, I presume, is that VMWare and Cedega offer significant benefits over their free alternatives - just as driverloader offers over ndiswrapper.

Why the double standard?
Comment 22 Stefan Schweizer (RETIRED) gentoo-dev 2005-05-01 11:24:20 UTC
Donate me a network card and a driver-loader license and I will try to maintain it, its that simple.

Some developers have cedega or vmware but obviously no one has driverloader, I hope you realize that we cant seriously support something, we dont own.

As you see I made the current ebuild for driverloader which you can see here .. I received no feedback about it.
People keep telling things like "I just installed driverloader 2.26 from tar"

Do they really need an ebuild then? Why should I bother maintaining something non-free which I dont need or maintain where I am not even able to test?
Comment 23 Joel Parker 2005-05-01 12:33:12 UTC
I see, thanks for the clarification. I suppose if I were a dev, I could maintain it. Maybe someday...