Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 526992 - media-tv/kodi-14.1 version bump (formerly known as xbmc)
Summary: media-tv/kodi-14.1 version bump (formerly known as xbmc)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 7 votes (vote)
Assignee: Xbox herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-26 23:52 UTC by Rafal Kupiec
Modified: 2015-02-16 23:59 UTC (History)
32 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
diff to rename xbmc-send to kodi-send.py (xbmc-kodi.patch,467 bytes, patch)
2014-11-10 18:12 UTC, Ville Aakko
Details | Diff
xbmc-9999.ebuild.patch (xbmc-9999.ebuild.patch,3.41 KB, patch)
2014-11-10 21:48 UTC, PhobosK
Details | Diff
xbmc-9999.ebuild (xbmc-9999.ebuild,9.10 KB, text/plain)
2014-11-27 22:34 UTC, PhobosK
Details
Working ebuild for kodi-14.0 release (kodi-14.0.ebuild,8.50 KB, text/plain)
2014-12-30 04:20 UTC, godlike64
Details
Updated ebuild (kodi-14.0.ebuild,7.99 KB, text/plain)
2015-01-12 12:38 UTC, Mathy Vanvoorden
Details
CPU_FLAGS_X86 variable chnages (file_526992.txt,1.28 KB, patch)
2015-01-31 04:23 UTC, Ron
Details | Diff
kodi ebuild with cpu flag patch applied and url update (kodi-14.1.ebuild,8.05 KB, text/plain)
2015-02-04 20:18 UTC, Fredrik Eriksson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafal Kupiec 2014-10-26 23:52:45 UTC
XBMC has changed name, please rename the live ebuild from XBMC to Kodi.

Reproducible: Always
Comment 1 SpanKY gentoo-dev 2014-10-27 17:56:15 UTC
i'll just wait until the first release of kodi
Comment 2 Rafal Kupiec 2014-10-27 17:58:27 UTC
There is Kodi 14 alpha 4 already.
I think xbmc ebuild should stay as they are up to 13.2, but live (9999) as well as other new ebuild shoul be already available under kodi name. Also xbmc-9999 does not build. So this is a great time to fix ebuild and rename it IMHO.
Comment 3 SpanKY gentoo-dev 2014-10-27 18:58:18 UTC
(In reply to Rafal Kupiec from comment #2)

i don't bother adding alphas/betas/rcs to the tree anymore
Comment 4 Vladi 2014-10-27 22:16:25 UTC
I think what Rafal means is that xbmc-9999 is failing to build because its expecting scripts and stuff to install as xbmc but the name has been changed to kodi. So its a good time to change the -9999 ebuild to kode and fix the install section to use kodi instead of xbmc.
Comment 5 Rafal Kupiec 2014-10-28 23:17:04 UTC
(In reply to Vladi from comment #4)
> I think what Rafal means is that xbmc-9999 is failing to build because its
> expecting scripts and stuff to install as xbmc but the name has been changed
> to kodi. So its a good time to change the -9999 ebuild to kode and fix the
> install section to use kodi instead of xbmc.

Yes, that's exactly what I wanted to say :)
Any chance to get live ebuild updated?
Comment 6 Vladi 2014-10-30 04:16:58 UTC
>>> Install xbmc-9999 into /tmp/portage/media-tv/xbmc-9999/image/ category media-tv
make -j8 -l2 DESTDIR=/tmp/portage/media-tv/xbmc-9999/image/ install 
Copying support and legal files...                                             
Done!
Copying system files to /tmp/portage/media-tv/xbmc-9999/image//usr/share/kodi
Copying bindings to /tmp/portage/media-tv/xbmc-9999/image//usr/include/kodi    
Copying kodi binary to /tmp/portage/media-tv/xbmc-9999/image//usr/lib64/kodi/
You can run kodi with the command 'kodi'
 * ERROR: media-tv/xbmc-9999::gentoo failed (install phase):
 *   !!! newexe: tools/EventClients/Clients/XBMC Send/xbmc-send.py does not exist
 *
 * If you need support, post the output of `emerge --info '=media-tv/xbmc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-tv/xbmc-9999::gentoo'`.
 * The complete build log is located at '/tmp/portage/media-tv/xbmc-9999/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/media-tv/xbmc-9999/temp/environment'.
 * Working directory: '/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * S: '/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * ERROR: media-tv/xbmc-9999::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_install
 *   environment, line 4551:  Called python_newscript 'tools/EventClients/Clients/XBMC Send/xbmc-send.py' 'xbmc-send'
 *   environment, line 4365:  Called python_newexe 'tools/EventClients/Clients/XBMC Send/xbmc-send.py' 'xbmc-send'
 *   environment, line 4355:  Called die
 * The specific snippet of code:
 *       newexe "${f}" "${newfn}" || die );
 *
 * If you need support, post the output of `emerge --info '=media-tv/xbmc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-tv/xbmc-9999::gentoo'`.
 * The complete build log is located at '/tmp/portage/media-tv/xbmc-9999/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/media-tv/xbmc-9999/temp/environment'.
 * Working directory: '/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * S: '/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'
 * QA Notice: Unrecognized configure options:
 *
 *      --enable-external-libraries
 *      --disable-hal
 *      --enable-external-libraries
 *      --disable-hal
 * QA Notice: make jobserver unavailable:
 *
 *      make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[2]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[2]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 *      make[2]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.

>>> Failed to emerge media-tv/xbmc-9999, Log file:
Comment 7 Michael Cook 2014-11-04 00:37:12 UTC
Quickly looking at your log, you should just need to change XBMC to Kodi and xbmc-send to kodi-send. (You appear to have made the other changes already)
Comment 8 Ville Aakko 2014-11-10 18:12:09 UTC
Created attachment 389034 [details, diff]
diff to rename xbmc-send to kodi-send.py

This patch makes the change to xbmc-send.py being renamed to kodi-send.py.

However, there is other stuff (fonts etc.) in the ebuild being replaced that still use xbmc file names, so they still need to be changed (they are trivial changes, but too busy to make the changes currently myself, the euibld works as it is).

Cheers!
Comment 9 PhobosK 2014-11-10 21:48:43 UTC
Created attachment 389054 [details, diff]
xbmc-9999.ebuild.patch

There are a lot of other changes needed in the ebuild.
Here I propose the xbmc-9999 that has most of the needed changes.

One important thing to do before emerging it, is that any installed XBMC should first be "emerge -C xbmc" because the upstream installation creates several symlinks named "xbmc" for compatible reasons. So if this proposed version is emerged over an already existing one, the symlinks will be named "xbmc_backup001" (or smth like this) and Kodi may not work properly....

This ebuild proposal is only for temp overlay reference for those that need Kodi latest git to be available on their systems ....

Maybe there are a lot of things that can be done better... but anyway...
Comment 10 Tim G. 2014-11-27 19:08:13 UTC
I've never applied an ebuild patch before. I put this patch in /etc/portage/patches/media-tv/xbmc, but I got a "Permission Denied" error when attempting to emerge. I'll have to figure that out some other time....

In the meantime, I've actually gotten this Kodi to install with out a patch by 
1) digging into /var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999/tools/EventClients/Clients/ during the emerge,
2) creating an 'XBMC\ Send' folder there,
3) copying kodi-send.py from the 'Kodi\ Send' folder into the new 'XBMC\ Send' folder, and
4) renaming the copied kodi-send.py as 'xbmc-send.py'.

I'm not sure what sort of blowback I should expect from monkeying around like that, but I at least have Kodi back up and running. Portage recognizes it, so it seems okay, and a half-decent alternative if you're like me and you haven't got the patching process figured out.
Comment 11 PhobosK 2014-11-27 22:27:55 UTC
@Tim G.,
As you said it yourself... your way is not at all a good one...

Anyway, the patch I've uploaded is a patch against the official ebuild file in the portage tree i.e. against the  /usr/portage/media-tv/xbmc/xbmc-9999.ebuild file. It will result in a new xbmc-9999.ebuild that you should put in your local overlay (for example in /usr/local/portage/media-tv/xbmc/xbmc-9999.ebuild assuming that your local overlay resides in /usr/local/portage). For more info read these:
https://wiki.gentoo.org/wiki/Overlay
and especially this one:
https://wiki.gentoo.org/wiki/Overlay/Local_overlay

For your ease I will upload the already patched xbmc-9999.ebuild file that you should put in your local overlay (for example in /usr/local/portage/media-tv/xbmc/xbmc-9999.ebuild assuming that your local overlay resides in /usr/local/portage) after you create one using the docs from the links above...
Comment 12 PhobosK 2014-11-27 22:34:56 UTC
Created attachment 390432 [details]
xbmc-9999.ebuild

The patched ebuild file to be put in the local overlay in  media-tv/xbmc folder. In that same folder you should create a "files" subfolder and copy these files there:
/usr/portage/media-tv/xbmc/files/generate.sh
/usr/portage/media-tv/xbmc/files/xbmc-9999-no-arm-flags.patch
/usr/portage/media-tv/xbmc/files/xbmc-9999-nomythtv.patch

Then emerge xbmc again
Comment 13 Andrew Udvare 2014-12-20 21:30:56 UTC
I created an ebuild for 'latest stable', the Helix rc3 version based on PhobosK and others' work. I removed all code related to XBMC naming. Due to the checks for 9999 that would add JRE as a requirement I made that a non-optional requirement.

https://github.com/Tatsh/tatsh-overlay/blob/master/media-tv/kodi/kodi-14.0_rc3.ebuild

This all seems to work.

I do not use XBMC/Kodi in any kind of complicated way (I rarely use add-ons), so I have no need for any 'backward compatibility'.
Comment 14 Leho Kraav (:macmaN @lkraav) 2014-12-24 01:12:06 UTC
SpankY is probably already hard at work since Kodi stable is released :)

http://kodi.tv/kodi-14-0-helix-unwinds/
Comment 15 godlike64 2014-12-30 04:20:14 UTC
Created attachment 392688 [details]
Working ebuild for kodi-14.0 release

I modified the ebuild from Andrew in comment 13, since it was building against an rc pulled from git. This one pulls the official tarball (I copied the logic for SRC_URI from the original xbmc-13.2.ebuild). It builds and runs (tested it by reproducing a movie). I did not try further as Kodi now changes the home dir (~/.kodi), and I think addons for the previous XBMC version might not work at all.

Besides ${CODENAME} I had to change ${S} too, since for some reason, when the tarball is extracted, it is named 'xbmc-14.0-Helix'.
Comment 16 Jura 2015-01-01 20:07:04 UTC
Kodi build only with MAKEOPTS="-j1"


P.S.: use flags: X alsa avahi fishbmc joystick opengl projectm pulseaudio rsxs sdl sse sse2 udisks upnp upower usb vaapi vdpau webserver xrandr
Comment 17 daktak 2015-01-05 11:30:20 UTC
Codegenerator.mk is failing for me. recipe for target 'java-not-found' failed

I don't have a jre installed ;-)

Also is groovy required? Or only if java enabled?
Comment 18 Mathy Vanvoorden 2015-01-12 12:37:10 UTC
I also gave compiling Kodi a shot. The ebuild that is submitted by godlike64 works but has some issues in the ffmpeg department:

* Kodi developers dropped the configure flag --enable-external-libraries. Although you can now select a system library with --with-ffmpeg=shared by default it is set to force which means that it downloads and builds the ffmpeg distributed by Kodi developers. They completely removed all the external library compatibilities. I tried building it with vanilla ffmpeg 2.4.4 but it doesn't work as it is missing some of their patches. Their intentions seem to be to go towards vanilla ffmpeg though but for the moment it doesn't seem possible.

* This is (I think) also the reason that Jura has the issue that only building with one cpu works, I suspect it is a concurrency issue while downloading the package or something like that. For me it worked one time and didn't another which is when I noticed that it was downloading ffmpeg.

* Kodi requires ffmpeg 2.4.3, which the configure script checks. We have 2.5.(1,2,3) in the tree but they are masked because they break VLC.

I made an update of the ebuild with the following stuff:

* Removed ffmpeg stuff as it isn't valid
* Added a blocker for xbmc since there are conflicting files

I also put them up in an overlay together with a PVR addons ebuild if anyone needs it:

https://github.com/MathyV/gentoo-overlays-media
Comment 19 Mathy Vanvoorden 2015-01-12 12:38:26 UTC
Created attachment 393784 [details]
Updated ebuild
Comment 20 Ron 2015-01-31 04:23:55 UTC
Created attachment 395242 [details, diff]
CPU_FLAGS_X86 variable chnages

Just a simple diff of the changes needed for the new implementation of CPU_FLAGS_X86 variables specifically sse sse2 to cpu_flags_x86_sse cpu_flags_x86_sse2

You can make a patch or just edit it manually it's as simple as it looks.
Comment 21 Timo Rothenpieler 2015-02-01 15:59:42 UTC
xbmc/kodi git master doesn't seem to need sdl anymore. configure doesn't even know the --enable-sdl option anymore. It looks like the sdl useflags and all the sdl dependencies can just be dropped.
Comment 22 hal 2015-02-02 19:16:49 UTC
@Timo Rothenpieler This has already been reported: https://bugs.gentoo.org/show_bug.cgi?id=536602
Comment 23 Nebojsa Trpkovic 2015-02-04 11:06:35 UTC
will there be any package in the official tree any time soon?
Comment 24 Anthony Ryan 2015-02-04 19:01:54 UTC
I wouldn't expect this to make it into the tree any time soon. A lot of people have started using the unofficial kodi overlay.

https://github.com/frace/kodi-overlay

It might be worth exploring while you wait.
Comment 25 Nebojsa Trpkovic 2015-02-04 19:22:12 UTC
thx, Anthony.

after making xbmc uncompilable, they are prolonging inclusion of kodi.
good strategy.
I'll investigate the overlay...
Comment 26 Fredrik Eriksson 2015-02-04 20:16:24 UTC
If it is to any help: I've used the ebuild from Mathy Vanvoorden on amd64 and have not had any troubles with it. Today I applied the CPU flag changes and changed the source URL to kodi.tv instead of xbmc.org. The old link still work, but I thought it might be good to update it to go against their new domain. I used this ebuild to update to 14.1 and it appears to work just fine.

Although there are only simple changes, I will upload the ebuild so that anyone who wants to test don't have to bother editing by hand or adding patches to the ebuild.
Comment 27 Fredrik Eriksson 2015-02-04 20:18:18 UTC
Created attachment 395550 [details]
kodi ebuild with cpu flag patch applied and url update
Comment 28 SpanKY gentoo-dev 2015-02-15 18:35:59 UTC
Comment on attachment 389034 [details, diff]
diff to rename xbmc-send to kodi-send.py

this has been merged:
http://sources.gentoo.org/media-tv/xbmc/xbmc-9999.ebuild?r1=1.164&r2=1.165
Comment 29 SpanKY gentoo-dev 2015-02-16 00:45:05 UTC
Comment on attachment 389054 [details, diff]
xbmc-9999.ebuild.patch

latest git should largely cover this now

http://sources.gentoo.org/media-tv/xbmc/xbmc-9999.ebuild?r1=1.171&r2=1.172
Comment 30 SpanKY gentoo-dev 2015-02-16 00:47:02 UTC
Comment on attachment 395242 [details, diff]
CPU_FLAGS_X86 variable chnages

this was fixed via bug 536402
Comment 31 SpanKY gentoo-dev 2015-02-16 00:48:19 UTC
(In reply to Nebojsa Trpkovic from comment #25)

this isn't the place to gripe.  use the forums or something to complain.  bugzilla is for tracking bugs.
Comment 34 SpanKY gentoo-dev 2015-02-16 07:39:02 UTC
Commit message: Migrate people to the new kodi package
http://sources.gentoo.org/media-tv/xbmc/xbmc-9999.ebuild?r1=1.173&r2=1.174
Comment 35 SpanKY gentoo-dev 2015-02-16 07:41:28 UTC
kodi is in the tree now, but not keyworded.  building against libav (at configure time) or ffmpeg (at build time) fails.  until that can get sorted, it'll stay dekeyworded.

i've replaced the xbmc-9999.ebuild with a stub that pulls in media-tv/kobi.  when kobi eventually goes stable, we can do a proper package move.  renaming xbmc in place to kodi looks like more hassle than it's worth.
Comment 36 Manuel Rüger (RETIRED) gentoo-dev 2015-02-16 19:54:55 UTC
(In reply to SpanKY from comment #35)
> kodi is in the tree now, but not keyworded.  building against libav (at
> configure time) or ffmpeg (at build time) fails.  until that can get sorted,
> it'll stay dekeyworded.
> 
> i've replaced the xbmc-9999.ebuild with a stub that pulls in media-tv/kobi. 
> when kobi eventually goes stable, we can do a proper package move.  renaming
> xbmc in place to kodi looks like more hassle than it's worth.

http://cvs.rpmfusion.org/viewvc/rpms/kodi/devel/kodi-14.0-dvddemux-ffmpeg.patch?revision=1.1&root=free&view=markup
Comment 37 hal 2015-02-16 20:35:09 UTC
(In reply to Manuel Rüger from comment #36)
> (In reply to SpanKY from comment #35)
> > kodi is in the tree now, but not keyworded.  building against libav (at
> > configure time) or ffmpeg (at build time) fails.  until that can get sorted,
> > it'll stay dekeyworded.
> > 
> > i've replaced the xbmc-9999.ebuild with a stub that pulls in media-tv/kobi. 
> > when kobi eventually goes stable, we can do a proper package move.  renaming
> > xbmc in place to kodi looks like more hassle than it's worth.
> 
> http://cvs.rpmfusion.org/viewvc/rpms/kodi/devel/kodi-14.0-dvddemux-ffmpeg.
> patch?revision=1.1&root=free&view=markup

Was that patch sent/reported upstream?
Comment 38 Tomas Rusnak 2015-02-16 22:24:59 UTC
No, the patchset wasn't sent upstream. At various sources/discussions we can find same answer why. For example:
http://kodi.wiki/view/Linux_FAQ
11. XBMC builds that use external ffmpeg/libav are not supported and are strongly discouraged.

It looks like they are supporting only their own internal ffmpeg. By that, the patch will be never accepted upstream, until it needs to use some internal ffmpeg functions. These functions are not exported public in newest ffmpeg versions, anymore.
Comment 39 SpanKY gentoo-dev 2015-02-16 23:59:26 UTC
(In reply to Manuel Rüger from comment #36)

thanks, that was what i was hitting:
http://sources.gentoo.org/media-tv/kodi/files/kodi-14.0-dvddemux-ffmpeg.patch?rev=1.1
http://sources.gentoo.org/media-tv/kodi/kodi-14.1.ebuild?r1=1.1&r2=1.2
http://sources.gentoo.org/media-tv/kodi/kodi-9999.ebuild?r1=1.1&r2=1.2

now that 14.1 is in ~arch, lets close out this bug and file new bugs about various specific problems as they come up.