Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 536402 - media-tv/xbmc-9999 - Patching libsquish not necessary anymore
Summary: media-tv/xbmc-9999 - Patching libsquish not necessary anymore
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Xbox herd
URL: https://github.com/xbmc/xbmc/commit/7...
Whiteboard:
Keywords:
: 538210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-12 12:53 UTC by hal
Modified: 2015-02-15 18:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
no_libsquish_patching.patch (no_libsquish_patching.patch,338 bytes, patch)
2015-01-12 12:53 UTC, hal
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description hal 2015-01-12 12:53:37 UTC
Created attachment 393790 [details, diff]
no_libsquish_patching.patch

It's not necessary anymore to patch the libsquish makefile. Build successfully tested.
Comment 1 Fabian Groffen gentoo-dev 2015-01-18 18:24:58 UTC
I've committed this to the 9999 ebuild
Comment 2 hal 2015-01-30 00:32:44 UTC
In the patch I forgot to remove related USE flags: altivec, sse, sse2
See: https://bugs.gentoo.org/show_bug.cgi?id=538210
Comment 3 SpanKY gentoo-dev 2015-02-15 18:06:57 UTC
*** Bug 538210 has been marked as a duplicate of this bug. ***
Comment 4 SpanKY gentoo-dev 2015-02-15 18:12:15 UTC
should be all set now in the tree; thanks for the report!

Commit message: Drop unused cpu flags now that squish is gone
http://sources.gentoo.org/media-tv/xbmc/xbmc-9999.ebuild?r1=1.168&r2=1.169