Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 526364 (perl-subslot) - [TRACKER] Packages missing a := slot operator in the dev-lang/perl dependency
Summary: [TRACKER] Packages missing a := slot operator in the dev-lang/perl dependency
Status: CONFIRMED
Alias: perl-subslot
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL: http://dilfridge.blogspot.de/2014/11/...
Whiteboard:
Keywords: Tracker
Depends on: 526366 529462 531144 552800 553326 555348 556512 557082 583794 594198
Blocks:
  Show dependency tree
 
Reported: 2014-10-21 20:12 UTC by Andreas K. Hüttel
Modified: 2017-05-04 15:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2014-10-21 20:12:47 UTC
No talking here please.
Comment 1 Pacho Ramos gentoo-dev 2015-06-25 13:30:31 UTC
Is there any document or something explaining when a package needs to specify the := dep for perl? I have seen many packages still lack that and even some I commit :S, and I would like to start committing fixed stuff finally ;)

Thanks a lot for the info
Comment 2 Andreas K. Hüttel gentoo-dev 2015-06-25 13:45:00 UTC
Yes, here: 
http://dilfridge.blogspot.de/2014/11/rdepending-on-perl-itself.html