Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 524242 - media-sound/audacity-2.1.2 version bump
Summary: media-sound/audacity-2.1.2 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
: 545178 (view as bug list)
Depends on: 579944
Blocks: 417869
  Show dependency tree
 
Reported: 2014-10-01 19:17 UTC by Frank Krömmelbein
Modified: 2016-05-14 05:19 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log for audacity-2.1.2 with USE="-midi" (audacity-2.1.2:20160315-073559.log,511.15 KB, text/x-log)
2016-03-15 07:55 UTC, Alexander Stein
Details
build.log (USE=vamp) (build.log,857.88 KB, text/plain)
2016-04-14 09:35 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Krömmelbein 2014-10-01 19:17:25 UTC
Release notes:
http://wiki.audacityteam.org/wiki/Release_Notes_2.0.6

Reproducible: Always
Comment 1 Nikoli 2014-10-12 02:34:42 UTC
"Linux) Audacity may not always compile against supported versions of libav or FFmpeg. Audacity 2.0.6 supports FFmpeg 1.2 or higher (FFmpeg 2.2.3 is known to work) or libav 0.8 or higher. "
Comment 2 tman 2015-01-11 03:40:36 UTC
wie have now 2015 can we have now a bump of this ebuild in portage?
Comment 3 Fabian Henze 2015-01-27 08:21:22 UTC
Can we at least get a masked 2.0.6 bump? Unfortunately renaming the ebuild does not seem to work
Comment 4 Dennis Schridde 2015-03-07 10:28:06 UTC
(In reply to Nikoli from comment #1)
> "Linux) Audacity may not always compile against supported versions of libav
> or FFmpeg. Audacity 2.0.6 supports FFmpeg 1.2 or higher (FFmpeg 2.2.3 is
> known to work) or libav 0.8 or higher. "

>=media-sound/ffmpeg-2.2 are available in tilda, as is >=media-sound/libav-9. Is this sufficient to get media-sound/audacity-2.0.6 to compile? Did anyone succeed with the bump?
Comment 5 Frank Krömmelbein 2015-03-30 09:13:34 UTC
29.03.2015: Audacity 2.1.0 Released
https://code.google.com/p/audacity/source/browse/audacity-src/trunk/README.txt
Comment 6 Manuel Rüger gentoo-dev 2015-03-31 20:27:34 UTC
*** Bug 545178 has been marked as a duplicate of this bug. ***
Comment 7 Mikael Magnusson 2015-04-10 08:51:47 UTC
It (2.0.6) works for me with -ffmpeg, but I also had to add --without-lv2 as it seems the bundled lv2 only compiles if there is a system lv2 installed. I didn't try installing a system lv2 first.
Comment 8 Frank Krömmelbein 2015-05-23 11:25:02 UTC
Ping!
Comment 9 Frank Krömmelbein 2015-07-16 19:08:15 UTC
5 Juli 2015: Audacity 2.1.1 Released
Audacity 2.1.1 replaces all previous versions.

The most visible new feature is scrubbing and seeking , including backwards play. Updates to Quick-Play also help with finding a precise position in the audio.
You can now install plug-ins without restarting Audacity or add and remove any effect or generator from the menus.
Over 50 bugs have been addressed with this release. Edits are now processed much faster in longer projects of a few hours duration.
Effects now have presets. A new Limiter replaces the Hard Limiter effect. There's a new version of Vocal Removal, a cross-fade effect for combining clips on the same track and 'classic filters' available as an opt-in effect.
There's also been lots of work behind the scenes, including VI usability enhancements and upgrade to new libraries.
Comment 10 Ben de Groot (RETIRED) gentoo-dev 2015-07-20 15:26:50 UTC
I have just added a masked audacity-2.1.1 ebuild. It mostly works, but there are a few things we need to fix before we can unmask it.

TODO:
- figure out why system libs for lv2, portaudio, and portmidi are not recognized
- failure with USE=vamp: libtool: link: `/usr/lib64/libvamp-hostsdk.la' is not a valid libtool archive
- roll new automagic patch (we need explicit switches for alsa and jack)

@Richard: can we get upstream explicit configure switches for --with-alsa and --with-jack please?
Comment 11 Frank Krömmelbein 2016-01-20 16:43:43 UTC
Version 2.1.2 is now available, changelog:
http://wiki.audacityteam.org/wiki/Release_Notes_2.1.2
Comment 12 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2016-02-09 15:26:35 UTC
2.1.2 is now on wxGTK 3.0 which is nice. Can we get a bump please?
Comment 13 Alexander Stein 2016-03-15 07:55:10 UTC
Renaming the ebuild for version 2.1.2 works so far, but USE="-midi" is broken and does not compile. Build log is attached.
Comment 14 Alexander Stein 2016-03-15 07:55:46 UTC
Created attachment 428276 [details]
build log for audacity-2.1.2 with USE="-midi"
Comment 15 Lars Wendler (Polynomial-C) gentoo-dev 2016-03-31 12:23:23 UTC
commit b51f7276663df24e8dd1aced9fe19ab6a07f6a56
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Thu Mar 31 14:21:49 2016

    media-video/h264enc: Bump to version 10.4.7
    
    Package-Manager: portage-2.2.28
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Comment 16 Lars Wendler (Polynomial-C) gentoo-dev 2016-03-31 12:23:59 UTC
D'oh, scratch that...

the real commit I wanted to post here is this one:

commit 7a91644d1007d90cca81f74cd6cfc8e3d2ef9dda
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Thu Mar 31 14:17:40 2016

    media-sound/audacity: Bump to version 2.1.2 (bug #524242).
    
    Package-Manager: portage-2.2.28
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Comment 17 Frank Krömmelbein 2016-03-31 13:14:21 UTC
Thank you very much @Lars!
Comment 18 Mikael Magnusson 2016-04-09 18:23:15 UTC
The lv2 dep / USE flag is a bit wonky. audacity needs not only lv2, but also lilv and suil,
   dnl see if lv2 is installed on the system

   PKG_CHECK_MODULES(LV2, [lv2 lilv-0 >= 0.16 suil-0 >= 0.8.2],
                     LV2_SYSTEM_AVAILABLE="yes",
                     LV2_SYSTEM_AVAILABLE="no")

If either of these are missing, it uses the local version of lv2. The USE-flag lv2 in the ebuild adds the lv2 dependency but not suil and lilv, and passes --with-lv2. However, the installed lv2 dependency will never be used unless the user manually installs suil and lilv. IDK if we want to have a separate system-lv2 flag or just make the lv2 flag add these additional libraries too. (or alternatively remove the dependency on lv2 instead).
Comment 19 Mikael Magnusson 2016-04-09 18:39:19 UTC
Re USE=vamp not working, the error I got was
libtool: link: `/usr/lib64/libvamp-hostsdk.la' is not a valid libtool archive

Hilariously, this can be resolved by adding these lines to the top of the file:
# libvamp-hostsdk.la - a libtool library file
# Generated by libtool (GNU libtool) 2.4.2 Debian-2.4.2-1.3ubuntu1
#
# Please DO NOT delete this file!
# It is necessary for linking the library.

I don't know why they were missing, or why libtool errors out if comments are missing.
Comment 20 Dennis Schridde 2016-04-14 08:48:54 UTC
(In reply to Frank Krömmelbein from comment #17)
> Thank you very much @Lars!

According to package.mask, this is not entirely fixed, yet:
# Ben de Groot <yngwin@gentoo.org> (20 Jul 2015)
# Version bump is a WIP, see bug #524242
# It works (except USE=vamp) but is not up to Gentoo standards yet
>=media-sound/audacity-2.1.1

Maybe this bug should stay open, until the ebuild can be unmasked?
Comment 21 Dennis Schridde 2016-04-14 09:35:04 UTC
Created attachment 430424 [details]
build.log (USE=vamp)

(In reply to Mikael Magnusson from comment #19)
> Re USE=vamp not working, the error I got was
> libtool: link: `/usr/lib64/libvamp-hostsdk.la' is not a valid libtool archive
> 
> Hilariously, this can be resolved by adding these lines to the top of the
> file:
> # libvamp-hostsdk.la - a libtool library file
> # Generated by libtool (GNU libtool) 2.4.2 Debian-2.4.2-1.3ubuntu1
> #
> # Please DO NOT delete this file!
> # It is necessary for linking the library.
> 
> I don't know why they were missing, or why libtool errors out if comments
> are missing.

Confirmed!
Comment 22 Dennis Schridde 2016-04-14 09:39:19 UTC
(In reply to Dennis Schridde from comment #21)
> Created attachment 430424 [details]
> build.log (USE=vamp)
> 
> (In reply to Mikael Magnusson from comment #19)
> > Re USE=vamp not working, the error I got was
> > libtool: link: `/usr/lib64/libvamp-hostsdk.la' is not a valid libtool archive
>
> Confirmed!

See-Also: https://bugs.gentoo.org/show_bug.cgi?id=579944
Comment 23 Dennis Schridde 2016-05-14 05:19:40 UTC
(In reply to Dennis Schridde from comment #22)
> (In reply to Dennis Schridde from comment #21)
> > (In reply to Mikael Magnusson from comment #19)
> > > Re USE=vamp not working, the error I got was
> > > libtool: link: `/usr/lib64/libvamp-hostsdk.la' is not a valid libtool archive
> >
> > Confirmed!
> 
> See-Also: https://bugs.gentoo.org/show_bug.cgi?id=579944

A patch for that issue is available in the bugreport.