Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 417869 - media-sound/audacity-2.0.0 does not compile against || ( >=media-video/ffmpeg-0.11 >=media-video/libav-9 )
Summary: media-sound/audacity-2.0.0 does not compile against || ( >=media-video/ffmpeg...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
: 421585 (view as bug list)
Depends on: 524242
Blocks: ffmpeg-0.11-breakage libav-9
  Show dependency tree
 
Reported: 2012-05-27 20:22 UTC by shinydoofy
Modified: 2014-10-12 02:34 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
bzip2'd build.log (build.log.bz2,24.38 KB, application/octet-stream)
2012-05-27 20:24 UTC, shinydoofy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shinydoofy 2012-05-27 20:22:16 UTC
When trying to compile audacity against =media-video/ffmpeg-0.11, it fails. See the attached logs.

Reproducible: Always

Steps to Reproduce:
1. Have =media-video/ffmpeg-0.11 installed.
2. # emerge -1v audacity

Actual Results:  
Compilation fails.

Expected Results:  
Compilation succeeds.

Portage 2.2.0_alpha108 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.3.0-64 x86_64)
=================================================================
System uname: Linux-3.3.0-64-x86_64-Intel-R-_Core-TM-_i7_CPU_X_980_@_3.33GHz-with-gentoo-2.1
Timestamp of tree: Sun, 27 May 2012 14:45:01 +0000
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo local glc
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula cadsoft ut2003 AdobeFlash-10.3 QUAKE4 Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS=""
MAKEOPTS="-j13"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/glc"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa amd64 bash-completion berkdb bluetooth bluray branding bzip2 cdr cjk cli consolekit cracklib crypt cups cursors cxx dbus dri dts dvd dvdr enca ffmpeg firefox flac fortran gdbm gif glut gpm gtk icons iconv id3 id3tag introspection ipv6 java jpeg jpeg2k kde libcaca libnotify libsamplerate lm_sensors lzo mad matroska mmx mmxext modules mp3 mp4 mpeg mudflap multilib mysql ncurses networkmanager nls nptl nsplugin nvidia ogg ogm opengl openmp pcre pdf png policykit pppd qt3support qt4 readline samba sdl session smp speex srt sse sse2 ssl ssse3 svg tcpd tetex theora tiff truetype unicode usb vdpau vorbis wmf x264 xattr xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 shinydoofy 2012-05-27 20:24:35 UTC
Created attachment 313321 [details]
bzip2'd build.log
Comment 2 Agostino Sarubbo gentoo-dev 2012-06-17 15:50:16 UTC
*** Bug 421585 has been marked as a duplicate of this bug. ***
Comment 3 Richard Ash 2012-06-30 09:46:10 UTC
Ack as known upstream issue, and it's the same in 2.0.1.
http://bugzilla.audacityteam.org/show_bug.cgi?id=540

Needs a clever patch to allow configure to detect what symbols FFmpeg is exporting and select the right code to call them. This gets messy when added to 0.5 and 0.8 support already present in the code base.
Comment 4 Alexis Ballier gentoo-dev 2012-11-08 14:49:29 UTC
Note: The fix does not seem trivial at all. Meanwhile this gets fixed upstream, we will have to mask ffmpeg support in audacity when we will unmask ffmpeg 1.0 to ~arch.
Comment 5 Alexis Ballier gentoo-dev 2013-02-15 19:21:08 UTC
Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/profiles/ChangeLog,v
retrieving revision 1.7496
diff -u -B -r1.7496 ChangeLog
--- ChangeLog	14 Feb 2013 22:33:47 -0000	1.7496
+++ ChangeLog	15 Feb 2013 19:20:37 -0000
@@ -6,6 +6,10 @@
 # Only typo fixes which don't affect portage/repoman behaviour could be avoided
 # here. If in doubt put a record here!
 
+  15 Feb 2013; Alexis Ballier <aballier@gentoo.org> base/package.use.mask:
+  Mask media-sound/audacity[ffmpeg], it needs to be fixed upstream to cope with
+  new releases of FFmpeg/libav. bug #417869
+
   14 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> updates/1Q-2013:
   Move rt61-firmware from net-wireless/ to sys-firmware/ category.
 
Index: base/package.use.mask
===================================================================
RCS file: /var/cvsroot/gentoo-x86/profiles/base/package.use.mask,v
retrieving revision 1.436
diff -u -B -r1.436 package.use.mask
--- base/package.use.mask	11 Feb 2013 09:19:44 -0000	1.436
+++ base/package.use.mask	15 Feb 2013 19:20:37 -0000
@@ -6,6 +6,11 @@
 # New entries go on top.
 #
 
+# Alexis Ballier <aballier@gentoo.org> (15 Feb 2013)
+# Needs a huge patch to build against recent releases of FFmpeg/libav.
+# Mask it until upstream fixes it. Bug #417869
+media-sound/audacity ffmpeg
+
 # Julian Ospald <hasufell@gentoo.org> (10 Feb 2013)
 # This flag is experimental and breaks googleearth
 # in numerous ways. Unsupportable.