Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 523932 - dev-db/mariadb-10.0.14: libmysql_versions.ld:155:9: invalid use of VERSION in input file
Summary: dev-db/mariadb-10.0.14: libmysql_versions.ld:155:9: invalid use of VERSION in...
Status: RESOLVED DUPLICATE of bug 508724
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-28 11:37 UTC by Erik Zeek
Modified: 2014-09-28 14:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (dev-db:mariadb-10.0.14:20140928-111343.log.gz,36.34 KB, application/gzip)
2014-09-28 11:37 UTC, Erik Zeek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Zeek 2014-09-28 11:37:15 UTC
Created attachment 385662 [details]
build log

Mariadb is currently failing with:

/usr/bin/ar cr libmysqlclient.a  CMakeFiles/mysqlclient.dir/mysqlclient_depends.c.o
/usr/bin/ranlib libmysqlclient.a
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/bin/ld: error: /gentoo/tmp/portage/dev-db/mariadb-10.0.14/work/mysql-abi_x86_32.x86/libmysql/libmysql_versions.ld:155:9: invalid use of VERSION in input file
collect2: error: ld returned 1 exit status

emerge --info '=dev-db/mariadb-10.0.14::gentoo'
Portage 2.2.14_rc1 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.3, glibc-2.19-r1, 3.16.3-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.16.3-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1055T_Processor-with-gentoo-2.2
KiB Mem:    16434676 total,    174844 free
KiB Swap:   10491892 total,  10446548 free
Timestamp of tree: Sun, 28 Sep 2014 10:15:01 +0000
ld GNU gold (Gentoo 2.24 p1.4 2.24) 1.11
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p49
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.8, 3.3.5-r1, 3.4.1
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo sunrise science kde jmbsvicetto ddemidov steam-overlay x11 zeekec
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -mtune=native -march=native -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -mtune=native -march=native -O2"
DISTDIR="/gentoo/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going -j 3 --backtrack=1000"
FCFLAGS="-O2 -pipe -mtune=native -march=native -O2"
FEATURES="assume-digests binpkg-logs candy cgroup clean-logs collision-protect compress-build-logs config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -mtune=native -march=native -O2"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--enable-new-dtags -Wl,--hash-style=gnu"
MAKEOPTS="-j8 --load-average=18"
PKGDIR="/gentoo/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-i --no-p --omit-dir-times"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/gentoo/tmp"
PORTDIR="/gentoo/portage"
PORTDIR_OVERLAY="/gentoo/local/layman/sunrise /gentoo/local/layman/science /gentoo/local/layman/kde /gentoo/local/layman/jmbsvicetto /gentoo/local/layman/ddemidov /gentoo/local/layman/steam /gentoo/local/layman/x11 /gentoo/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="256-color 3des 3dnow 3dnowext 3ds 64bit R S3TC X a2ps a52 aac aacplus aacs aalib accessibility ace acl acoustid acpi additions addressbook adolc aes aesicm aften agg aimodules aio airplay akonadi alac alaw alevt alisp all_sfx alsa amd64 amr anacron analitza ancient android animgif ansi ant ao apache apache2 apm apng arcfour archive armadillo arpack artworkextra asdf asn asn1 asyncns atm atsc attica audacious audio audiofile audit auth authdaemond auto-completion autoipd automap automount autotools autotrace avahi bash-completion bazaar bcmath bdf berkdb bidi bitmap bittorrent bl blas blender blksha1 bloodsuckermaps bluray bookmarks boost branding btrfs bugzilla builder bwscheduler bzip2 c++0x cairo cal3d calendar canberra canna caps cblas-external ccache cdda cddb cdf cdinstall cdparanoia cdr cdrom cdsound cegui celt cgi chardet charmap cheats checkpath chm chroot cilk city cjk clamav clang cli client clucene clutter cmake collab collada color colordiff compress consolekit context contrast contrib convert-mozilla-cookies corefonts cpio cpumining cracklib cramfs crashreporter cron crypt cryptsetup csc cscope css ctype cups curl curlwrappers custom-optimization cvs cvsgraph cxx d dap data dbus ddate debug-frame debug-utils debugger declarative demo deprecated designer-plugin desktopglobe detex development devhelp device-mapper dga dhcp dia dirac discouraged distinct-l djvu dlna dmraid dns docbook doctool doom doomsday dot double-precision down-root downloadorder dri dri3 drm drmaa dtmf dts dv dvb dvd dvdnav dvdr dvi dvipdfm ebook editor egl eigen elf elfutils emacs embedded emboss emf emovix enca encode enscript epspdf epub ethernet examples excel exceptions exif expoblending extensions extra extra-algorithms extra-cardsets extra-ciphers extra-tools extraengine extras faac faad facebook facedetect faillog fakevim fam fancy fastcgi fat fax fbcondecor fcgi fdk festival ffmpeg fftw filter finger firefox firewalld firmware fits flac flash flatfile flickr fluidsynth fma fmod fontconfig fontforge fonts foomaticdb fortran fortran95 fortune fpx frei0r ftp fuse g3dvl gadu gallium games gbm gcdmaster gcrypt gd gdal gdbm gdu geoip geolocation geos gif gimp git gkrellm glade glamor glep gles gles1 gles2 glew glgd glib gltf glut gmail gmath gme gml gmp gmtfull gmttria gnome-print gnuplot go gocr gold google gopher gost gpac gpg gphoto2 gpm grammar graphics graphicsmagick graphite graphviz grass groupwise gsf gsl gsm gstreamer gtk gtk3 gtkhtml gts guidexml guile gzip gzip-el h224 h281 h323 handbook hash hbci hddtemp hdf hdf5 hdri help hesiod heterogeneous hexen high-ints highlight history hou hscolour html htmlreport http httpd humanities hunspell hwinfo hyphenation i18n ical iconv icoutils icq icu id3tag ide idea idn ieee1394 ignore-case image imagemagick imaging imap imlib inifile inkjar inotify introspection iplayer ipv6 ipython irc isag ithreads ivr jabber jadetex jai java java6 javacomm javascript jbig jce jimi jit jmf john jpeg jpeg2k json kate kde kdecards kdenlive kdepim kdrive kerberos kernel kernel-patch keymap kipi konqueror kontact kpathsea kvm ladspa lame lapack lasi latex lcms ldap lensfun libass libburn libffi libkms liblockfile libnotify libproxy libsamplerate libsecret libssh2 libtiger libv4l libvirtd libwww lightning lights live llvm llvm-gcc llvm-shared-libs lm_sensors lock log log4j logrotate logviewer logwatch lqr lto lua luatex lvm lxc lyrics lzma lzo mad madde mail maildir map mapimg maps math mathml matplotlib matroska maui mbrola md5sum mdadm mdnsresponder-compat media mediawiki melt memmap mercurial metapost metis mhash midi mikmod mime minizip mixer mjpeg mmap mms mmx mmxext mng mod modpack modplug module modules mono mopac7 mount mozdom mozilla mp3 mp3tunes mp4 mpeg mpi_njtree mplayer mpqc mtp mudflap multilib multimedia multiprocess multitarget multiuser musepack music musicbrainz mysql mysqli na_dd na_dtv na_icons nas natspec nbconvert ncat ncurses ndiff net netcdf nethack netpbm network network-cron networking new-clx new-login nfs nfsdcld nfsv3 nfsv41 nls nmap-update nntp nocd nosource notebook nowin nowlistening nping npp nptl nsplugin nss nsscache nssdb ntfs ntfsprogs ntp numa numpy nut nuv oauth objc ocaml ocr ocrad octave odbcmanual odf ofa offensive offlinehelp ofx ogg ogm okteta okular omega oom openal openbabel opencl openexr opengl openinventor openmax openmp openssl opensslcrypt openstreetmap openvg openxml optimization opus orc osc oscar osd osdmenu osgapps osmesa otr ots pager pam pam_ssh pango panorama paranoidmsg parcheck parse-clocks parted patented pbins pbs pch pci pcntl pcre pcre16 pdf pdfannotextractor pdl2 pdo perl pgo pgplot phonon php phyp physfs pink pipe pkcs11 plasma player playlist plotutils plugins png pnm policykit pop portage posix postfix postproc postscript ppds pptx prison proc proj projectm psf pstricks pth publishers pulseaudio pvr pygments pylint python python3 q16 q32 q64 q8 qalculate qd qemu qhull qimageblitz qml qnx qos qrcode qscintilla qt-dbus qt-faststart qt3support qt4 qthelp quesoglc quicktime quota quotes qwt r600-llvm-compiler radio ramfs rar raw rc5 rcs rdesktop readline redeyes redland regex remix remote rendering reports resources reviewboard rfc3779 rle rogue romio root rpc rpm rrdcgi rrdtool rss rtc rtf rtmp rtsp s3tc samba sasl sbcl scale0tilt scanfolder scanner schroedinger science scipy scotch screen script scripting scripts scripttools sdk sdl sdl-image sdlgfx search search-index secure-delete semantic-desktop sensord sensors server session setproctitle setup sftp sha512 shadow shapefile shared-glapi sharedmem shine shm shmvideo shorten shout sid sift sigsegv sip sipim skins skype slp smbclient smbsharemodes smbtav2 smime smp smpeg sms sndfile soap sockets socks socks5 solver songs soprano sou sound sounds soup sourceview sox spamassassin sparse spatialite speech speex spell sql sqlite sqlite3 srt srtp sse sse2 sse3 ssh ssl stars startup-notification statistics stats steamfonts steamgames_defenders_quest steamgames_dwarfs steamgames_hammerwatch steamgames_journey_down steamgames_painkiller steamgames_shatter steamgames_source_engine steamgames_tf2 steamgames_trine2 steamgames_unwritten_tales steamruntime stlport stream streaming subject-rewrite subtitles subunit subversion suexec suid superlu svg swat swig switcher symlink syslog system-cairo system-icu system-jpeg system-sqlite systeminfo sysvipc szip t1lib taamey taglib tcl tcmalloc tcpd templates tesseract testbed tex4ht texi2html textures tga themedesigner themes theora thesaurus thin-splines threads threadsafe thumbnail thunar tidy tiff timezone tk tls tokenizer toolbar tools torque track-src-odirect transcode translator trayicon truetype tts tty-helpers tv tv_check tv_combiner tv_pick_cgi twolame type3 udev udisks udunits umfpack uml unicode unique unwind unzip upnp upower urandom urlpicpreview usb userpriv utempter utils uudeview uuid v4l vaapi valgrind vamp vcd vcdx vde vdpau vdr verify-file video videos videoslideshow vim vim-pager vim-syntax virt-network virtualbox virtuoso visibility visual vlc vlm vnc voice vorbis vpx vserver vxml warmstarts wav wavpack weather web webcam webdav webdav-neon webdav-serf webinterface webkit webm webp webpresence wide-unicode wifi wiki winbind windeco wineappdb wininst winpopup wma wma-fixed wmf word-perfect wordperfect wpg wps wxwidgets wyfv x264 xa xanim xattr xcap xcb xcomposite xdm-auth xerces-c xetex xext xface xforms xforward xft xhtml xine xinerama xinetd xlib-xcb xml xmlpatterns xmlreader xmlrpc xmlwriter xmp xnest xorg xosd xplanet xpm xrandr xrender xscreensaver xsettings xsl xslt xtended xterm xv xvfb xvid xvmc yaepg yahoo youtube zeitgeist zeroconf zip zlib zsh-completion zvbi" ABI_X86="64 32" ALSA_CARDS="intel8x0 intel8x0m pxa2xx-ac97 hda-intel" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias cgi cgid authn_core authz_core unixd socache_shmcb lbmethod_bytraffic slotmem_shm" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" DRACUT_MODULES="btrfs crypt syslog biosdevname caps crypt-gpg ssh-client syslog" DVB_CARDS="af9005 bcm3510 cx18 cx231xx cx23885 mpc718 nxt200x sp8870 sp887x" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer nlpsolver pdfimport scripting-javascript wiki-publisher scripting-beanshell" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5 php5-4 php5-2" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 ppc ppc64 ppc64abi32 x86_64" RUBY_TARGETS="ruby20 ruby21" SANE_BACKENDS="canon canon630u canon_dr canon_pp hp hp3500 hp3900 hp4200 hp5400 hp5590 hpljm1005 hpsj5s net pnm" USERLAND="GNU" VIDEO_CARDS="r600 radeon fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2014-09-28 14:07:06 UTC

*** This bug has been marked as a duplicate of bug 508724 ***