Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 508724 - dev-db/mariadb-5.5.37 - ld: error: .../work/mariadb-5.5.37_build/libmysql/libmysql_versions.ld:156:9: invalid use of VERSION in input file
Summary: dev-db/mariadb-5.5.37 - ld: error: .../work/mariadb-5.5.37_build/libmysql/lib...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
: 523932 538252 (view as bug list)
Depends on:
Blocks: gold-tracker
  Show dependency tree
 
Reported: 2014-04-25 20:25 UTC by Maks Verver
Modified: 2015-03-17 19:46 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,747.88 KB, text/plain)
2014-04-25 20:27 UTC, Maks Verver
Details
emerge --info (emerge-info.txt,5.51 KB, text/plain)
2014-04-25 20:27 UTC, Maks Verver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maks Verver 2014-04-25 20:25:48 UTC
mariadb fails to link libmysqlclient.so when compiling with GNU gold as the linker.

Reproducible: Always

Steps to Reproduce:
binutils-config --linker ld.gold
emerge mariadb
Actual Results:  
Linking CXX shared library libmysqlclient.so
cd /var/tmp/portage/dev-db/mariadb-5.5.37/work/mariadb-5.5.37_build/libmysql && /usr/bin/cmake -E cmake_link_script CMakeFiles/libmysql.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++  -fPIC -Wall -O2 -pipe -fno-strict-aliasing -felide-constructors -fno-implicit-templates -fno-exceptions -fno-rtti -fno-strict-aliasing  -Wno-unused-parameter -fno-implicit-templates -fno-exceptions -fno-rtti -DNDEBUG -DDBUG_OFF  -Wl,--no-undefined -Wl,--no-undefined -Wl,/var/tmp/portage/dev-db/mariadb-5.5.37/work/mariadb-5.5.37_build/libmysql/libmysql_versions.ld  -Wl,-O1 -Wl,--as-needed -shared -Wl,-soname,libmysqlclient.so.18 -o libmysqlclient.so.18.0.0 CMakeFiles/libmysql.dir/libmysql_exports_file.cc.o -lpthread libclientlib.a ../dbug/libdbug.a ../strings/libstrings.a ../vio/libvio.a ../mysys/libmysys.a -lz -lssl -lcrypto -lcrypto -ldl ../dbug/libdbug.a ../mysys/libmysys.a ../strings/libstrings.a -lz -lm -lpthread 
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: error: /var/tmp/portage/dev-db/mariadb-5.5.37/work/mariadb-5.5.37_build/libmysql/libmysql_versions.ld:156:9: invalid use of VERSION in input file
Comment 1 Maks Verver 2014-04-25 20:27:11 UTC
Created attachment 375738 [details]
build.log
Comment 2 Maks Verver 2014-04-25 20:27:53 UTC
Created attachment 375740 [details]
emerge --info
Comment 3 Brian Evans Gentoo Infrastructure gentoo-dev 2014-04-28 13:31:11 UTC
Listed upstream as MDEV-5982
Comment 4 Mark R. Pariente 2014-07-30 09:40:42 UTC
Have the same issue with dev-db/mariadb-10.0.12 as well.
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2014-09-28 14:07:06 UTC
*** Bug 523932 has been marked as a duplicate of this bug. ***
Comment 6 Brian Evans Gentoo Infrastructure gentoo-dev 2015-01-30 15:22:17 UTC
*** Bug 538252 has been marked as a duplicate of this bug. ***
Comment 7 Brian Evans Gentoo Infrastructure gentoo-dev 2015-03-17 19:46:13 UTC
+  17 Mar 2015; <grknight@gentoo.org> mysql-multilib.eclass:
+  Move flag modifications to apply once for all ABIs; Use tc-ld-disable-gold
+  for bug 508724; Move tokudb check to pkg_pretend


Forced to use ld.bfd per above commit since upstream cannot come to a solution.