Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522952 - www-client/qupzilla-1.8.0 version bump and add USE=qt5
Summary: www-client/qupzilla-1.8.0 version bump and add USE=qt5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard: [qt overlay]
Keywords:
: 485680 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-16 14:47 UTC by Alpha Bravo
Modified: 2014-10-02 03:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
qupzilla-1.6.6-r1.ebuild added IUSE qt5 (qupzilla-1.6.6-r1.ebuild,2.91 KB, text/plain)
2014-09-16 14:48 UTC, Alpha Bravo
Details
qupzilla-1.6.6-r1.ebuild added IUSE qt5 (qupzilla-1.6.6-r1.ebuild,3.09 KB, text/plain)
2014-09-16 15:19 UTC, Alpha Bravo
Details
qupzilla-1.6.6-r1.ebuild added IUSE qt5 (qupzilla-1.6.6-r1.ebuild,3.10 KB, text/plain)
2014-09-16 15:29 UTC, Alpha Bravo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alpha Bravo 2014-09-16 14:47:04 UTC
qupzilla-1.6.6 already can be built with Qt5 support, which now is in portage tree (yet atm still masked). Building with Qt5 should e.g. improve html5 performance.

Reproducible: Always
Comment 1 Alpha Bravo 2014-09-16 14:48:17 UTC
Created attachment 384856 [details]
qupzilla-1.6.6-r1.ebuild added IUSE qt5
Comment 2 Alpha Bravo 2014-09-16 15:19:45 UTC
Created attachment 384868 [details]
qupzilla-1.6.6-r1.ebuild added IUSE qt5
Comment 3 Alpha Bravo 2014-09-16 15:29:59 UTC
Created attachment 384870 [details]
qupzilla-1.6.6-r1.ebuild added IUSE qt5
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2014-09-16 19:09:09 UTC
Comment on attachment 384870 [details]
qupzilla-1.6.6-r1.ebuild added IUSE qt5

--- qupzilla-1.6.6.ebuild       2014-05-28 11:45:47.000000000 +0200
+++ -   2014-09-16 21:08:51.397536474 +0200
@@ -7,7 +7,7 @@
 PLUGINS_HASH='b19f6e0b83baca40e96019ccda329b88459e6a7f'
 PLUGINS_VERSION='1.6.3' # if there are no updates, we can use the older archive

-inherit l10n multilib qt4-r2 vcs-snapshot
+inherit l10n multilib qmake-utils qt4-r2 vcs-snapshot
 
 DESCRIPTION="Qt WebKit web browser"
 HOMEPAGE="http://www.qupzilla.com/"
@@ -17,17 +17,33 @@
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86"
-IUSE="dbus debug gnome-keyring kde nonblockdialogs"
+IUSE="dbus debug gnome-keyring kde nonblockdialogs qt4 qt5"

-RDEPEND="dev-libs/openssl:0
-       >=dev-qt/qtcore-4.8:4
-       >=dev-qt/qtgui-4.8:4
-       >=dev-qt/qtscript-4.8:4
-       >=dev-qt/qtsql-4.8:4[sqlite]
-       >=dev-qt/qtwebkit-4.8:4
-       dbus? ( >=dev-qt/qtdbus-4.8:4 )
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+RDEPEND="
+        dev-libs/openssl:0
        gnome-keyring? ( gnome-base/gnome-keyring )
-       kde? ( kde-base/kwalletd:4 )"
+        kde? ( kde-base/kwalletd:4 )
+        qt4? (
+                >=dev-qt/qtcore-4.7:4
+                >=dev-qt/qtgui-4.7:4
+                >=dev-qt/qtscript-4.7:4
+                >=dev-qt/qtsql-4.7:4
+                >=dev-qt/qtwebkit-4.7:4
+                dbus? ( >=dev-qt/qtdbus-4.7:4 )
+        )
+        qt5? (
+                dev-qt/qtcore:5
+                dev-qt/qtgui:5
+                dev-qt/linguist:5
+                dev-qt/qtconcurrent:5
+                dev-qt/qtprintsupport:5
+                dev-qt/qtscript:5
+                dev-qt/qtsql:5[sqlite]
+                dev-qt/qtwebkit:5
+                dbus? ( dev-qt/qtdbus:5 )
+        )"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"

@@ -58,7 +74,11 @@
                KDE_INTEGRATION=$(usex kde 'true' '') \
                NONBLOCK_JS_DIALOGS=$(usex nonblockdialogs 'true' '')

-       eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       if use qt4 ; then
+               eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       else
+               eqmake5 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       fi
 }
 
 src_install() {
@@ -75,3 +95,4 @@
                ewarn "For using adobe flash plugin you most likely need to run \"paxctl-ng -m /usr/bin/qupzilla\""
        fi
 }
+
Comment 5 Davide Pesavento gentoo-dev 2014-09-17 00:00:21 UTC
I don't understand why this blocks bug 454132
Comment 6 Davide Pesavento gentoo-dev 2014-09-17 00:06:02 UTC
(In reply to Jeroen Roovers from comment #4)
> Comment on attachment 384870 [details]
> qupzilla-1.6.6-r1.ebuild added IUSE qt5
> 
> --- qupzilla-1.6.6.ebuild       2014-05-28 11:45:47.000000000 +0200
> +++ -   2014-09-16 21:08:51.397536474 +0200
> @@ -7,7 +7,7 @@
>  PLUGINS_HASH='b19f6e0b83baca40e96019ccda329b88459e6a7f'
>  PLUGINS_VERSION='1.6.3' # if there are no updates, we can use the older
> archive
> 
> -inherit l10n multilib qt4-r2 vcs-snapshot
> +inherit l10n multilib qmake-utils qt4-r2 vcs-snapshot
>  

Stop using qt4-r2

>  DESCRIPTION="Qt WebKit web browser"
>  HOMEPAGE="http://www.qupzilla.com/"
> @@ -17,17 +17,33 @@
>  LICENSE="GPL-3"
>  SLOT="0"
>  KEYWORDS="~amd64 ~arm ~x86"
> -IUSE="dbus debug gnome-keyring kde nonblockdialogs"
> +IUSE="dbus debug gnome-keyring kde nonblockdialogs qt4 qt5"
> 
> -RDEPEND="dev-libs/openssl:0
> -       >=dev-qt/qtcore-4.8:4
> -       >=dev-qt/qtgui-4.8:4
> -       >=dev-qt/qtscript-4.8:4
> -       >=dev-qt/qtsql-4.8:4[sqlite]
> -       >=dev-qt/qtwebkit-4.8:4
> -       dbus? ( >=dev-qt/qtdbus-4.8:4 )
> +REQUIRED_USE="^^ ( qt4 qt5 )"
> +
> +RDEPEND="
> +        dev-libs/openssl:0
>         gnome-keyring? ( gnome-base/gnome-keyring )
> -       kde? ( kde-base/kwalletd:4 )"
> +        kde? ( kde-base/kwalletd:4 )
> +        qt4? (
> +                >=dev-qt/qtcore-4.7:4

Why did you lower the dep to 4.7? It doesn't make sense anyway, it's an obsolete version, no longer in tree.

> +                >=dev-qt/qtgui-4.7:4
> +                >=dev-qt/qtscript-4.7:4
> +                >=dev-qt/qtsql-4.7:4

You forgot [sqlite] here

> +                >=dev-qt/qtwebkit-4.7:4
> +                dbus? ( >=dev-qt/qtdbus-4.7:4 )
> +        )
> +        qt5? (
> +                dev-qt/qtcore:5
> +                dev-qt/qtgui:5
> +                dev-qt/linguist:5

I doubt that linguist is a dep. If lrelease is needed, it's in dev-qt/linguist-tools:5
Comment 7 Alpha Bravo 2014-09-17 20:15:01 UTC
--- qupzilla-1.6.6.ebuild      2014-05-28 11:45:47.000000000 +0200
+++ -   2014-09-17 22:10:04.253221659 +0200
@@ -1,13 +1,13 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/qupzilla-1.6.6.ebuild,v 1.1 2014/05/28 09:45:47 pinkbyte Exp $
+# $Header: $
 
 EAPI=5
 PLOCALES="ar_SA bg_BG ca_ES cs_CZ de_DE el_GR es_ES es_MX es_VE eu_ES fa_IR fr_FR gl_ES he_IL hu_HU id_ID it_IT ja_JP ka_GE lg lv_LV nl_NL nqo pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sr_BA sr_BA@latin sr_RS sr_RS@latin sv_SE uk_UA uz@Latn zh_CN zh_TW"
 PLUGINS_HASH='b19f6e0b83baca40e96019ccda329b88459e6a7f'
 PLUGINS_VERSION='1.6.3' # if there are no updates, we can use the older archive
 
-inherit l10n multilib qt4-r2 vcs-snapshot
+inherit base l10n multilib qmake-utils vcs-snapshot
 
 DESCRIPTION="Qt WebKit web browser"
 HOMEPAGE="http://www.qupzilla.com/"
@@ -17,17 +17,33 @@
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86"
-IUSE="dbus debug gnome-keyring kde nonblockdialogs"
+IUSE="dbus debug gnome-keyring kde nonblockdialogs qt4 qt5"
 
-RDEPEND="dev-libs/openssl:0
-       >=dev-qt/qtcore-4.8:4
-       >=dev-qt/qtgui-4.8:4
-       >=dev-qt/qtscript-4.8:4
-       >=dev-qt/qtsql-4.8:4[sqlite]
-       >=dev-qt/qtwebkit-4.8:4
-       dbus? ( >=dev-qt/qtdbus-4.8:4 )
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+RDEPEND="
+       dev-libs/openssl:0
        gnome-keyring? ( gnome-base/gnome-keyring )
-       kde? ( kde-base/kwalletd:4 )"
+       kde? ( kde-base/kwalletd:4 )
+       qt4? (
+               >=dev-qt/qtcore-4.8:4
+               >=dev-qt/qtgui-4.8:4
+               >=dev-qt/qtscript-4.8:4
+               >=dev-qt/qtsql-4.8:4[sqlite]
+               >=dev-qt/qtwebkit-4.8:4
+               dbus? ( >=dev-qt/qtdbus-4.8:4 )
+       )
+       qt5? (
+               dev-qt/linguist-tools:5
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtconcurrent:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtscript:5
+               dev-qt/qtsql:5[sqlite]
+               dev-qt/qtwebkit:5
+               dbus? ( dev-qt/qtdbus:5 )
+       )"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
@@ -35,9 +51,12 @@
 PATCHES=( "${FILESDIR}/${P}-plugins-version-check-fix.patch" )
 
 src_prepare() {
-       # remove outdated prebuilt localizations
-       rm -rf bin/locale || die
-
+       rm_loc() {
+               sed -i -e "/${1}.ts/d" translations/translations.pri || die
+               rm translations/${1}.ts || die
+       }
+       # remove outdated copies of localizations:
+       rm -r bin/locale || die
        # remove empty locale
        rm translations/empty.ts || die
 
@@ -45,7 +64,7 @@
        mv "${WORKDIR}"/${PN}-plugins-${PLUGINS_VERSION}/themes/* "${S}"/bin/themes/ || die
 
        l10n_find_plocales_changes "translations" "" ".ts"
-       qt4-r2_src_prepare
+       l10n_for_each_disabled_locale_do rm_loc
 }
 
 src_configure() {
@@ -53,17 +72,23 @@
        export \
                QUPZILLA_PREFIX="${EPREFIX}/usr/" \
                USE_LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
-               USE_QTWEBKIT_2_2=true \
                DISABLE_DBUS=$(usex dbus '' 'true') \
                KDE_INTEGRATION=$(usex kde 'true' '') \
                NONBLOCK_JS_DIALOGS=$(usex nonblockdialogs 'true' '')
+       has_version '>=dev-qt/qtwebkit-4.8.0:4' && export USE_QTWEBKIT_2_2=true
 
-       eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       if use qt4 ; then
+               eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       else
+               eqmake5 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       fi
 }
 
 src_install() {
-       qt4-r2_src_install
-       l10n_for_each_disabled_locale_do rm_loc
+       debug-print-function $FUNCNAME "$@"
+
+       base_src_install INSTALL_ROOT="${D}" "$@"
+       einstalldocs
 }
 
 rm_loc() {
Comment 8 Davide Pesavento gentoo-dev 2014-09-17 20:42:24 UTC
(In reply to Alpha Bravo from comment #7)
>  
> -inherit l10n multilib qt4-r2 vcs-snapshot
> +inherit base l10n multilib qmake-utils vcs-snapshot
>

Don't inherit base either. It's deprecated.
Comment 9 Alpha Bravo 2014-09-18 10:26:19 UTC
--- qupzilla-1.6.6.ebuild       2014-09-18 12:20:27.624020069 +0200
+++ -   2014-09-18 12:11:27.490772664 +0200
@@ -7,7 +7,7 @@
 PLUGINS_HASH='b19f6e0b83baca40e96019ccda329b88459e6a7f'
 PLUGINS_VERSION='1.6.3' # if there are no updates, we can use the older archive
 
-inherit l10n multilib qt4-r2 vcs-snapshot
+inherit eutils l10n multilib qmake-utils vcs-snapshot
 
 DESCRIPTION="Qt WebKit web browser"
 HOMEPAGE="http://www.qupzilla.com/"
@@ -17,17 +17,33 @@
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86"
-IUSE="dbus debug gnome-keyring kde nonblockdialogs"
+IUSE="dbus debug gnome-keyring kde nonblockdialogs qt4 qt5"
 
-RDEPEND="dev-libs/openssl:0
-       >=dev-qt/qtcore-4.8:4
-       >=dev-qt/qtgui-4.8:4
-       >=dev-qt/qtscript-4.8:4
-       >=dev-qt/qtsql-4.8:4[sqlite]
-       >=dev-qt/qtwebkit-4.8:4
-       dbus? ( >=dev-qt/qtdbus-4.8:4 )
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+RDEPEND="
+       dev-libs/openssl:0
        gnome-keyring? ( gnome-base/gnome-keyring )
-       kde? ( kde-base/kwalletd:4 )"
+       kde? ( kde-base/kwalletd:4 )
+       qt4? (
+               >=dev-qt/qtcore-4.8:4
+               >=dev-qt/qtgui-4.8:4
+               >=dev-qt/qtscript-4.8:4
+               >=dev-qt/qtsql-4.8:4[sqlite]
+               >=dev-qt/qtwebkit-4.8:4
+               dbus? ( >=dev-qt/qtdbus-4.8:4 )
+       )
+       qt5? (
+               dev-qt/linguist-tools:5
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtconcurrent:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtscript:5
+               dev-qt/qtsql:5[sqlite]
+               dev-qt/qtwebkit:5
+               dbus? ( dev-qt/qtdbus:5 )
+       )"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
@@ -35,9 +51,13 @@
 PATCHES=( "${FILESDIR}/${P}-plugins-version-check-fix.patch" )
 
 src_prepare() {
-       # remove outdated prebuilt localizations
-       rm -rf bin/locale || die
+       rm_loc() {
+               sed -i -e "/${1}.ts/d" translations/translations.pri || die
+               rm translations/${1}.ts || die
+       }
 
+       # remove outdated copies of localizations:
+       rm -r bin/locale || die
        # remove empty locale
        rm translations/empty.ts || die
 
@@ -45,7 +65,7 @@
        mv "${WORKDIR}"/${PN}-plugins-${PLUGINS_VERSION}/themes/* "${S}"/bin/themes/ || die
 
        l10n_find_plocales_changes "translations" "" ".ts"
-       qt4-r2_src_prepare
+       l10n_for_each_disabled_locale_do rm_loc
 }
 
 src_configure() {
@@ -58,12 +78,16 @@
                KDE_INTEGRATION=$(usex kde 'true' '') \
                NONBLOCK_JS_DIALOGS=$(usex nonblockdialogs 'true' '')
 
-       eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       if use qt4 ; then
+               eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       else
+               eqmake5 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       fi
 }
 
 src_install() {
-       qt4-r2_src_install
-       l10n_for_each_disabled_locale_do rm_loc
+       emake INSTALL_ROOT="${D}" "$@" install
+       einstalldocs
 }
 
 rm_loc() {
Comment 10 Davide Pesavento gentoo-dev 2014-09-18 14:05:58 UTC
* Patches are not applied
* rm_loc() is duplicated
* "$@" in emake ... install is not needed
Comment 11 Alpha Bravo 2014-09-22 09:44:02 UTC
--- qupzilla-1.6.6.ebuild
+++ -
@@ -7,7 +7,7 @@
 PLUGINS_HASH='b19f6e0b83baca40e96019ccda329b88459e6a7f'
 PLUGINS_VERSION='1.6.3' # if there are no updates, we can use the older archive
 
-inherit l10n multilib qt4-r2 vcs-snapshot
+inherit eutils l10n multilib qmake-utils vcs-snapshot
 
 DESCRIPTION="Qt WebKit web browser"
 HOMEPAGE="http://www.qupzilla.com/"
@@ -17,27 +17,46 @@
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86"
-IUSE="dbus debug gnome-keyring kde nonblockdialogs"
+IUSE="dbus debug gnome-keyring kde nonblockdialogs qt4 qt5"
 
-RDEPEND="dev-libs/openssl:0
-       >=dev-qt/qtcore-4.8:4
-       >=dev-qt/qtgui-4.8:4
-       >=dev-qt/qtscript-4.8:4
-       >=dev-qt/qtsql-4.8:4[sqlite]
-       >=dev-qt/qtwebkit-4.8:4
-       dbus? ( >=dev-qt/qtdbus-4.8:4 )
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+RDEPEND="
+       dev-libs/openssl:0
        gnome-keyring? ( gnome-base/gnome-keyring )
-       kde? ( kde-base/kwalletd:4 )"
+       kde? ( kde-base/kwalletd:4 )
+       qt4? (
+               >=dev-qt/qtcore-4.8:4
+               >=dev-qt/qtgui-4.8:4
+               >=dev-qt/qtscript-4.8:4
+               >=dev-qt/qtsql-4.8:4[sqlite]
+               >=dev-qt/qtwebkit-4.8:4
+               dbus? ( >=dev-qt/qtdbus-4.8:4 )
+       )
+       qt5? (
+               dev-qt/linguist-tools:5
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtconcurrent:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtscript:5
+               dev-qt/qtsql:5[sqlite]
+               dev-qt/qtwebkit:5
+               dbus? ( dev-qt/qtdbus:5 )
+       )"
+
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 DOCS=( AUTHORS CHANGELOG FAQ README.md )
-PATCHES=( "${FILESDIR}/${P}-plugins-version-check-fix.patch" )
 
 src_prepare() {
-       # remove outdated prebuilt localizations
-       rm -rf bin/locale || die
-
+       rm_loc() {
+               sed -i -e "/${1}.ts/d" translations/translations.pri || die
+               rm translations/${1}.ts || die
+       }
+       # remove outdated copies of localizations:
+       rm -r bin/locale || die
        # remove empty locale
        rm translations/empty.ts || die
 
@@ -45,7 +64,9 @@
        mv "${WORKDIR}"/${PN}-plugins-${PLUGINS_VERSION}/themes/* "${S}"/bin/themes/ || die
 
        l10n_find_plocales_changes "translations" "" ".ts"
-       qt4-r2_src_prepare
+       l10n_for_each_disabled_locale_do rm_loc
+
+       epatch "${FILESDIR}/${P}-plugins-version-check-fix.patch"
 }
 
 src_configure() {
@@ -58,19 +79,19 @@
                KDE_INTEGRATION=$(usex kde 'true' '') \
                NONBLOCK_JS_DIALOGS=$(usex nonblockdialogs 'true' '')
 
-       eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       if use qt4 ; then
+               eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       else
+               eqmake5 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+       fi
 }
 
 src_install() {
-       qt4-r2_src_install
-       l10n_for_each_disabled_locale_do rm_loc
-}
-
-rm_loc() {
-       rm -f "${ED}"/usr/share/${PN}/locale/${1}.qm || die
+       emake INSTALL_ROOT="${D}" install
+       einstalldocs
 }
 
-pkg_postinst(){
+pkg_postinst() {
        if has_version www-plugins/adobe-flash; then
                ewarn "For using adobe flash plugin you most likely need to run \"paxctl-ng -m /usr/bin/qupzilla\""
        fi
Comment 12 Ben de Groot (RETIRED) gentoo-dev 2014-10-01 03:08:55 UTC
I've added an ebuild for the recently released 1.8.0 version to the qt overlay. I'm getting a compilation error in one of the new plugins. I'm leaving this for someone else to look into, for now.
Comment 13 Ben de Groot (RETIRED) gentoo-dev 2014-10-01 03:09:42 UTC
*** Bug 485680 has been marked as a duplicate of this bug. ***
Comment 14 Ben de Groot (RETIRED) gentoo-dev 2014-10-02 03:12:29 UTC
With an upstream update to the plugins it now builds. So I've committed it to the main tree. Thanks for your contributions!