Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522824 - x11-apps/mesa-progs-8.2.0[-egl,-gles1,-gles2]: glxinfo.c:(.text+0x82e): undefined reference to `bitmask_to_string'
Summary: x11-apps/mesa-progs-8.2.0[-egl,-gles1,-gles2]: glxinfo.c:(.text+0x82e): undef...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 522826 522832 (view as bug list)
Depends on:
Blocks: 530652
  Show dependency tree
 
Reported: 2014-09-14 23:39 UTC by tman
Modified: 2015-01-21 15:38 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2014-09-14 23:39:38 UTC
* Package:    x11-apps/mesa-progs-8.2.0
 * Repository: gentoo
 * Maintainer: x11@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
 * Running eautoreconf in '/var/tmp/portage/x11-apps/mesa-progs-8.2.0/work/mesa-demos-8.2.0' ...
 * Running libtoolize --install --copy --force --automake ...
 [ ok ]
 * Running aclocal -I m4 ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running automake --add-missing --copy --foreign --force-missing ...
 [ ok ]
 * Running elibtoolize in: mesa-demos-8.2.0/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.2 patch ...
 *   Applying target-nm/2.4.2 patch ...
x86_64-pc-linux-gnu-gcc -march=corei7 -O2 -pipe  -Wl,-O1 -Wl,--as-needed  src/xdemos/glxinfo.c  -lX11 -lGL -o src/xdemos/glxinfo
/var/tmp/portage/x11-apps/mesa-progs-8.2.0/temp/ccQZAUaB.o: In function `print_visual_attribs_verbose':
glxinfo.c:(.text+0x82e): undefined reference to `bitmask_to_string'
glxinfo.c:(.text+0x9a1): undefined reference to `bitmask_to_string'
/var/tmp/portage/x11-apps/mesa-progs-8.2.0/temp/ccQZAUaB.o: In function `create_context_flags.constprop.2':
glxinfo.c:(.text+0xd6d): undefined reference to `extension_supported'
/var/tmp/portage/x11-apps/mesa-progs-8.2.0/temp/ccQZAUaB.o: In function `create_context_with_config':
glxinfo.c:(.text+0xe4c): undefined reference to `extension_supported'
/var/tmp/portage/x11-apps/mesa-progs-8.2.0/temp/ccQZAUaB.o: In function `print_screen_info':
glxinfo.c:(.text+0x1486): undefined reference to `print_extension_list'
glxinfo.c:(.text+0x14d2): undefined reference to `print_extension_list'
glxinfo.c:(.text+0x150b): undefined reference to `print_extension_list'
glxinfo.c:(.text+0x15e9): undefined reference to `print_extension_list'
glxinfo.c:(.text+0x1641): undefined reference to `build_core_profile_extension_list'
glxinfo.c:(.text+0x16e2): undefined reference to `profile_mask_string'
glxinfo.c:(.text+0x1779): undefined reference to `print_limits'
glxinfo.c:(.text+0x18f2): undefined reference to `context_flags_string'
collect2: error: ld returned 1 exit status
<builtin>: recipe for target 'src/xdemos/glxinfo' failed
make: *** [src/xdemos/glxinfo] Error 1
 * ERROR: x11-apps/mesa-progs-8.2.0::gentoo failed (compile phase):
 *   emake failed


Reproducible: Always




Portage 2.2.12 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop, gcc-4.8.3, glibc-2.19-r1, 3.16.2-gentoo x86_64)
=================================================================
System uname: Linux-3.16.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-3740QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    24627196 total,  19314336 free
KiB Swap:   25461756 total,  25461756 free
Timestamp of tree: Sun, 14 Sep 2014 23:00:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p47
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.8, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo bitcoin steam-overlay bumblebee printer-drivers lokal
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/mnt/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/mnt/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/portage"
Comment 1 Patrick Lauer gentoo-dev 2014-09-15 02:22:40 UTC
*** Bug 522832 has been marked as a duplicate of this bug. ***
Comment 2 Patrick Lauer gentoo-dev 2014-09-15 02:22:51 UTC
*** Bug 522826 has been marked as a duplicate of this bug. ***
Comment 3 jospezial 2014-09-15 04:12:08 UTC
For me it compiled. Is this fixed? Should I downgrade too?

Portage 2.2.12 (python 3.3.5-final-0, default/linux/amd64/13.0, gcc-4.9.1, glibc-2.19-r1, 3.17.0-rc4 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.17.0-rc4-x86_64-AMD_Athlon-tm-_II_X2_240_Processor-with-gentoo-2.2
KiB Mem:     3918552 total,   1322548 free
KiB Swap:    4194292 total,   4187260 free
Timestamp of tree: Mon, 15 Sep 2014 03:15:01 +0000
ld GNU ld (GNU Binutils) 2.24
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p47
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.8, 3.3.5-r1, 3.4.1
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.2-r2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.9.1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo overlay_jl
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write=y --keep-going --quiet-build=y"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit X Xaw3d a52 aac aacplus aacs aalib ace acl acpi activefilter ads aften alsa amd64 ap apm apng archive async audacious audiofile automount bazaar berkdb binary-drivers binfilter blender-game bluetooth bluray boost bzip2 bzr cairo canusb ccache cdda cddb cdio cdparanoia cdr cdrdao cdrom cgi charconv chm chroot city cjk clang cleartype cli colordiff colors compress consolekit corefonts cpio cracklib crypt css cue cups curl curlwrappers cvs cxx daemon dbus declarative device-mapper dga dhcp doom doomsday dos download-subs dri dri3 dts dump dv dvb dvd dvdnav eap eap-sim eap-tls ebook egl emerald emoticon enca encode enscript equalizer exif extensions extras faac faad fam fat fax fbcon ffmpeg fftw firefox flac fluidsynth fontconfig foomaticdb fortran ftp fts3 fuse g3dvl gallium gbm gd gdbm gdu geoip gif gimp git glut gme gnutls gphoto2 gpm graphite gsm gstreamer gtk gtk3 gudev gui gzip hddtemp hdf hdf5 highlight hpcups hpijs http hwdb iconv icq icu id3 id3tag idn imagemagick introspection ios ipc ipod ipv6 jack java javascript jit jpeg jpeg2k kate kde keymap ladspa lame laptop lcms ldap lensfun lha libass libcaca libcanberra libkms libnl libnotify libsamplerate libssh2 libtiger libv4l libv4l2 libwww llvm-shared-libs lm_sensors logrotate lua lxde lzma lzo mad madwifi magic man matroska md5sum metalink midi mikmod mime minizip mixer mjpeg mmap mms mmx mmxext mng mobi mod modplug modules mono mouse mozilla mp3 mp4 mpeg mpeg2 mplayer mtp multilib multislot musepack musicbrainz nano-syntax ncat ncurses ndiff network nfs nfsidmap nfsv3 nfsv4 nfsv41 nls nmap nmap-update nokia normalize nowlistening nping nptl nsplugin ntfs ntfsprogs ntp nvidia nvram obex ocr ogg ogm openal opencl opengl openmax openmp openssl openvg optimized-qmake oscar osdmenu otr p2p pam pango panorama parport parse-clocks pcap pci pcre pdf pdfimport phonon pipes plasma plugins pm-utils pmu png policykit postscript ppds privacy projectm projectx pulseaudio pvr python python3 qalculate qt3support qt4 quicktime r600-llvm-compiler radio rar raw rdesktop readline recording redeyes reiser4 reiserfs remote-access remoteosd replaygain rpm rtc rtmp rtsp rubberband samba sbsms scanner schroedinger sdl secure-delete semantic-desktop sensord session sftp sha512 shorten shout skins slang smbclient smi sndfile sockets sound soundtouch speex spell sql sqlite sqlite3 sse sse2 sse3 ssh ssl startup-notification statistics stk stream subtitles subversion svg swat symlink syslog szip taglib tcpd texteffect tftp theora threads thumbnail tiff translator truetype twolame udev udisks unicode upcall upower urlpicpreview usb v4l vaapi vamp vcd vcdx vdpau video videos vim-syntax virtualbox vlm vnc vorbis vpx vroot vst wad wav wavpack webgl webkit webm webpresence wifi winbind winpopup wireshark wmf wps wxwidgets x264 x265 xa xattr xcb xcomposite xfs xine xinerama xinetd xml xmp xorg xosd xpm xrandr xscreensaver xv xvid xvmc zip zlib zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" RUBY_TARGETS="ruby19 ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev vesa svga vga radeon v4l modesetting r100 r200 r300 r600 nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-libs/mesa-10.2.7 was built with the following:
USE="classic dri3 egl gallium gbm llvm nptl opencl openmax openvg r600-llvm-compiler vdpau xa xvmc -bindist -debug -gles1 -gles2 -osmesa -pax_kernel -pic (-selinux) -wayland" ABI_X86="64 -32 -x32" VIDEO_CARDS="nouveau r100 r200 r300 r600 radeon -freedreno -i915 -i965 -ilo -intel -radeonsi -vmware"


x11-apps/mesa-progs-8.2.0 was built with the following:
USE="egl -gles1 -gles2" ABI_X86="64"
Comment 4 Dale Lukas Peterson 2014-09-15 07:01:49 UTC
I'm seeing the same error.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2014-09-15 07:03:35 UTC
 I can reproduce the problem with USE="-egl -gles1 -gles2". One of these USE flags must be enabled or else the build breaks.
Comment 6 Simon MARCHUK 2014-09-15 09:20:15 UTC
It doesn't build neither with USE="egl gles1 gles2". I was able to build it with USE="-egl gles1 gles2"
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-09-15 09:35:16 UTC
(In reply to Simon MARCHUK from comment #6)
Builds fine here with these flags. You are probably seeing a different issue then. Best open a new bug and attach your logs there.
Comment 8 Albert W. Hopkins 2014-09-15 11:08:51 UTC
It will build fine with -egl if you happen to already have media-libs/glew installed.  Without glew installed then -egl fails.
Comment 9 Michael J Coss 2014-09-22 22:27:19 UTC
I ran into this problem my solution was to modify the ebuild is src_configure() to always call default_src_configure, and in src_compile() always call emake -C src/xdemos glxgears glxinfo.  With those changes, it emerged just fine.
Comment 10 Pacho Ramos gentoo-dev 2015-01-15 13:06:03 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #5)
>  I can reproduce the problem with USE="-egl -gles1 -gles2". One of these USE
> flags must be enabled or else the build breaks.

It builds ok for me with all disabled :/
Comment 11 Pacho Ramos gentoo-dev 2015-01-15 13:14:29 UTC
Per:
https://bugs.funtoo.org/browse/FL-1535

it should be solved but some dependencies being pulled unconditionally (as it's done for some time on Gentoo due to a different bug report). Could you retry now that ebuild will pull in needed deps?
Comment 12 Pacho Ramos gentoo-dev 2015-01-21 15:38:47 UTC
(In reply to Pacho Ramos from comment #11)
> Per:
> https://bugs.funtoo.org/browse/FL-1535
> 
> it should be solved but some dependencies being pulled unconditionally (as
> it's done for some time on Gentoo due to a different bug report). Could you
> retry now that ebuild will pull in needed deps?