Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 521786 - media-fonts/font-alias-1.0.3 - /usr/share/fonts/misc/fonts.alias header causes trouble loading font "*": X Error of failed request: BadName (named color or font does not exist)
Summary: media-fonts/font-alias-1.0.3 - /usr/share/fonts/misc/fonts.alias header cause...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 530652
  Show dependency tree
 
Reported: 2014-08-30 23:11 UTC by Alex Orange
Modified: 2015-01-15 12:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Program to show failure (fail.c,237 bytes, text/plain)
2014-09-01 03:04 UTC, Alex Orange
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Orange 2014-08-30 23:11:26 UTC
The line at the top of /usr/share/fonts/misc/fonts.alias:

! $Xorg: fonts.alias,v 1.3 2000/08/21 16:42:31 coskrey Exp $

causes trouble if an application tries to load any font (font name "*"). See attached fail.c for an example. I'm guessing that because the "!" matches "*" that it tries to load the rest of the line as a font name, and fails as it's obviously not a font name. This is not just a contrived example, Synopsis CosmosScope tries to load the "*" font and fails, fail.c is just a short example to duplicate the problem.

Removing the line from the top of fonts.alias solves the problem. I'm not sure how the fonts.alias files are generated, so I'm hoping someone else can come up with the long term fix, at the moment I'm just deleting that line from the file and everything works.

Reproducible: Always

Steps to Reproduce:
1. gcc -o fail fail.c -lX11
2. ./fail
3.
Actual Results:  
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  45 (X_OpenFont)
  Serial number of failed request:  6
  Current serial number in output stream:  7

Expected Results:  
No output, just goes back to prompt.
Comment 1 Alex Orange 2014-09-01 03:04:13 UTC
Created attachment 384036 [details]
Program to show failure

Oops, I guess I forgot to upload this the other day.
Comment 2 Pacho Ramos gentoo-dev 2015-01-05 18:52:35 UTC
We need to apply this upstream patch:
http://cgit.freedesktop.org/xorg/font/alias/commit/?id=725970d993e44a2760b91bfdee7d6c2af61bffd2

Maintainers, do you let me to commit it? Do you want to also apply some other newer fixes from upstream?
http://cgit.freedesktop.org/xorg/font/alias/log/
Comment 3 Pacho Ramos gentoo-dev 2015-01-15 12:58:39 UTC
+*font-alias-1.0.3-r1 (15 Jan 2015)
+
+  15 Jan 2015; Pacho Ramos <pacho@gentoo.org>
+  +files/font-alias-1.0.3-cvs-tags.patch, +font-alias-1.0.3-r1.ebuild:
+  Remove CVS tags (#521786 by Alex Orange)
+