Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 514452 - net-analyzer/symon - init scripts use opts --oknodo /var/run
Summary: net-analyzer/symon - init scripts use opts --oknodo /var/run
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords: PATCH
: 514456 (view as bug list)
Depends on:
Blocks: keepdir-var-run_lock init.d-depr-opts s-s-d-deprecated
  Show dependency tree
 
Reported: 2014-06-22 13:32 UTC by Torbjörn Lönnemark
Modified: 2014-06-24 01:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Torbjörn Lönnemark 2014-06-22 13:32:01 UTC
The symon and symux init scripts included both use the opts variable and not extra_started_commands.

diff -uNr files/symon-init.d files_/symon-init.d
--- files/symon-init.d	2012-09-13 09:31:22.000000000 +0200
+++ files_/symon-init.d	2014-06-22 15:23:29.000000000 +0200
@@ -3,7 +3,7 @@
 # Distributed under the terms of the 2-clause BSD license
 # $Header: /var/cvsroot/gentoo-x86/net-analyzer/symon/files/symon-init.d,v 1.3 2012/09/13 07:07:53 pinkbyte Exp $
 
-opts="${opts} reload"
+extra_started_commands="reload"
 
 depend() {
 	after bootmisc
diff -uNr files/symux-init.d files_/symux-init.d
--- files/symux-init.d	2012-09-13 09:31:22.000000000 +0200
+++ files_/symux-init.d	2014-06-22 15:23:42.000000000 +0200
@@ -3,7 +3,7 @@
 # Distributed under the terms of the 2-clause BSD license
 # $Header: /var/cvsroot/gentoo-x86/net-analyzer/symon/files/symux-init.d,v 1.3 2012/09/13 07:07:53 pinkbyte Exp $
 
-opts="${opts} reload"
+extra_started_commands="reload"
 
 depend() {
 	after bootmisc
Comment 1 Jeroen Roovers gentoo-dev 2014-06-23 12:52:13 UTC
*** Bug 514456 has been marked as a duplicate of this bug. ***
Comment 2 Torbjörn Lönnemark 2014-06-24 00:14:32 UTC
Bug 514456 was marked as a duplicate of this bug, even though they were about different issues.

The following patch fixes both the issues.


--- files/symon-init.d	2012-09-13 09:31:22.000000000 +0200
+++ files/symon-init.d	2014-06-24 02:06:17.000000000 +0200
@@ -3,7 +3,7 @@
 # Distributed under the terms of the 2-clause BSD license
 # $Header: /var/cvsroot/gentoo-x86/net-analyzer/symon/files/symon-init.d,v 1.3 2012/09/13 07:07:53 pinkbyte Exp $
 
-opts="${opts} reload"
+extra_started_commands="reload"
 
 depend() {
 	after bootmisc
@@ -13,8 +13,8 @@
 
 reload() {
 	ebegin "Reloading symon"
-	start-stop-daemon --stop --pidfile /var/run/symon.pid \
-		--exec /usr/sbin/symon --oknodo --signal HUP
+	start-stop-daemon --pidfile /var/run/symon.pid --exec /usr/sbin/symon \
+		--signal HUP
 	eend $?
 }
 
--- files/symux-init.d	2012-09-13 09:31:22.000000000 +0200
+++ files/symux-init.d	2014-06-24 02:07:14.000000000 +0200
@@ -3,7 +3,7 @@
 # Distributed under the terms of the 2-clause BSD license
 # $Header: /var/cvsroot/gentoo-x86/net-analyzer/symon/files/symux-init.d,v 1.3 2012/09/13 07:07:53 pinkbyte Exp $
 
-opts="${opts} reload"
+extra_started_commands="reload"
 
 depend() {
 	after bootmisc
@@ -13,8 +13,8 @@
 
 reload() {
 	ebegin "Reloading symux"
-	start-stop-daemon --stop --pidfile /var/run/symux.pid \
-		--exec /usr/sbin/symux --oknodo --signal HUP
+	start-stop-daemon --pidfile /var/run/symux.pid --exec /usr/sbin/symux \
+		--signal HUP
 	eend $?
 }
Comment 3 Jeroen Roovers gentoo-dev 2014-06-24 01:22:46 UTC
(In reply to Torbjörn Lönnemark from comment #2)
> Bug 514456 was marked as a duplicate of this bug, even though they were
> about different issues.

There is a third issue, which is that it uses /var/run instead of /run. I batched them together because they all pertain to the same files.
Comment 4 Jeroen Roovers gentoo-dev 2014-06-24 01:31:17 UTC
Fixed in -r1. Thanks for the patch!