Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506818 - dev-lang/perl-5.18.2: partly ignores *FLAGS, results in failing multilib support on amd64
Summary: dev-lang/perl-5.18.2: partly ignores *FLAGS, results in failing multilib supp...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
: 458930 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-05 09:43 UTC by Thomas Sachau
Modified: 2014-11-29 00:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,258.39 KB, text/plain)
2014-04-05 09:43 UTC, Thomas Sachau
Details
Do not set custom CFLAGS in cpan/Digest-SHA/Makefile.PL (perl-5.20.1-respect-cflags.patch,464 bytes, patch)
2014-11-17 21:38 UTC, Matthias Maier
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Sachau gentoo-dev 2014-04-05 09:43:12 UTC
Created attachment 374286 [details]
build.log

build.log will be attached, one line missing *FLAGS is this one:

x86_64-pc-linux-gnu-gcc -c  -I. -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O1 -fomit-frame-pointer   -DVERSION=\"5.84_01\" -DXS_VERSION=\"5.84_01\" -fPIC "-I../.."  -DSHA_PerlIO SHA.c

emerge --info:

Portage 2.2.6-r1-multilib (hardened/linux/amd64, gcc-4.7.3, glibc-2.17, 3.4.86-gentoo x86_64)
=================================================================
System uname: Linux-3.4.86-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.2
KiB Mem:     8200312 total,   4231548 free
KiB Swap:     987992 total,    987992 free
Timestamp of tree: Mon Apr 22 07:39:43 CEST 2013
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p46-r1
dev-java/java-config:     2.2.0::java-overlay
dev-lang/python:          2.6.9, 2.7.6
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.6.3, 4.7.3-r1, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo enlightenment sunrise multilib x11 local
Installed sets: @enlightenment-modules, @fonts
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles force-multilib merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms sign splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3 --load-average=8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/portage/portage"
PORTDIR_OVERLAY="/var/lib/layman/enlightenment /var/lib/layman/sunrise /var/lib/layman/multilib-portage /var/lib/layman/x11 /usr/local/portage"
SYNC="cvs://tommy@cvs.gentoo.org:/var/cvsroot"
USE="3dnow X alsa amd64 berkdb cli cracklib crypt cups custom-cflags custom-cxxflags custom-optimization cxx dri gpm hardened java5 java6 justify mmx modules ncurses nls nptl nsplugin ogg openmp pam pax_kernel readline scanner session sse sse2 ssl tcpd unicode urandom v4l vorbis xtpax zlib" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" MULTILIB_ABI="amd64 x86" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python2_6" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.6 2.7"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-05-20 16:42:56 UTC

*** This bug has been marked as a duplicate of bug 134650 ***
Comment 2 Thomas Sachau gentoo-dev 2014-06-06 17:02:51 UTC
Reopening and adjusting title to make clear that this is not about using a cross-toolchain, but about multilib support and for this it only needs to fully respect *FLAGS variables.

As an addition, this is a regression against perl-5.16 as the previous major version had no such build failures.
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-08-01 19:29:05 UTC
hmm, try with 5.20 then, not sure if i can check it.
Comment 4 Thomas Sachau gentoo-dev 2014-08-03 08:18:47 UTC
(In reply to Mikle Kolyada from comment #3)
> hmm, try with 5.20 then, not sure if i can check it.

Dont expect it to be magically fixed if upstream does not claim so, if the build system partly ignores needed variables, this needs investigation and a patch/fix, otherwise new versions wont change in this regard, so with this in mind:

test with perl-5.20 gives the same result
Comment 5 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-08-03 17:16:29 UTC
(In reply to Thomas Sachau from comment #4)
> (In reply to Mikle Kolyada from comment #3)
> > hmm, try with 5.20 then, not sure if i can check it.
> 
> Dont expect it to be magically fixed if upstream does not claim so, if the
> build system partly ignores needed variables, this needs investigation and a
> patch/fix, otherwise new versions wont change in this regard, so with this
> in mind:
> 
> test with perl-5.20 gives the same result

I am not expected that it is will fixed magically. But if you say, the bug does not affect to perl-5.16 it is probably due to our local gentoo patchset. Since civil always add/remove some patches per version i thought he fix it. But i still not sure if it upstream, but not local regression.
Comment 6 Matthias Maier gentoo-dev 2014-11-17 21:38:51 UTC
Created attachment 389595 [details, diff]
Do not set custom CFLAGS in cpan/Digest-SHA/Makefile.PL

The issue is a very minor one cpan/Digest-SHA/Makefile.PL tries to be smart by overrinding optimization flags as was pointed out by Melker Narikka (meklu).

A straightforward fix is to just remove this optimization nonsene. Patch attached. Tested with perl-5.20
Comment 7 F. Fischer 2014-11-18 16:35:00 UTC
(In reply to Matthias Maier from comment #6)
> Created attachment 389595 [details, diff] [details, diff]
> Do not set custom CFLAGS in cpan/Digest-SHA/Makefile.PL
> 
> The issue is a very minor one cpan/Digest-SHA/Makefile.PL tries to be smart
> by overrinding optimization flags as was pointed out by Melker Narikka
> (meklu).
> 
> A straightforward fix is to just remove this optimization nonsene. Patch
> attached. Tested with perl-5.20

patch worked for me on 5.18.2-r2
Comment 8 Konstantin M 2014-11-24 13:45:33 UTC
Patch also worked for me on multilib-portage when adding it to src_prepare() in the ebuild for version 5.20.1-r2. Thanks, Matthias !
Comment 9 Andreas K. Hüttel gentoo-dev 2014-11-29 00:03:27 UTC
Fixed in 

dev-lang/perl-5.20.1-r3
perl-core/Digest-SHA-5.880.0
Comment 10 Andreas K. Hüttel gentoo-dev 2014-11-29 00:22:26 UTC
*** Bug 458930 has been marked as a duplicate of this bug. ***