Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458930 - perl-core/Digest-SHA-5.820.0 fails to link. - i386:x86-64 architecture of input file `SHA.o' is incompatible with i386 output
Summary: perl-core/Digest-SHA-5.820.0 fails to link. - i386:x86-64 architecture of inp...
Status: RESOLVED DUPLICATE of bug 506818
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on: perlxsflags
Blocks: portage-multilib
  Show dependency tree
 
Reported: 2013-02-24 00:55 UTC by salamanderrake
Modified: 2014-11-29 00:22 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge--info.txt,5.15 KB, text/plain)
2013-02-24 00:55 UTC, salamanderrake
Details
Digest-SHA-5.txt (Digest-SHA-5.txt,19.50 KB, text/plain)
2013-02-24 00:56 UTC, salamanderrake
Details

Note You need to log in before you can comment on or make changes to this bug.
Description salamanderrake 2013-02-24 00:55:24 UTC
perl-core/Digest-SHA-5.820.0 failes to link.



Reproducible: Always
Comment 1 salamanderrake 2013-02-24 00:55:53 UTC
Created attachment 339888 [details]
emerge --info
Comment 2 salamanderrake 2013-02-24 00:56:25 UTC
Created attachment 339890 [details]
Digest-SHA-5.txt
Comment 3 crabbed halo ablution 2013-04-24 16:08:20 UTC
caused by ebuild not respecting CFLAGS after 5.80:

5.80  Mon Dec 10 14:15:26 MST 2012
        - obtained noticeable speedup on Intel/gcc
                -- by setting -O1 and -fomit-frame-pointer
                -- SHA-1 about 63% faster, SHA-2 improves 11-20%

Relevant bits from Makefile.PL:
if ($Config{archname} =~ /^i[3456]86/ && $Config{ccname} eq 'gcc') {
        push(@extra, OPTIMIZE => '-O1 -fomit-frame-pointer');
}

This only causes problems on systems that have multilib-portage, please make this block bug 306835
Comment 4 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2013-07-29 04:20:28 UTC
Applying attachment 283109 [details, diff] from bug 261375 fixes this bug on multilib-portage for me.
Comment 5 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2013-07-30 04:08:55 UTC
Added to multilib-portage overlay in the meantime until this can be fixed in gentoo-x86: http://git.overlays.gentoo.org/gitweb/?p=proj/multilib-portage.git;a=commitdiff;h=f4e6c0050e5b89e92f9cc63805fb4b2703ad3f19
Comment 6 Melker Narikka 2014-02-13 20:07:15 UTC
I recently bumped into this again with 5.850.0, and having forgotten about
the fix, I worked around it another way.

I added this in a local copy of the ebuild:

src_configure() {
    export CCFLAGS="${CXXFLAGS}"
}
Comment 7 Andreas K. Hüttel archtester gentoo-dev 2014-11-29 00:22:26 UTC

*** This bug has been marked as a duplicate of bug 506818 ***