Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 505934 - www-apache/mod_jk-1.2.40 version bump
Summary: www-apache/mod_jk-1.2.40 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mike Weissman
URL:
Whiteboard:
Keywords: EBUILD
: 521948 (view as bug list)
Depends on:
Blocks: apache-2.4-stable
  Show dependency tree
 
Reported: 2014-03-27 07:43 UTC by Guido Jäkel
Modified: 2015-05-08 19:25 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
bumped ebuild (including patch for java useflag) (mod_jk-1.2.40.ebuild,1.96 KB, text/plain)
2014-03-27 07:43 UTC, Guido Jäkel
Details
patch to add support for the java useflag (mod_jk-1.2.37-r1.patch,827 bytes, patch)
2014-03-27 07:44 UTC, Guido Jäkel
Details | Diff
upsteam maintainer patch (mod_jk-1.2.39-chunked-post.patch,422 bytes, patch)
2014-04-10 06:30 UTC, Guido Jäkel
Details | Diff
upsteam maintainer patch (mod_jk-1.2.39-display-ipaddr.patch,2.69 KB, patch)
2014-04-10 06:31 UTC, Guido Jäkel
Details | Diff
bumped ebuild respecting patchfiles (including patch for java useflag) (mod_jk-1.2.39.ebuild,2.10 KB, text/plain)
2014-04-10 06:41 UTC, Guido Jäkel
Details
revised upsteam maintainer patch (mod_jk-1.2.39-chunked-post.patch,806 bytes, patch)
2014-04-10 13:49 UTC, Guido Jäkel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Jäkel 2014-03-27 07:43:06 UTC
Created attachment 373624 [details]
bumped ebuild (including patch for java useflag)

bumped ebuild for mod_jk-1.2.39

In principle there are no changes to mod_jk-1.2.37 needed, but i include an additional patch to respect the java useflag. Java isn't a requirement to use mod_jk and therefore you don't need it if the Tomcat(s) are located on a different server.
Comment 1 Guido Jäkel 2014-03-27 07:44:12 UTC
Created attachment 373626 [details, diff]
patch to add support for the java useflag
Comment 2 Guido Jäkel 2014-04-09 18:59:02 UTC
Dear Mike,

I discovered one cosmetical (display issue) and one serious processing bug (related to chunked transfers). I directly had reported them to one of the main upstream developers (Rainer Jung) and already got a patchset for both. I was able to integrate it in the ebuild and for me it solves the issues.

I'll upload a revised version of the ebuild and the patchfiles next workday. But maybe it's better to skip this version in Gentoo portage and wait for the next upstream release.

greetings

Guido
Comment 3 Guido Jäkel 2014-04-10 06:30:43 UTC
Created attachment 374658 [details, diff]
upsteam maintainer patch
Comment 4 Guido Jäkel 2014-04-10 06:31:13 UTC
Created attachment 374660 [details, diff]
upsteam maintainer patch
Comment 5 Guido Jäkel 2014-04-10 06:41:05 UTC
Created attachment 374662 [details]
bumped ebuild respecting patchfiles (including patch for java useflag)

Here's the revised ebuild including the set of maintainers patchfiles.

This will solve the two issues:

1.) No request body transfer to tomcat in case of chunked transfer (observed be me on POST request)

2.) Corrupted display of IP address for members of a load balancer set.

From the maintainers, the official mod_jk v1.2.40 is expected to be releases in about end of next week, i.e. 20140420. This will include other fixes concerning IPv6, too.
Comment 6 Guido Jäkel 2014-04-10 13:49:42 UTC
Created attachment 374692 [details, diff]
revised upsteam maintainer patch

Because i found another regression, the "chunked transfer"-patch was revised, again.
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2014-04-15 12:31:12 UTC
mod_jk-1.2.40 is out...
Comment 8 Guido Jäkel 2014-04-15 12:55:57 UTC
Confirmed, I just got an email from Rainer Jung about that.

From that, the fixes for 1.2.39 may be dropped and the first proposed ebuild should do the job for 1.2.40
Comment 9 Guido Jäkel 2014-04-15 12:57:10 UTC
Comment on attachment 374660 [details, diff]
upsteam maintainer patch

obsolete because committed upsteam @ 1.2.40
Comment 10 Guido Jäkel 2014-04-15 12:58:28 UTC
Comment on attachment 374692 [details, diff]
revised upsteam maintainer patch

obsolete because committed upsteam @ 1.2.40
Comment 11 Guido Jäkel 2014-04-15 13:00:07 UTC
Comment on attachment 373624 [details]
bumped ebuild (including patch for java useflag)

with the patches upstream, we may revert to this version for mod_jk-1.2.40.ebuild
Comment 12 Guido Jäkel 2014-04-15 13:02:25 UTC
Comment on attachment 374662 [details]
bumped ebuild respecting patchfiles (including patch for java useflag)

obsolete, no patching needed anymore. revert to the previous version of the ebuild.
Comment 13 Pacho Ramos gentoo-dev 2014-12-17 13:54:36 UTC
*** Bug 521948 has been marked as a duplicate of this bug. ***
Comment 14 Pacho Ramos gentoo-dev 2014-12-17 13:56:04 UTC
Looking to opensuse package seems that this version is needed for proper apache-2.4 support
Comment 15 Guido Jäkel 2014-12-17 16:03:58 UTC
(In reply to Pacho Ramos from comment #14)
> Looking to opensuse package seems that this version is needed for proper
> apache-2.4 support

Dear Pacho,

I was using other versions of mod_jk before on apache-2.4 but there was a big regression and minor issues. I solved that directly with an upstream maintainer leading to the 1.2.40 release.

There might be some other fixes, but the ones i was dealing with have been independent from the Apache version.
Comment 16 Pacho Ramos gentoo-dev 2015-05-08 19:25:59 UTC
+*mod_jk-1.2.40 (08 May 2015)
+
+  08 May 2015; Pacho Ramos <pacho@gentoo.org> +mod_jk-1.2.40.ebuild,
+  -mod_jk-1.2.28-r1.ebuild, -mod_jk-1.2.30.ebuild, -mod_jk-1.2.32.ebuild:
+  Version bump (#505934 by Guido Jäkel), drop old
+