Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 505160 - app-portage/gentoolkit-0.3.0.9 - euse - WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
Summary: app-portage/gentoolkit-0.3.0.9 - euse - WARNING: 'portageq envvar PORTDIR' is...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal normal with 5 votes (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords: InVCS
: 474574 485088 (view as bug list)
Depends on: 474574
Blocks: 546210
  Show dependency tree
 
Reported: 2014-03-20 12:23 UTC by Francesco Turco
Modified: 2017-02-28 17:40 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch that fixes the bug. (euse.patch,354 bytes, patch)
2014-06-27 11:53 UTC, Jeremi Piotrowski
Details | Diff
Patch to the original bug that also makes euse start faster. (euse-better.patch,354 bytes, patch)
2014-06-27 12:32 UTC, Jeremi Piotrowski
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco Turco 2014-03-20 12:23:30 UTC
I get the following warning when using the "euse" command from app-portage/gentoolkit-0.3.0.9:

> $ euse -V
> WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
> WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
> WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
> euse (0.3.0.9)
> Written by Marius Mauch
> 
> Copyright (C) 2004-2009 Gentoo Foundation, Inc.
> This is free software; see the source for copying conditions.

No matter which options I use, euse always displays this warning, multiple times.

This problem seems similar to bug 497220, but it occurs with euse instead of ufed.

Reproducible: Always
Comment 1 Pablo Cholaky 2014-03-21 04:14:22 UTC
I can confirm this problem with euse.

Seems to happen everytime, even if you have a PORTDIR variable setted on make.conf.
Comment 2 Francesco Turco 2014-03-21 14:08:14 UTC
Yes, I also have the following variable in /etc/portage/make.conf:
> PORTDIR="/usr/portage"
Comment 3 Boney McCracker 2014-03-21 22:43:41 UTC
I can confirm this as well.
Comment 4 faminebadger 2014-06-07 13:23:55 UTC
This is still present some 3 months after being raised!

Isn't this simply because the "get_portdir()" function in the euse script contains:

		eval $(portageq envvar -v PORTDIR)

This should be updated to:

                eval $(portageq get_repo_path $(portageq envvar EROOT) gentoo)

Or somesuch.
Comment 5 Jeremi Piotrowski 2014-06-27 11:53:27 UTC
Created attachment 379774 [details, diff]
Patch that fixes the bug.
Comment 6 Jeremi Piotrowski 2014-06-27 11:58:08 UTC
My solution is similar to what faminebadger suggested, replace

eval $(portageq envvar -v PORTDIR)

with

eval "PORTDIR=$(portageq get_repo_path $(portageq envvar EROOT) gentoo)"

It works and is correct. A side effect, however, is that euse turns on slightly slower than it used to.
Comment 7 Jeremi Piotrowski 2014-06-27 12:32:45 UTC
Created attachment 379780 [details, diff]
Patch to the original bug that also makes euse start faster.

To fix the speed issue I came up with this conditional assignment:

: ${PORTDIR="$(portageq get_repo_path $(portageq envvar EROOT) gentoo)"}

I do not know if the author had something in mind when calling get_portdir 3 times in the script instead of using PORTDIR. If not, then this solution is superior to the previous one.
Comment 8 Nikoli 2014-07-21 03:01:05 UTC
Seems this bug is blocker or duplicate of bug #474574
Comment 9 Sergey S. Starikoff 2015-01-30 06:19:58 UTC
The same issue:

$ euse -i cjk
WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
global use flags (searching: cjk)
************************************************************
[-      ] cjk - Add support for Multi-byte character languages (Chinese, Japanese, Korean)

local use flags (searching: cjk)
…

$ equery b $(which euse)
 * Searching for /usr/bin/euse ... 
app-portage/gentoolkit-0.3.0.9-r2 (/usr/bin/euse)

Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0, gcc-4.8.3, glibc-2.19-r1, 3.16.7-aufs x86_64)
Comment 10 Sergey Popov gentoo-dev 2015-01-30 11:10:46 UTC

*** This bug has been marked as a duplicate of bug 474574 ***
Comment 11 Sergey Popov gentoo-dev 2015-01-30 11:23:59 UTC
Oops, that's different issue, but related to bug #474574
Comment 12 Sergey S. Starikoff 2015-01-30 11:48:35 UTC
It is a regression in app-portage/gentoolkit-0.3.0.9-r2

# euse -V
WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
WARNING: 'portageq envvar PORTDIR' is deprecated. Use 'portageq repositories_configuration' instead.
euse (0.3.0.9-r2)
Written by Marius Mauch

Copyright (C) 2004-2009 Gentoo Foundation, Inc.
This is free software; see the source for copying conditions.

Downgrade:
# emerge -1 =app-portage/gentoolkit-0.3.0.8-r2

Re-check^
# euse -V
euse (0.3.0.8-r2)
Written by Marius Mauch

Copyright (C) 2004-2009 Gentoo Foundation, Inc.
This is free software; see the source for copying conditions.

Result: no issue.

P.S. BTW Isn't 2009 year in Copyright mark a mistake?
Comment 13 luze 2015-04-04 17:48:26 UTC
This is still an issue and the fix is trivial.
Comment 14 Paul Varner (RETIRED) gentoo-dev 2015-04-23 21:26:00 UTC
(In reply to luze from comment #13)
> This is still an issue and the fix is trivial.

Unfortunately, the fix was not trivial.  In order to be inline with the direction Portage is moving, the concept of a PORTDIR and PORTDIR_OVERLAY had to be removed from the software.  With that said, I have committed the changes to git.

https://gitweb.gentoo.org/proj/gentoolkit.git/commit/?h=gentoolkit&id=b7c075d2aeb593f0ddf1450e75b535cafbbd7201

Please test and verify using gentoolkit-9999
Comment 15 Scott Alfter 2015-06-10 15:12:22 UTC
>Please test and verify using gentoolkit-9999

Works for me...warning messages are gone.
Comment 16 Joakim Tjernlund 2015-09-25 17:33:33 UTC
please make a release
Comment 17 Mike DeSimone 2015-11-09 19:16:42 UTC
Please stabilize an ebuild with this fix. Been looking at this spam for almost two years now.
Comment 18 lumbrius 2015-11-11 09:40:13 UTC
another ask to stabilize
Comment 19 Ian Stakenvicius (RETIRED) gentoo-dev 2015-12-17 15:26:34 UTC
gentoolkit-0.3.1 was released with this fix included.  It will go stable soon, I'm sure.
Comment 20 Philippe Chaintreuil 2016-08-04 18:18:30 UTC
@perfinion did you mean depends on?  Over on bug #590170 they want to know why that bug depends on this bug.
Comment 21 Jeroen Roovers (RETIRED) gentoo-dev 2016-10-02 08:04:17 UTC
Apparently this is fixed.
Comment 22 Zac Medico gentoo-dev 2016-10-24 21:46:55 UTC
*** Bug 485088 has been marked as a duplicate of this bug. ***
Comment 23 Zac Medico gentoo-dev 2016-10-24 21:53:28 UTC
*** Bug 474574 has been marked as a duplicate of this bug. ***
Comment 24 Joseph 2017-02-28 13:58:01 UTC
(In reply to Ian Stakenvicius from comment #19)
> gentoolkit-0.3.1 was released with this fix included.  It will go stable
> soon, I'm sure.

I have Installed versions:  0.3.2-r1 and still getting this message!
Comment 25 Paul Varner (RETIRED) gentoo-dev 2017-02-28 17:40:58 UTC
(In reply to Joseph from comment #24)
> I have Installed versions:  0.3.2-r1 and still getting this message!

Then something is broken with your installation or you have a different copy of euse that is getting called. What do the following commands show?

# which euse  
/usr/bin/euse

# euse -V
euse (0.3.2-r1)
Written by Marius Mauch

Copyright (C) 2004-2009 Gentoo Foundation, Inc.
This is free software; see the source for copying conditions.

# grep PORTDIR /usr/bin/euse
#