Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 496048 - app-emulation/virtualbox-modules-4.3.6 - .../work/vboxdrv/include/VBox/SUPDrvMangling.h:31:27: fatal error: iprt/mangling.h: No such file or directory
Summary: app-emulation/virtualbox-modules-4.3.6 - .../work/vboxdrv/include/VBox/SUPDrv...
Status: RESOLVED DUPLICATE of bug 285866
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-26 03:30 UTC by Reonaydo
Modified: 2014-08-08 02:14 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_496048.txt,18.25 KB, text/plain)
2013-12-27 01:34 UTC, Reonaydo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reonaydo 2013-12-26 03:30:10 UTC
Can`t build app-emulation/virtualbox-modules-4.3.6
It can not find header file
Build log here: http://bpaste.net/show/161770/
Emerge --info here: http://bpaste.net/show/161772/

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2013-12-26 16:12:13 UTC
1) Please attach the entire build log to this bug report.
2) Please post your `emerge --info' output in a comment.
Comment 2 Reonaydo 2013-12-27 01:23:34 UTC
Build log:

 * Package:    app-emulation/virtualbox-modules-4.3.6
 * Repository: gentoo
 * Maintainer: polynomial-c@gentoo.org patrick@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox splitdebug userpriv usersandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.9.11-gentoo-r1/build
 * Found sources for kernel version:
 *     3.9.11-gentoo-r1
>>> Unpacking source...
>>> Unpacking vbox-kernel-module-src-4.3.6.tar.xz to /var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work
>>> Source unpacked in /var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work
>>> Preparing source in /var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work ...
ln: не удалось создать символьную ссылку «Module.symvers»: Файл существует
 * Preparing vboxdrv module
make -j3 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' KERN_DIR=/usr/src/linux KERNOUT=/lib/modules/3.9.11-gentoo-r1/build all 
*** Building 'vboxdrv' module ***
make[1]: вход в каталог «/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv»
pwd: невозможно открыть каталог «../../../../../..»: Отказано в доступе
make KBUILD_VERBOSE= SUBDIRS=/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv SRCROOT=/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv CONFIG_MODULE_SIG= -C /usr/src/linux modules
make[2]: вход в каталог «/usr/src/linux-3.9.11-gentoo-r1»
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/linux/SUPDrv-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/SUPDrv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/SUPDrvSem.o
In file included from <command-line>:0:0:
/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/include/VBox/SUPDrvMangling.h:31:27: fatal error: iprt/mangling.h: No such file or directory
 #include <iprt/mangling.h>
                           ^
In file included from <command-line>:0:0:
/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/include/VBox/SUPDrvMangling.h:31:27: fatal error: iprt/mangling.h: No such file or directory
 #include <iprt/mangling.h>
                           ^
In file included from <command-line>:0:0:
/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/include/VBox/SUPDrvMangling.h:31:27: fatal error: iprt/mangling.h: No such file or directory
 #include <iprt/mangling.h>
                           ^
compilation terminated.
compilation terminated.
compilation terminated.
scripts/Makefile.build:307: recipe for target '/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/SUPDrv.o' failed
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/SUPDrv.o] Error 1
make[3]: *** Waiting for unfinished jobs....
scripts/Makefile.build:307: recipe for target '/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/SUPDrvSem.o' failed
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/SUPDrvSem.o] Error 1
scripts/Makefile.build:307: recipe for target '/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/linux/SUPDrv-linux.o' failed
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv/linux/SUPDrv-linux.o] Error 1
Makefile:1222: ошибка выполнения рецепта для цели «_module_/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv»
make[2]: *** [_module_/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv] Ошибка 2
make[2]: выход из каталога «/usr/src/linux-3.9.11-gentoo-r1»
Makefile:289: ошибка выполнения рецепта для цели «vboxdrv»
make[1]: *** [vboxdrv] Ошибка 2
make[1]: выход из каталога «/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work/vboxdrv»
Makefile:39: ошибка выполнения рецепта для цели «all»
make: *** [all] Ошибка 2
 * ERROR: app-emulation/virtualbox-modules-4.3.6::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=app-emulation/virtualbox-modules-4.3.6::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/virtualbox-modules-4.3.6::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/temp/environment'.
 * Working directory: '/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work'
 * S: '/var/tmp/portage/app-emulation/virtualbox-modules-4.3.6/work'
Comment 3 Reonaydo 2013-12-27 01:34:22 UTC
Created attachment 366258 [details]
emerge --info
Comment 4 Ben Kohler gentoo-dev 2014-08-08 02:14:00 UTC

*** This bug has been marked as a duplicate of bug 285866 ***