Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 500060 - app-emulation/virtualbox-modules 4.2.2 - In file included from .../work/vboxdrv/linux/SUPDrv-linux.c:31: include/linux/page-flags-layout.h:5:30: fatal error: generated/bounds.h: No such file or directory
Summary: app-emulation/virtualbox-modules 4.2.2 - In file included from .../work/vboxd...
Status: RESOLVED DUPLICATE of bug 285866
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-02 10:37 UTC by Nicolas
Modified: 2014-08-08 02:14 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas 2014-02-02 10:37:47 UTC
I spent my afternoon to install a fresh Gentoo after being absent for some years. Unfortunately, when I wanted to install VirtualBox, there were a bug on virtualbox-modules since it fail each time, with all the 4.2.2 and the 4.3.6 versions.

Like it says "  WARNING: Symbol version dump /usr/src/linux-3.10.25-gentoo/Module.symvers is missing; modules will have no dependencies and modversions." maybe that's because I use genkernel to compile the kernel ?

Anyways, when I made "cd /usr/src/linux && make modules_prepare", I be able to emerge virtualbox-modules

Reproducible: Always

Steps to Reproduce:
Install a new Gentoo with genkernel




 * IMPORTANT: 6 config files in '/etc/portage' need updating.
Calculating dependencies   * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
.... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 5) app-emulation/virtualbox-modules-4.2.22
 * vbox-kernel-module-src-4.2.22.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...   [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.10.25-gentoo/build
 * Found sources for kernel version:
 *     3.10.25-gentoo
>>> Unpacking source...
>>> Unpacking vbox-kernel-module-src-4.2.22.tar.xz to /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work
>>> Source unpacked in /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work
>>> Preparing source in /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work ...
ln: failed to create symbolic link 'Module.symvers': File exists
 * Preparing vboxdrv module
make -j5 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' KERN_DIR=/usr/src/linux KERNOUT=/lib/modules/3.10.25-gentoo/build all 
*** Building 'vboxdrv' module ***
make[1]: Entering directory `/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv'
make KBUILD_VERBOSE= SUBDIRS=/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv SRCROOT=/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv CONFIG_MODULE_SIG= -C /usr/src/linux modules
make[2]: Entering directory `/usr/src/linux-3.10.25-gentoo'

  WARNING: Symbol version dump /usr/src/linux-3.10.25-gentoo/Module.symvers
           is missing; modules will have no dependencies and modversions.

  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/linux/SUPDrv-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/SUPDrv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/SUPDrvSem.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/r0drv/alloc-r0drv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/SUPDrvTracer.o
In file included from include/linux/mmzone.h:18:0,
                 from include/linux/gfp.h:4,
                 from include/linux/slab.h:12,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/linux/../SUPDrvInternal.h:106,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/linux/SUPDrv-linux.c:31:
include/linux/page-flags-layout.h:5:30: fatal error: generated/bounds.h: No such file or directory
compilation terminated.
In file included from include/linux/mmzone.h:18:0,
                 from include/linux/gfp.h:4,
                 from include/linux/kmod.h:22,
                 from include/linux/module.h:13,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/include/internal/iprt.h:56,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/r0drv/alloc-r0drv.c:33:
include/linux/page-flags-layout.h:5:30: fatal error: generated/bounds.h: No such file or directory
compilation terminated.
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/linux/SUPDrv-linux.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv/r0drv/alloc-r0drv.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv] Error 2
make[2]: Leaving directory `/usr/src/linux-3.10.25-gentoo'
make[1]: *** [vboxdrv] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work/vboxdrv'
make: *** [all] Error 2
 * ERROR: app-emulation/virtualbox-modules-4.2.22::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=app-emulation/virtualbox-modules-4.2.22::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/virtualbox-modules-4.2.22::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/temp/environment'.
 * Working directory: '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work'
 * S: '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work'

>>> Failed to emerge app-emulation/virtualbox-modules-4.2.22, Log file:

>>>  '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/temp/build.log'
 * Messages for package app-emulation/virtualbox-modules-4.2.22:
 * ERROR: app-emulation/virtualbox-modules-4.2.22::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=app-emulation/virtualbox-modules-4.2.22::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/virtualbox-modules-4.2.22::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/temp/environment'.
 * Working directory: '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work'
 * S: '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.22/work'
Comment 1 Joe Kane 2014-06-10 13:47:00 UTC
same here.   kernel 3.12.13, updating vbox

In file included from /lib/modules/3.12.13-gentoo/build/include/linux/mmzone.h:18:0,
                 from /lib/modules/3.12.13-gentoo/build/include/linux/gfp.h:4,
                 from /lib/modules/3.12.13-gentoo/build/include/linux/slab.h:14,
                 from /var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.2.24/work/VirtualBox-4.2.24/src/VBox/Runtime/r0drv/linux/the-linux-kernel.h:72,
                 from /var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.2.24/work/VirtualBox-4.2.24/src/VBox/Runtime/r0drv/linux/alloc-r0drv-linux.c:31:
/lib/modules/3.12.13-gentoo/build/include/linux/page-flags-layout.h:5:30: fatal error: generated/bounds.h: No such file or directoryIn file included from /lib/modules/3.12.13-gentoo/build/include/linux/mmzone.h:18:0,
                 from /lib/modules/3.12.13-gentoo/build/include/linux/gfp.h:4,
                 from /lib/modules/3.12.13-gentoo/build/include/linux/slab.h:14,
                 from /var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.2.24/work/VirtualBox-4.2.24/src/VBox/Runtime/r0drv/linux/the-linux-kernel.h:72,
                 from /var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.2.24/work/VirtualBox-4.2.24/src/VBox/Runtime/r0drv/linux/assert-r0drv-linux.c:31:
/lib/modules/3.12.13-gentoo/build/include/linux/page-flags-layout.h:5:30: fatal error: generated/bounds.h: No such file or directory
compilation terminated.
Comment 2 Joe Kane 2014-06-10 13:51:21 UTC
though in my case it is going from 4.2.22 to 4.2.24
Comment 3 Joe Kane 2014-06-13 18:44:39 UTC
never mind my comments.
resolved with 
# cd /usr/src/linux && make modules_prepare
Comment 4 Ben Kohler gentoo-dev 2014-08-08 02:14:19 UTC

*** This bug has been marked as a duplicate of bug 285866 ***