Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 493268 - [gnome-overlay] app-crypt/gcr-3.10.1 should DEPEND on dev-lang/vala[vapigen] - configure: error: vapigen >= 0.18.0.22 not found
Summary: [gnome-overlay] app-crypt/gcr-3.10.1 should DEPEND on dev-lang/vala[vapigen] ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome-3.10
  Show dependency tree
 
Reported: 2013-12-03 22:00 UTC by Michael Hampicke
Modified: 2013-12-05 22:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,10.20 KB, text/plain)
2013-12-03 22:01 UTC, Michael Hampicke
Details
config.log (config.log,53.29 KB, text/plain)
2013-12-03 22:03 UTC, Michael Hampicke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hampicke 2013-12-03 22:00:56 UTC
Trying to build app-crypt/gcr-3.10.1 fails with: 

configure: error: vapigen >= 0.18.0.22 not found



Reproducible: Always




# qlist -Iv vala
dev-lang/vala-0.20.1
dev-lang/vala-0.22.1
dev-libs/vala-common-0.22.1
Comment 1 Michael Hampicke 2013-12-03 22:01:17 UTC
Created attachment 364560 [details]
build.log
Comment 2 Michael Hampicke 2013-12-03 22:03:38 UTC
Created attachment 364562 [details]
config.log
Comment 3 Evgeny Bobkin 2013-12-04 20:04:15 UTC
strange that your installation fails,

checking for GTK... yes
checking for x86_64-pc-linux-gnu-pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for vapigen... no
checking for timegm... yes
checking for mlock... yes
checking for P11_KIT... yes

....

BUILD
  Debug Build:          default (-g, debug output, testable)
  Strict Compilation:   no (quick tests, non-fatal warnings)
  GTK+ Widgets:         yes
  Introspection:        yes
  Vala:                 no
  Valgrind:             no
  Test Coverage:        no

>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-crypt/gcr-3.10.1/work/gcr-3.10.1 ...
make -j8 
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/app-crypt/gcr-3.10.1/work/gcr-3.10.1'


because vala is not required here, where does your ebuild come from? gentoo-next overlay?
Comment 4 Evgeny Bobkin 2013-12-04 20:05:37 UTC
please use https://github.com/Heather/gentoo-gnome instead, that is there we work on integration of gnome 3.10 into gentoo
Comment 5 Gilles Dartiguelongue gentoo-dev 2013-12-05 00:40:30 UTC
Please, the official overlay is the gnome overlay...

The problem has been fixed in 1bbcebbc599ae52fdbd20c7e3da15cab89fd3c2e.
Comment 6 Walter Meinl 2013-12-05 19:38:28 UTC
(In reply to Gilles Dartiguelongue from comment #5)
> Please, the official overlay is the gnome overlay...
> 
> The problem has been fixed in 1bbcebbc599ae52fdbd20c7e3da15cab89fd3c2e.

I still see the problem reported in comment #0 It appears that configure checks for vapigen.pc (note without version) but in my /usr/share/pkgconfig dir only vapigen-0.20.pc and vapigen-0.22.pc are found.
When I add in the src_prepare() function of the ebuild

use vala && vala_src_prepare

gcr is built successfully with USE=vala
Comment 7 Gilles Dartiguelongue gentoo-dev 2013-12-05 22:30:57 UTC
Indeed. Added to the overlay now.