Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 486484 (gnome-3.10) - [Tracker] GNOME 3.10 Official Release
Summary: [Tracker] GNOME 3.10 Official Release
Status: RESOLVED FIXED
Alias: gnome-3.10
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: Tracker
: 486068 488186 489994 500120 (view as bug list)
Depends on: 450582 452162 491464 492226 493268 493642 493816 494456 495248 495250 495252 495254 495272 496106 496848 497018 497162 497168 499512 499722 499784 499820 499822 499964 bluez-5 500118
Blocks: 492300
  Show dependency tree
 
Reported: 2013-09-29 13:21 UTC by Gilles Dartiguelongue
Modified: 2017-01-19 18:47 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Dartiguelongue gentoo-dev 2013-09-29 13:21:50 UTC
Hello there, GNOME 3.10 was released officially a few days ago.

1. No talks in here. No questions, no comments, nothing.
2. 3.10 will be included in tree when it is ready.
3. Do not file bump request reports, we might be slow but eventually we will get around all 3.10 bumps.
4. If you have a particular problem with 3.10 ebuilds, please file a separate bug report and make it depend on this one.

Thanks for flying gentoo.
Comment 1 Gilles Dartiguelongue gentoo-dev 2013-09-29 13:23:27 UTC
*** Bug 486068 has been marked as a duplicate of this bug. ***
Comment 2 Jura 2013-10-08 11:04:12 UTC
I install gnome from https://github.com/thankjura/gentoo-gnome
Comment 3 Pacho Ramos gentoo-dev 2013-10-08 18:52:07 UTC
(In reply to Jura from comment #2)
> I install gnome from https://github.com/thankjura/gentoo-gnome


I would try to coordinate with Heather to prevent a fork of a fork of a fork...

The best would be to try to merge Heather's work on official overlay, but I won't have time for it in the near future :(, not sure if any other gnome team member could take care to prevent people from creating a ton of forks that will be impossible to review or use when we need to put gnome 3.10 in the tree/overlay(In reply to Jura from comment #2)
Comment 4 Cynede (RETIRED) gentoo-dev 2013-10-09 14:43:54 UTC
(In reply to Pacho Ramos from comment #3)
> (In reply to Jura from comment #2)
> > I install gnome from https://github.com/thankjura/gentoo-gnome
> 
> 
> I would try to coordinate with Heather to prevent a fork of a fork of a
> fork...
> 
> The best would be to try to merge Heather's work on official overlay, but I
> won't have time for it in the near future :(, not sure if any other gnome
> team member could take care to prevent people from creating a ton of forks
> that will be impossible to review or use when we need to put gnome 3.10 in
> the tree/overlay(In reply to Jura from comment #2)

My overlay / repository / fork is not ready. I can think that Jura fork is not ready too, in current state. And I need any possible help there... For now I have one contributor there.

Also maybe another addition task there will be separating multilibed ebuilds (sadly I used to got some there for myself) from non-multilibed.

It's hard for me to deal currently with Jura fork. It contains lots of useful changes but I'm not agreed with removing all live packages and some dev tools so for now I can only manually pick what I need from there. And according changes map we made on both repositories so far it's not possible to merge it in any way except re-fork.

by the way there is another separated repository: https://github.com/canek-pelaez/gnome-canek and seems like maintainer don't plan to merge this work also... I personally didn't checked it so I can't say maybe it's even more ready compared to my repository, I don't know.

So any suggestions where we should go still being welcome...
Comment 5 Pacho Ramos gentoo-dev 2013-10-16 19:27:36 UTC
*** Bug 488186 has been marked as a duplicate of this bug. ***
Comment 6 Cynede (RETIRED) gentoo-dev 2013-10-17 12:04:47 UTC
Gnome overlay and EvaSDK started work on it. From scratch. Note that my fork is desynchronized now and not the same, I would say it's separated overlay now which is not even in layman yet.
Comment 7 Pacho Ramos gentoo-dev 2013-10-17 18:37:11 UTC
I have being talking with Heather and I think we can do go the following to try to get all people happy:
- As seems that Gilles prefers to make the bumps himself from scratch -> I would wait from he to do that (I partly understand this position as I also had a lot of problems while trying to bump 3.8 from 2.32 (as I came from 2.32) looking to the differences between 2.32 -> 3.8, differences between 3.6 and 3.8 and ebuilds done by sobhan) -> At the end, was really difficult to handle all the changes

- Once he is done, I could try to compare both overlays to merge the differences.

- After that, I would give Heather access to the overlay to work and help us (well, he is finally a dev and we shouldn't discard his help at all :))
Comment 8 Ulenrich 2013-10-19 15:58:14 UTC
Today a lot of bugfixes for Gnome-3.10.1
http://ftp.gnome.org/pub/GNOME/core/3.10/3.10.1/NEWS
Comment 9 Pacho Ramos gentoo-dev 2013-11-01 14:27:31 UTC
*** Bug 489994 has been marked as a duplicate of this bug. ***
Comment 10 Gilles Dartiguelongue gentoo-dev 2013-11-03 23:17:33 UTC
I have thought about this a lot and I think I will review Heather work rather than continue from scratch. Don't expect this to go any faster though since reviewing takes time as well.
Comment 11 Cynede (RETIRED) gentoo-dev 2013-11-04 06:58:54 UTC
(In reply to Gilles Dartiguelongue from comment #10)
> I have thought about this a lot and I think I will review Heather work
> rather than continue from scratch. Don't expect this to go any faster though
> since reviewing takes time as well.

Thank you. I understand that review is really hard work to do. And will try to help where I can.
Comment 12 Cynede (RETIRED) gentoo-dev 2013-11-04 08:27:45 UTC
Also added overlay to layman, it's called gnome-next there
Comment 13 Ulenrich 2013-12-06 13:22:09 UTC
Not a dup because independend from gnome-3.10
?
https://bugs.gentoo.org/show_bug.cgi?id=489994

net-libs/webkit-gtk-2.2.3 version bump
solved an issue with current portage tree at
https://forums.gentoo.org/viewtopic-t-977728-highlight-.html

Of course 2.2.3 instead of 2.2.1
Comment 14 Pacho Ramos gentoo-dev 2013-12-24 18:22:12 UTC
*** Bug 492226 has been marked as a duplicate of this bug. ***
Comment 15 Pacho Ramos gentoo-dev 2014-02-02 18:38:41 UTC
*** Bug 500120 has been marked as a duplicate of this bug. ***