Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 489988 - app-office/libreoffice-4.1.X.X - hangs when moving cells in Calc
Summary: app-office/libreoffice-4.1.X.X - hangs when moving cells in Calc
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-31 18:16 UTC by Alexandre
Modified: 2013-12-11 21:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Strace file. (libreoffice_out_put.txt,72.27 KB, text/plain)
2013-10-31 18:17 UTC, Alexandre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre 2013-10-31 18:16:38 UTC
Every time trying to move one or more cells on LO Calc KDE/X freeze. Just pointer still work.

Reproducible: Always

Steps to Reproduce:
1. Select one or more cell on Calc
2. Try to move that

Actual Results:  
X/KDE freeze.


Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.1, glibc-2.17, 3.10.17-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.10.17-gentoo-x86_64-Intel-R-_Pentium-R-_Dual_CPU_T3400_@_2.16GHz-with-gentoo-2.2
KiB Mem:     2821700 total,   1100712 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of tree: Thu, 31 Oct 2013 15:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r4, 3.3.2-r2
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.1-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.10 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo sunrise privacychain
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -g0"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -g0"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy ccache config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" ftp://gentoo.c3sl.ufpr.br/gentoo/ http://gentoo.c3sl.ufpr.br/ ftp://ftp.las.ic.unicamp.br/pub/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ "
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage/"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo caps cdda cdr cli consolekit cracklib crypt css cups custom-cflags custom-optimization cxx dbus declarative dga dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac gdbm gif gnutls gpm gtk iconv infinality jpeg kde kipi lame lcms libnotify lzma lzo mad minimal mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses networkmanager nls nptl nvidia offensive ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline samba sdl semantic-desktop session spell sse sse2 ssl ssse3 startup-notification svg syslog tcpd theora threads tiff truetype udev udisks unicode upower usb v4l vdpau vim-syntax vorbis vpx wavpack wxwidgets x264 xcb xcomposite xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel loopback" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-office/libreoffice-4.1.2.3 was built with the following:
USE="branding cups dbus gtk java kde opengl vba webdav (-aqua) -bluetooth -debug -eds -gnome -gstreamer -gtk3 -jemalloc -mysql -odk -postgres -telepathy -test" LIBREOFFICE_EXTENSIONS="-nlpsolver -presenter-minimizer -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3" PYTHON_TARGETS="python2_7 -python3_3"
Comment 1 Alexandre 2013-10-31 18:17:08 UTC
Created attachment 362372 [details]
Strace file.
Comment 2 Stephan Karacson 2013-11-03 12:08:31 UTC
I can just confirm exact the same issue.
Libreoffice up to 4.1.3.2
xorg-server 1.14.3-r2
kde 4.10.5

Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.15-r3, 3.10.17-gentoo x86_64)
=================================================================
System uname: Linux-3.10.17-gentoo-x86_64-Intel-R-_Core-TM-_i7-2720QM_CPU_@_2.20GHz-with-gentoo-2.2
KiB Mem:     8152088 total,   6337064 free
KiB Swap:    8499196 total,   8499196 free
Timestamp of tree: Sun, 03 Nov 2013 07:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA skype-4.0.0.7-copyright ut2003 PUEL AdobeFlash-10.3 AdobeFlash-11.x googleearth"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ "
LANG="de_AT.UTF-8"
LC_ALL="de_AT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac aacs acei acl acpi acpi4linux addressbook alsa amd64 apm apng audiofile avx bidi binfilter bittorrent bluetooth bluray bzip2 c c++ cdaudio cdda cddb cdinstall cdparanoia cdr cdrom chroot cjk clamav cli codecs consolekit cracklib css cups cvs cxx dbus declarative device-mapper dhcp dhcpcd dri dvd dvdnav dvdread emul-linux-x86 encode ethereal exif extras ffmpeg flac flash fontconfig foomaticdb fortran ftp g3dvl gallium gcj gdbm german gif gnutls gphoto2 gudev h323 hal hwdb iconv imap imlib ipv6 irmc java javascript joystick jpeg jpeg2k kde kdepim keymap lame langpacks libwww live lm_sensors lua lzma mad matroska md5sum midi mikmod minizip mjpeg mmx mmx2 mmxext mng mod modules mp2 mp3 mp4 mp4live mpeg mpeg2 mpeg4 mtp mudflap multilib multimedia music ncurses net network networkmanager nls nptl nvidia obex ogg oggvorbis opengl openmp oss pam pcre pdf phonon plasma pmu png pnm pnp policykit postscript qt4 quicktime readline reports rtc rtsp scanner script semantic-desktop session smime smp sound sounds sqlite sse sse2 ssl stream svg svgz sysfs tcpd templates theora threads tiff timidity transcode truetype udisks unicode usb utf8 vcd vdpau videos vlc vlm vorbis wav webkit webm wma wmf wmp x264 xcb xinerama xml xmp xpm xv xvid zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="synaptics mouse evdev keyboard joystick void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="epson" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 Tumanov 2013-11-14 22:16:51 UTC
Confirm both in 4.1.2.3 and in 4.1.3.2. x86_64.
Interesting topic: in case I compile libreoffice form source form original website I see no problems. It seams that the problem is in gentoo installation only

 * Found these USE flags for app-office/libreoffice-4.1.3.2:
 U I
 - - bluetooth                                   : Enable Bluetooth Support
 + + branding                                    : Enable Gentoo specific branding
 + + cups                                        : Add support for CUPS (Common Unix Printing System)
 + + dbus                                        : Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
 - - debug                                       : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful
                                                   backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
 - - eds                                         : Enable support for Evolution-Data-Server (EDS)
 - - gnome                                       : Add GNOME support
 - - gstreamer                                   : Add support for media-libs/gstreamer (Streaming media)
 + + gtk                                         : Add support for x11-libs/gtk+ (The GIMP Toolkit)
 - - gtk3                                        : Enable highly experimental gtk3 frontend
 + + java                                        : Add support for Java
 - - jemalloc                                    : Use dev-libs/jemalloc for allocations
 + + kde                                         : Add support for KDE (K Desktop Environment)
 - - libreoffice_extensions_nlpsolver            : LIBREOFFICE_EXTENSIONS option to build non-linear solver for calc
 + + libreoffice_extensions_presenter-minimizer  : LIBREOFFICE_EXTENSIONS option to build presentation minimizer
 - - libreoffice_extensions_scripting-beanshell  : LIBREOFFICE_EXTENSIONS option to build beanshell scripts parser
 - - libreoffice_extensions_scripting-javascript : LIBREOFFICE_EXTENSIONS option to build javascript scripts parser
 - - libreoffice_extensions_wiki-publisher       : LIBREOFFICE_EXTENSIONS option to build mediawiki integration
 + + mysql                                       : Add mySQL Database support
 - - odk                                         : Build the Office Development Kit
 + + opengl                                      : Add support for OpenGL (3D graphics)
 - - postgres                                    : Add support for the postgresql database
 + + python_single_target_python2_7              : Build for Python 2.7 only
 - - python_single_target_python3_3              : Build for Python 3.3 only
 + + python_targets_python2_7                    : Build with Python 2.7
 - - python_targets_python3_3                    : Build with Python 3.3
 - - telepathy                                   : Enable document colaboration features using telepathy communication framework.
 - - test                                        : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this
                                                   internally, so don't set it in make.conf/package.use anymore
 + + vba                                         : Enable support for VBA compatibility and ActiveX embedding
 + + webdav                                      : Adds support for HTTP content adding via net-libs/neon
Comment 4 Andreas K. Hüttel gentoo-dev 2013-12-07 21:05:08 UTC
If you have the cpu time handy, please keyword libreoffice-4.1.3.2-r2 (it has
no keywords yet so you need something like

=app-office/libreoffice-4.1.3.2-r2 **

) and test it; the drag-and-drop infinite loop should be gone.
(Rebuilding myself still...)

This is also including the fix for bug 489656 and is completely untested so far.
Comment 5 Andreas Sturmlechner gentoo-dev 2013-12-08 09:30:36 UTC
Seems to be fixed after last night's update as well. ;)
Comment 6 Paolo Pedroni 2013-12-09 13:43:53 UTC
(In reply to Andreas K. Hüttel from comment #4)
> If you have the cpu time handy, please keyword libreoffice-4.1.3.2-r2 (it has
> no keywords yet so you need something like
> 
> =app-office/libreoffice-4.1.3.2-r2 **
> 
> ) and test it; the drag-and-drop infinite loop should be gone.
> (Rebuilding myself still...)
> 
> This is also including the fix for bug 489656 and is completely untested so
> far.

Just finished recompiling, and it looks good, so far.
Comment 7 Frank Krömmelbein 2013-12-09 14:10:54 UTC
Looks good here too.
Comment 8 Andreas K. Hüttel gentoo-dev 2013-12-10 17:57:34 UTC
Sounds good. Keywords restored in 4.1.3.2-r2.
Comment 9 Stephan Karacson 2013-12-11 20:52:04 UTC
works fine, thank you.
Comment 10 Alexandre 2013-12-11 21:37:05 UTC
Fixed here. Thanks!