Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 489656 - app-office/libreoffice-4.1.2.3 USE="kde" save dialog crashes libreoffice, QWidget::repaint: Recursive repaint detected
Summary: app-office/libreoffice-4.1.2.3 USE="kde" save dialog crashes libreoffice, QWi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
: 490504 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-28 11:52 UTC by Franz Trischberger
Modified: 2014-05-02 13:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
backtrace (lo_filesave.bt,15.56 KB, text/plain)
2013-10-28 11:52 UTC, Franz Trischberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franz Trischberger 2013-10-28 11:52:50 UTC
Created attachment 362130 [details]
backtrace

The dialog for saving the file takes some time here to pop up. Moving the pointer into the dialog can crash libreoffice. I tried with different styles, and until now I only could reproduce it with oxygen style. The easiest way to crash it is to move the pointer to the point where a file/dir of the main file view will be shown, not the sidebar (I already had crashes there, but it is not that easy to reproduce).
I wanted to get a verbose backtrace, but 921MB is too much for the bandwidth :( So if someone who can reproduce the crash could create a better backtrace, would be nice.

Attached the backtrace I can produce, symbol names of libreoffice obviously missing...
Comment 1 Franz Trischberger 2013-10-28 12:05:00 UTC
OK, it really crashes everytime I move my cursor fast enough over the different elements of the save dialog. libreoffice-bin-4.1.2.3[kde] + oxygen is not usable here. Downgrading to libreoffice-bin-4.0.42 completely fixes the issue.
I am quite sure that also libreoffice (source version) is affected, so if someone could test would be great!
The file save dialog executed from kde apps is completely stable, so most likely it's an issue how libreoffice does event filtering.

latest (testing) kdelibs/oxygen-style are used.

$ emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.15-r3, 3.11.3-gentoo x86_64)
=================================================================
System uname: Linux-3.11.3-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:     7885768 total,   4749876 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of tree: Sun, 27 Oct 2013 17:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45::<unknown repository>
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r4, 3.2.5-r3
dev-util/ccache:          3.1.9::<unknown repository>
dev-util/cmake:           2.8.12
dev-util/pkgconfig:       0.28::<unknown repository>
sys-apps/baselayout:      2.2::<unknown repository>
sys-apps/openrc:          0.12.3
sys-apps/sandbox:         2.6-r1::<unknown repository>
sys-devel/autoconf:       2.13::<unknown repository>, 2.69::<unknown repository>
sys-devel/automake:       1.11.6::<unknown repository>, 1.12.6::<unknown repository>, 1.13.4
sys-devel/binutils:       2.23.2::<unknown repository>
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3::<unknown repository>
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4::<unknown repository>
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.15-r3::<unknown repository>
Repositories: gentoo ff2000 kde local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7-avx -O2 -pipe -ggdb"
DISTDIR="/var/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j10"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/repositories/gentoo"
PORTDIR_OVERLAY="/var/repositories/ff2000 /var/repositories/kde /var/repositories/local"
SYNC="rsync://rsync15.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apm berkdb bluray branding bzip2 cairo cdda cdr cli cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm iconv introspection ipv6 jpeg jpeg2k kde lcms mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nvidia ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 sse3 sse4 sse4_1 ssl ssse3 startup-notification svg systemd tcpd theora threads tiff truetype udev udisks unicode upower usb vaapi vorbis vpx wxwidgets x264 xcb xcomposite xml xscreensaver xv xvid zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="krita sheets words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de de_DE" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="i915 i965 intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2013-10-31 15:47:58 UTC
The crash seems to be caused by wrong langpack. I restricted the versions there so sync and let us know if it is fine.



Also for debug symbols. You can install libreoffice-bin-debug, just for further refference.
Comment 3 Franz Trischberger 2013-10-31 16:52:11 UTC
The langpack does not fix this crash. Had it already installed, but synced again, reinstalled both libreoffice-bin + l10n and the file save dialog still crashes.
And as I stated I know about libreoffice-bin-debug, but the 921 MB are too much for the bandwith with ~45kB/s... Half a day of downloading just for a better backtrace ;)
Comment 4 Andreas Sturmlechner gentoo-dev 2013-11-01 18:24:32 UTC
(In reply to Franz Fellner from comment #1)
> I am quite sure that also libreoffice (source version) is affected, so if
> someone could test would be great!

Confirmed with libreoffice-4.1.2.3. I've had that bug a while ago with 4.1.something and was just very glad that I didn't need to touch localc for a long time afterwards again.
Comment 5 Andreas K. Hüttel gentoo-dev 2013-11-01 19:56:58 UTC
Problem not specific to bin version, I've also seen it in the source version myself.
Comment 6 Franz Trischberger 2013-11-02 13:16:58 UTC
Updated to 4.1.3.2 and the kde save dialog still crashes libreoffice-bin :(
Comment 7 Ulenrich 2013-11-03 15:57:45 UTC
Use flag "kde" behaves badly when runing libreoffice in a kde session!
Comment 8 Andreas K. Hüttel gentoo-dev 2013-11-06 16:18:47 UTC
*** Bug 490504 has been marked as a duplicate of this bug. ***
Comment 9 Andreas K. Hüttel gentoo-dev 2013-12-07 20:32:20 UTC
If you have the cpu time handy, please keyword libreoffice-4.1.3.2-r1 (it has no keywords yet so you need something like

=app-office/libreoffice-4.1.3.2-r1 **

) and test it; the kde-related crash in the file dialog should be gone. (Rebuilding myself still...)
Comment 10 George L. Emigh 2013-12-08 00:50:04 UTC
amd64

coincidence or not libreoffice-4.1.3.2-r2, I can no longer make it crash in the save dialog.
Comment 11 Andreas Sturmlechner gentoo-dev 2013-12-08 09:29:15 UTC
So far I couldn't reproduce this after last night's update.
Comment 12 Frank Krömmelbein 2013-12-09 14:09:20 UTC
Looks good. Also no crash anymore.
Comment 13 Andrea Cascio 2013-12-10 16:36:33 UTC
I was haunted by crashes in the KDE "save as" requester, although I had no way to reproduce the bug 100% of the times. But the problem seems gone with 4.1.3.2-r2. No crashes since the update.
Comment 14 Andreas K. Hüttel gentoo-dev 2013-12-10 17:56:31 UTC
Sounds good. Keywords restored on -r2.