Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 487944 - dev-libs/libevdev x11-drivers/xf86-input-evdev-2.9.0 keywording request
Summary: dev-libs/libevdev x11-drivers/xf86-input-evdev-2.9.0 keywording request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 517452 (view as bug list)
Depends on:
Blocks: 530652
  Show dependency tree
 
Reported: 2013-10-13 23:16 UTC by Chí-Thanh Christopher Nguyễn
Modified: 2015-01-25 16:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chí-Thanh Christopher Nguyễn gentoo-dev 2013-10-13 23:16:41 UTC
Arches, please keyword dev-libs/libevdev-0.4
This is needed for >=x11-drivers/xf86-input-evdev-2.9

Target keywords: ~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-10-14 14:39:18 UTC
Keyworded ~ppc.
Comment 2 Jeroen Roovers gentoo-dev 2013-10-16 14:18:05 UTC
Marked ~hppa.
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-10-17 13:27:26 UTC
Keyworded ~arm.
Comment 4 bing 2013-10-22 05:06:51 UTC
I believe --disable-gcov should be added in src_configure session to disable profiling, see rhbz #1012180 https://bugzilla.redhat.com/show_bug.cgi?id=1012180
Comment 5 Sergey Popov gentoo-dev 2013-10-22 09:23:04 UTC
(In reply to bing from comment #4)
> I believe --disable-gcov should be added in src_configure session to disable
> profiling, see rhbz #1012180
> https://bugzilla.redhat.com/show_bug.cgi?id=1012180

Please, open a separate bugreport for this, this one is for keywording purposes
Comment 6 Myckel Habets 2013-10-30 20:40:53 UTC
Builds fine on ~x86, please keyword for ~x86.
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-11-01 17:24:37 UTC
Keyworded ~x86, thanks Myckel
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2013-11-01 17:27:13 UTC
~mips added
Comment 9 Matt Turner gentoo-dev 2013-11-04 00:00:15 UTC
added ~alpha.
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-05-14 16:48:11 UTC
x11-drivers/xf86-input-evdev-2.8.99.1 and x11-drivers/xf86-input-synaptics-1.8.0 which depend on dev-libs/libevdev have been added to the tree.
Comment 11 Akinori Hattori gentoo-dev 2014-06-15 14:29:42 UTC
ia64 done
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-07-21 09:10:06 UTC
I will unmask and drop keywords on >=x11-drivers/xf86-input-evdev-2.9.0 and >=x11-drivers/xf86-input-synaptics-1.8.0 in a week for those arches that have not keyworded libevdev yet.
Comment 13 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-07-21 09:11:16 UTC
*** Bug 517452 has been marked as a duplicate of this bug. ***
Comment 14 Anthony Basile gentoo-dev 2014-09-28 10:46:35 UTC
Keyworded ~ppc64
Comment 15 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-10-23 15:09:59 UTC
sh and sparc keywords have been dropped from xf86-input-evdev-2.9.0
Comment 16 Raúl Porcel (RETIRED) gentoo-dev 2015-01-25 16:52:55 UTC
~sh/~sparc done