Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 481738 - gnome-base/gnome-core-apps: cleanup
Summary: gnome-base/gnome-core-apps: cleanup
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 464736 567760 (view as bug list)
Depends on:
Blocks: gnome-3.8
  Show dependency tree
 
Reported: 2013-08-20 11:33 UTC by Pacho Ramos
Modified: 2015-12-11 15:20 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2013-08-20 11:33:00 UTC
Reading ebuild I saw:
# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
# any apps, but shouldn't be used by users unless they know what they are doing.


And, then, I wonder if we really should supply it. gnome-base/gnome with all USE flags disabled will get a fairly minimum desktop, the only additions would be:
        >=app-crypt/gcr-${PV} -> needed by gnome-shell
        >=gnome-base/gnome-keyring-${PV} -> I think should be mandatory
        >=gnome-extra/evolution-data-server-${PV} -> needed by gnome-shell
        >=app-crypt/seahorse-${PV} -> this is really useful, do we really want people to drop it?
        >=app-editors/gedit-${PV} -> Maybe could be moved to "extras" or a "minimal" USE flag could be added to gnome-base/gnome
        >=app-text/evince-${PV} -> Probably interesting to move it to "extras"
        >=gnome-extra/gnome-contacts-${PV} -> I would do the same -> extras
        >=media-gfx/eog-${PV} -> unsure since it's useful and I don't see much lightweight replacements
        >=media-video/totem-${PV} -> I would have no problem installing it, maybe put it behind a "+gstreamer" USE flag could help if people get angry :/
        >=net-im/empathy-${PV} -> I really think this belong to "extras" (well, I am still a pidgin user :P)
        >=gnome-extra/gnome-user-docs-${PV}
        >=gnome-extra/yelp-${PV} -> I would really make this optional due the really heavy webkit-gtk requirement 

What do you think?
Comment 1 Pacho Ramos gentoo-dev 2013-08-20 11:34:08 UTC
Regarding "seahorse" I am referring it's useful if we pull in gnome-keyring ;)
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-08-20 11:43:33 UTC
(In reply to Pacho Ramos from comment #0)
> And, then, I wonder if we really should supply it. gnome-base/gnome with all
> USE flags disabled will get a fairly minimum desktop, the only additions
> would be:

If USE flags give the control such that gnome-light can almost be mimicked, I'd say give it a go; otherwise I wouldn't appreciate it (and would thus go back to to merging its dependencies in a set :P).

>         >=gnome-extra/evolution-data-server-${PV} -> needed by gnome-shell

Hmm, wish this were optional; I don't see the point in having this when I do not have or want Evolution as I use something else, I could look into making this optional again. It's a fairly simple patch to remove the TODO's from the pop out menu when you click at the top of GNOME shell.

>         >=app-crypt/seahorse-${PV} -> this is really useful, do we really
> want people to drop it?

Well, I don't feel a need to use it; probably others will feel the same.

>         >=media-video/totem-${PV} -> I would have no problem installing it,
> maybe put it behind a "+gstreamer" USE flag could help if people get angry :/

Yes, it will at least bother them; people usually run something they prefer.

>         >=gnome-extra/gnome-user-docs-${PV}

Assuming this is the documentation, doc USE flag? :)

>         >=gnome-extra/yelp-${PV} -> I would really make this optional due
> the really heavy webkit-gtk requirement 

Yes, it is nice to be able to use GNOME 3.8 without webkit-gtk; I do that.
Comment 3 Pacho Ramos gentoo-dev 2013-08-20 11:56:02 UTC
(In reply to Tom Wijsman (TomWij) from comment #2)
[...]
> >         >=gnome-extra/evolution-data-server-${PV} -> needed by gnome-shell
> 
> Hmm, wish this were optional; I don't see the point in having this when I do
> not have or want Evolution as I use something else, I could look into making
> this optional again. It's a fairly simple patch to remove the TODO's from
> the pop out menu when you click at the top of GNOME shell.
> 

Well, I first thought on pulling it *in the meta* depending on global "eds" USE flag... but if it's mandatory by gnome-shell... I am unsure :/ Regarding making it optional in gnome-shell too, I would wait for other team members opinion as usually upstream refuses that changes and carrying one more patch like this forever would add us more work

> >         >=app-crypt/seahorse-${PV} -> this is really useful, do we really
> > want people to drop it?
> 
> Well, I don't feel a need to use it; probably others will feel the same.
> 

OK, after re-thinking it I think you are true => maybe under "extras"...

> >         >=media-video/totem-${PV} -> I would have no problem installing it,
> > maybe put it behind a "+gstreamer" USE flag could help if people get angry :/
> 
> Yes, it will at least bother them; people usually run something they prefer.
> 
> >         >=gnome-extra/gnome-user-docs-${PV}
> 
> Assuming this is the documentation, doc USE flag? :)
> 
> >         >=gnome-extra/yelp-${PV} -> I would really make this optional due
> > the really heavy webkit-gtk requirement 
> 
> Yes, it is nice to be able to use GNOME 3.8 without webkit-gtk; I do that.

Well, I doubt between putting yelp/gnome-user-docs under "doc" or "webkit" or one per each. The problem is that gnome-user-docs won't probably be useful without yelp
Comment 4 Alexander Tsoy 2013-08-21 00:20:42 UTC
I'm currently using gnome-light. But if gnome metapackage will provide the same via use flags, this would be OK.
Comment 5 Gilles Dartiguelongue gentoo-dev 2013-08-25 16:05:20 UTC
Are we going to discuss this again to end up to the same conclusion.

This is afair the 3rd bug about this in the last years, gnome ebuild is for 
what we consider to be, as per usptream recommendations, the gnome desktop.

gnome-light is meant for nay-sayers to want to have their word on everything.

Please keep it that way.
Comment 6 Pacho Ramos gentoo-dev 2013-08-26 06:37:16 UTC
(In reply to Gilles Dartiguelongue from comment #5)
> Are we going to discuss this again to end up to the same conclusion.
> 
> This is afair the 3rd bug about this in the last years, gnome ebuild is for 
> what we consider to be, as per usptream recommendations, the gnome desktop.
> 
> gnome-light is meant for nay-sayers to want to have their word on everything.
> 
> Please keep it that way.

OK:

- What about the webkit USE flag for gnome-base/gnome? webkit-gtk is really a beast that takes really a long time and resources to compile :S
Comment 7 Gilles Dartiguelongue gentoo-dev 2013-08-26 07:04:10 UTC
webkit is used in epiphany, evolution and empathy, all core apps to my understanding. A use flag in gnome-core-apps ebuild is ok, but in my opinion, it must be enable for gnome meta.
Comment 8 Pacho Ramos gentoo-dev 2013-08-26 07:33:49 UTC
I guess would be similar to cdr and bluetooth -> add webkit USE for core, and webkit? for gnome ebuild, enabling by default on both
Comment 9 Pacho Ramos gentoo-dev 2013-08-27 16:41:43 UTC
(In reply to Pacho Ramos from comment #8)
> I guess would be similar to cdr and bluetooth -> add webkit USE for core,
> and webkit? for gnome ebuild, enabling by default on both

Forget that, I was thinking in other meta ;)
Comment 10 Pacho Ramos gentoo-dev 2013-09-01 18:39:06 UTC
Seeing metas again, looks like webkit USE flag wouldn't save much. Packages needing webkit-gtk in gnome-core-apps meta are:
yelp -> this with gnome-user-docs could be behind a "+doc" USE flag
empathy -> wouldn't it fit better in gnome-extra-apps meta? I have used it only one time after installing first 3.8 version, after that I reverted to pidgin and I don't think it is a "core" app at all.
Comment 11 Pacho Ramos gentoo-dev 2013-09-11 13:57:43 UTC
Well, as looks like Gilles and me are not able to reach a consensus on this, will close and keep status quo (as the other team members don't have a strong opinion on this)
Comment 12 Pacho Ramos gentoo-dev 2013-09-11 13:59:01 UTC
*** Bug 464736 has been marked as a duplicate of this bug. ***
Comment 13 Pacho Ramos gentoo-dev 2015-12-11 15:20:08 UTC
*** Bug 567760 has been marked as a duplicate of this bug. ***