Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477702 - >=www-servers/apache-2.4.6 with www-apache/mod_macro - file collision in /usr/lib64/apache2/modules/mod_macro.so
Summary: >=www-servers/apache-2.4.6 with www-apache/mod_macro - file collision in /usr...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL: http://people.apache.org/~fabien/mod_...
Whiteboard:
Keywords: NeedPatch
: 521342 535840 (view as bug list)
Depends on:
Blocks: apache-2.4-stable 513232
  Show dependency tree
 
Reported: 2013-07-22 06:41 UTC by Jan Vansteenkiste
Modified: 2015-06-07 19:26 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
apache-2.4.6.ebuild patch (apache-2.4.6-mod_macro.patch,1.04 KB, patch)
2013-07-22 06:55 UTC, Jan Vansteenkiste
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Vansteenkiste 2013-07-22 06:41:22 UTC
Since apache 2.4.6, mod_macro seems to be included in the apache package itself. There is no use flag available to enable/disable mod_macro and it currently conflicts if mod_macro is installed.

Reproducible: Always

Steps to Reproduce:
1. emerge mod_macro
2. emerge apache

Actual Results:  
* Detected file collision(s):
 * 
 * 	/usr/lib64/apache2/modules/mod_macro.so


Expected Results:  
apache 2.4.6 blocks mod_macro and includes a use flag to enable/disable.
Comment 1 Jan Vansteenkiste 2013-07-22 06:55:46 UTC
Created attachment 353836 [details, diff]
apache-2.4.6.ebuild patch

Fixes macro as a apache built-in module and blocks mod_macro external package.
Comment 2 Jan Vansteenkiste 2013-07-22 06:58:26 UTC
What still needs to be done:

Add mod_macro config file and example in gentoo-apache and enable including them in the ebuild.
Comment 3 Michael Orlitzky gentoo-dev 2014-05-22 18:34:25 UTC
Reassigning to current apache maintainer, conflict confirmed.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2014-08-28 08:50:09 UTC
*** Bug 521342 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2015-01-07 07:44:40 UTC
*** Bug 535840 has been marked as a duplicate of this bug. ***
Comment 6 Pacho Ramos gentoo-dev 2015-05-08 19:13:50 UTC
Looks like current ebuild sets RDEPEND/DEPEND at eclass level (also affecting to 2.2) :S
Comment 7 Pacho Ramos gentoo-dev 2015-06-03 08:47:12 UTC
If anyone could provide a patch for current ebuild and eclass, it would for sure help to get this finally solved

Thanks
Comment 8 Tomáš Mózes 2015-06-03 11:21:13 UTC
Wouldn't it be enough to add a block to apache-2.eclass?

Currently we have:
case $(get_version_component_range 1-2) in
    2.4)
        DEFAULT_MPM_THREADED="event" #509922
        RDEPEND=">=dev-libs/apr-1.5.1" #492578
    ;;
    *)  
        DEFAULT_MPM_THREADED="worker"
        RDEPEND=">=dev-libs/apr-1.4.5" #368651
    ;;
esac

How about to add and RDEPEND line to all 2.4
!www-apache/mod_macro
Comment 9 Pacho Ramos gentoo-dev 2015-06-07 19:26:10 UTC
+  07 Jun 2015; Pacho Ramos <pacho@gentoo.org> -apache-2.4.12.ebuild,
+  apache-2.4.12-r1.ebuild, metadata.xml:
+  mod_macro is now provided by apache itself (#477702 by Jan Vansteenkiste, and
+  Tomas Mozes)
+