Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477290 - =media-libs/libv4l-0.9.5 on uclibc - configure: error: Cannot continue: argp.h not found
Summary: =media-libs/libv4l-0.9.5 on uclibc - configure: error: Cannot continue: argp....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrey Utkin
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: musl-porting uclibc-porting
  Show dependency tree
 
Reported: 2013-07-18 12:10 UTC by Amadeusz Sławiński
Modified: 2019-06-17 17:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,9.37 KB, text/plain)
2013-07-18 12:10 UTC, Amadeusz Sławiński
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Amadeusz Sławiński 2013-07-18 12:10:01 UTC
It fails during configure searching for argp.h

checking argp.h usability... no
checking argp.h presence... no
checking for argp.h... no
configure: error: Cannot continue: argp.h not found


Reproducible: Always




Portage 2.1.12.13 (hardened/linux/uclibc/amd64, gcc-4.7.3, uclibc-0.9.33.2-r4, 3.10.0-hardened x86_64)
=================================================================
System uname: Linux-3.10.0-hardened-x86_64-Intel-R-_Core-TM-_i3_CPU_M_350_@_2.27GHz-with-gentoo-2.2
KiB Mem:     2994964 total,   1977672 free
KiB Swap:    3145724 total,   3145724 free
Timestamp of tree: Wed, 17 Jul 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.3-r3, 3.2.5-r1, 3.3.2-r1
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.6.4, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/uclibc:          0.9.33.2-r4
Repositories: gentoo x-hardened-development x-portage-crossdev local-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-gentoo-linux-uclibc"
CFLAGS="-fstack-check -O2 -march=native -pipe"
CHOST="x86_64-gentoo-linux-uclibc"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-fstack-check -O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch webrsync-gpg xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/hardened-development /usr/local/portage-crossdev /home/amade/overlay"
SYNC=""
USE="X acpi alsa amd64 bash-completion bluetooth cli cracklib crypt cups cxx dbus dri dvd flac fortran gif gnutls gold gpg hardened iconv icu ipv6 jpeg jpeg2k mmx mng modules mp3 mudflap ncurses nptl opengl openmp pax_kernel pcre pic png readline session sse sse2 sse4_2 ssl ssse3 tcpd threads tiff uclibc udev unicode usb v4l vim-syntax wacom xattr xft xinerama zlib zsh-completion" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="uclibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB pl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 ppc" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Amadeusz Sławiński 2013-07-18 12:10:19 UTC
Created attachment 353574 [details]
build.log
Comment 2 Anthony Basile gentoo-dev 2013-07-18 15:26:13 UTC
Okay here's why: argp is not provided by uclibc.  Instead you need sys-libs/argp-standalone and you need to append -largp to the LDFLAGS.  Take a look at bug #470884 comment #14.  You'd also have to change the DEPEND so that

    uclibc? ( sys-libs/argp-standalone )
Comment 3 Alexis Ballier gentoo-dev 2013-07-18 16:18:05 UTC
(In reply to Anthony Basile from comment #2)
>     uclibc? ( sys-libs/argp-standalone )

if this is going to spread, please provide a virtual for this like we do for libiconv or libintl.
Comment 4 Anthony Basile gentoo-dev 2013-07-27 12:46:43 UTC
(In reply to Alexis Ballier from comment #3)
> (In reply to Anthony Basile from comment #2)
> >     uclibc? ( sys-libs/argp-standalone )
> 
> if this is going to spread, please provide a virtual for this like we do for
> libiconv or libintl.

Aha!  good point.
Comment 5 Felix Janda 2015-05-14 17:02:36 UTC
argp is also not provided by musl. So the musl profiles would also
benefit from the virtual.
Comment 6 Andrey Utkin gentoo-dev 2019-06-04 08:59:59 UTC
Managed to set up the environment to reproduce this.
Will add this dep.
Will add it directly first, then will see if I can make the virtual thing.
Comment 7 Larry the Git Cow gentoo-dev 2019-06-05 18:23:34 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=30f4049a39b818052c0ad71c7a8493c7ab6063ec

commit 30f4049a39b818052c0ad71c7a8493c7ab6063ec
Author:     Andrey Utkin <andrey_utkin@gentoo.org>
AuthorDate: 2019-06-05 18:19:21 +0000
Commit:     Andrey Utkin <andrey_utkin@gentoo.org>
CommitDate: 2019-06-05 18:20:11 +0000

    media-libs/libv4l: depend on argp-standalone in non-glibc envs
    
    Before, on musl and uclibc based profiles emerge libv4l failed due to
    missing sys-libs/argp-standalone.
    
    This commit affects only newly-added version 1.16.6 which will become
    default only after stabilization.
    
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=561866
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=477290
    Package-Manager: Portage-2.3.62, Repoman-2.3.12
    Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>

 media-libs/libv4l/libv4l-1.16.6.ebuild | 1 +
 1 file changed, 1 insertion(+)
Comment 8 Andrey Utkin gentoo-dev 2019-06-17 17:09:14 UTC
Hope the commit pushed on Jun 5 helped.
Postponing virtual/argp idea for now - can always be done when we run out of more tangible problems, the current situation doesn't seem too painful to me.