Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 561866 - media-libs/libv4l needs sys-libs/argp-standalone on musl targets
Summary: media-libs/libv4l needs sys-libs/argp-standalone on musl targets
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrey Utkin
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-29 21:02 UTC by David Flogeras
Modified: 2019-06-17 17:09 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Flogeras 2015-09-29 21:02:30 UTC
configure fails if no argp.h is found.  On musl, it is standard practice to use argp-standalone since the C implementation does not provide it like with glibc.

Reproducible: Always
Comment 1 Felix Janda 2015-10-06 07:44:27 UTC
This is almost exactly the same as bug 477290
Comment 2 Andrey Utkin gentoo-dev 2019-05-20 18:24:29 UTC
I've just tried to reproduce this (with latest stable which is 1.16.3), and the thing appears to work.

    ebuildtester --atom media-libs/libv4l --portage-dir /home/j/work/foss/gentoo/gentoo --profile default/linux/amd64/17.0/musl

(I patched ebuildtester to work on arbitrary profile).

Am I missing anything?
Comment 3 tt_1 2019-05-21 07:51:17 UTC
it seems so: 

checking for ALSA... yes
checking for libudev... yes
checking whether x86_64-gentoo-linux-musl-gcc is Clang... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking whether more special flags are required for pthreads... no
checking for PTHREAD_PRIO_INHERIT... yes
checking for library containing dlopen... none required
checking argp.h usability... no
checking argp.h presence... no
checking for argp.h... no
configure: error: Cannot continue: argp.h not found

the bug could be mitigated by adding sys-libs/argp-standalone in case of elibc_musl 

(it's libv4l-1.16.3 here)
Comment 4 Larry the Git Cow gentoo-dev 2019-06-05 18:23:36 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=30f4049a39b818052c0ad71c7a8493c7ab6063ec

commit 30f4049a39b818052c0ad71c7a8493c7ab6063ec
Author:     Andrey Utkin <andrey_utkin@gentoo.org>
AuthorDate: 2019-06-05 18:19:21 +0000
Commit:     Andrey Utkin <andrey_utkin@gentoo.org>
CommitDate: 2019-06-05 18:20:11 +0000

    media-libs/libv4l: depend on argp-standalone in non-glibc envs
    
    Before, on musl and uclibc based profiles emerge libv4l failed due to
    missing sys-libs/argp-standalone.
    
    This commit affects only newly-added version 1.16.6 which will become
    default only after stabilization.
    
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=561866
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=477290
    Package-Manager: Portage-2.3.62, Repoman-2.3.12
    Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>

 media-libs/libv4l/libv4l-1.16.6.ebuild | 1 +
 1 file changed, 1 insertion(+)
Comment 5 Andrey Utkin gentoo-dev 2019-06-17 17:09:04 UTC
Hope the commit pushed on Jun 5 helped.
Postponing virtual/argp idea for now - can always be done when we run out of more tangible problems, the current situation doesn't seem too painful to me.