Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 464754 - >=net-im/ktp-call-ui-0.6.0 fails to compile with >net-libs/telepathy-farstream-0.4.0
Summary: >=net-im/ktp-call-ui-0.6.0 fails to compile with >net-libs/telepathy-farstrea...
Status: RESOLVED DUPLICATE of bug 449296
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-05 16:33 UTC by Vladi
Modified: 2013-04-20 20:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,84.18 KB, text/plain)
2013-04-05 16:33 UTC, Vladi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladi 2013-04-05 16:33:06 UTC
In file included from /usr/include/gstreamer-1.0/gst/gstevent.h:179:0,
                 from /usr/include/gstreamer-1.0/gst/gstpadtemplate.h:36,
                 from /usr/include/gstreamer-1.0/gst/gstpad.h:68,
                 from /usr/include/gstreamer-1.0/gst/gstelement.h:57,
                 from /usr/include/gstreamer-1.0/gst/gstbin.h:27,
                 from /usr/include/gstreamer-1.0/gst/gst.h:34,
                 from /usr/include/telepathy-1.0/telepathy-farstream/channel.h:5,
                 from /usr/include/telepathy-1.0/telepathy-farstream/telepathy-farstream.h:23,
                 from /tmp/portage/net-im/ktp-call-ui-0.6.0/work/ktp-call-ui-0.6.0/libqtf/qtf.cpp:22:
/usr/include/gstreamer-1.0/gst/gsttaglist.h:152:28: error: conflicting declaration 'typedef struct _GstTagList GstTagList'
/usr/include/QtGStreamer/QGst/global.h:134:1: error: 'GstTagList' has a previous declaration as 'typedef struct _GstStructure GstTagList'
distcc[24590] ERROR: compile /tmp/portage/net-im/ktp-call-ui-0.6.0/work/ktp-call-ui-0.6.0/libqtf/qtf.cpp on localhost failed


Reproducible: Always

Steps to Reproduce:
1.emerge net-im/ktp-call-ui-0.6.0


Expected Results:  
success

Portage 2.1.11.55 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.17, 3.8.4 x86_64)
=================================================================
System uname: Linux-3.8.4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_U9400_@_1.40GHz-with-gentoo-2.1
KiB Mem:     3950272 total,   1367724 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Fri, 05 Apr 2013 06:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo kde
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="256-color X a52 aac aalib acpi adns alsa alt-font-width amd64 archive asf aspell async autoreplace bash-completion branding bzip2 c++0x cairo cdda cdinstall cdr chroot cli consolekit cracklib crypt cups curl custom-cflags custom-optimization cxx dbus declarative dhcp disk-partition divx divx4linux dri dts dvd dvdr egl emerald enca encode exif faac farstream ffmpeg firefox flac focused-urgency font-styles fortran fts3 fuse gd gdbm gecko-sdk geoip gif gles gles2 glibc-omitfp glitz gmedia gnome-keyring gnutls google gphoto2 gps gstreamer gtk gudev hardcoded-tables hddtemp history hpn hwdb ibmacpi iconv id3tag imagemagick imap imlib infinality inotify introspection iproute2 ithreads jabber javascript jpeg kde kdehiddenvisibility kdenlive kdepim kdexdeltas kipi lame laptop lcdfilter lcms libcaca libkms libnotify logrotate lzo mad matroska minizip mmx mmxext mng modules mousewheel mozbranding moznocompose moznoirc moznomail mozsvg mp3 mp4 mpeg mudflap multilib musicbrainz mysql ncurses networkmanager nfsv3 nonfsv4 nptl nsplugin offensive ogg opengl openmp openvg optimized-qmake pam pango pch pcre pdf perl phonon pic plasma png pnp policykit ppds pulseaudio python python3 qt3support qt4 rar rdesktop readline rss rtc samba sasl scrobbler sdl secondary-wheel secure-delete semantic-desktop session shared-dricore sip sipim smi smime smtp sna snmp speex spell sqlite srt sse sse2 sse3 ssl ssse3 stroke svg telepathy theora thinkpad threads tidy tiff tordns truetype udev udisks udisks2 unicode upower urandom usb userlocales v4l2 vim vim-syntax vnc vorbis vpx webkit wifi wma wmp x264 xcb xcomposite xforms xml xosd xrandr xscreensaver xv xvid xvmc yahoo zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport wiki-publisher" LINGUAS="en bg" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Vladi 2013-04-05 16:33:43 UTC
Created attachment 344518 [details]
build.log
Comment 2 Reuben Martin 2013-04-12 04:16:49 UTC
This is due to qt-gstreamer not building with gstreamer-1.0 yet.
Comment 3 Kamen Dokov 2013-04-12 17:18:18 UTC
Same here on ~amd64
Comment 4 Erich Seifert 2013-04-12 17:24:51 UTC
The solution is/was to downgrade to net-libs/telepathy-farstream-0.4.0. This should already be fixed. Please emerge --sync and try again.
Comment 5 Kamen Dokov 2013-04-12 18:23:52 UTC
(In reply to comment #4)
> The solution is/was to downgrade to net-libs/telepathy-farstream-0.4.0. This
> should already be fixed. Please emerge --sync and try again.

That was it, thank you;)
Comment 6 Johannes Huber gentoo-dev 2013-04-20 20:19:39 UTC

*** This bug has been marked as a duplicate of bug 449742 ***
Comment 7 Johannes Huber gentoo-dev 2013-04-20 20:24:39 UTC

*** This bug has been marked as a duplicate of bug 449296 ***