Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 449296 - net-im/ktp-call-ui fails to build with >=net-libs/telepathy-farstream-0.6
Summary: net-im/ktp-call-ui fails to build with >=net-libs/telepathy-farstream-0.6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: fixed in 0.9.0
Keywords:
: 449742 464754 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-30 12:38 UTC by Dennis Schridde
Modified: 2014-10-31 13:53 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,86.14 KB, text/plain)
2012-12-30 12:39 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2012-12-30 12:38:51 UTC
media-libs/qt-gstreamer-0.10.2 has RDEPEND=">=media-libs/gstreamer-0.10.33:0.10", but when net-im/ktp-call-ui-0.5.1 is being built, it includes the gstreamer-1.0 headers:

In file included from /usr/include/gstreamer-1.0/gst/gstevent.h:179:0,
                 from /usr/include/gstreamer-1.0/gst/gstpadtemplate.h:36,
                 from /usr/include/gstreamer-1.0/gst/gstpad.h:68,
                 from /usr/include/gstreamer-1.0/gst/gstelement.h:57,
                 from /usr/include/gstreamer-1.0/gst/gstbin.h:27,
                 from /usr/include/gstreamer-1.0/gst/gst.h:34,
                 from /usr/include/telepathy-1.0/telepathy-farstream/channel.h:5,
                 from /usr/include/telepathy-1.0/telepathy-farstream/telepathy-farstream.h:23,
                 from /var/tmp/portage/net-im/ktp-call-ui-0.5.1/work/ktp-call-ui-0.5.1/libqtf/qtf.cpp:22:
/usr/include/gstreamer-1.0/gst/gsttaglist.h:152:28: error: conflicting declaration ‘typedef struct _GstTagList GstTagList’
In file included from /usr/include/QtGStreamer/QGst/miniobject.h:20:0,
                 from /usr/include/QtGStreamer/QGst/message.h:20,
                 from /usr/include/QtGStreamer/QGst/Message:1,
                 from /var/tmp/portage/net-im/ktp-call-ui-0.5.1/work/ktp-call-ui-0.5.1/libqtf/qtf.h:27,
                 from /var/tmp/portage/net-im/ktp-call-ui-0.5.1/work/ktp-call-ui-0.5.1/libqtf/qtf.cpp:18:
/usr/include/QtGStreamer/QGst/global.h:134:1: error: ‘GstTagList’ has a previous declaration as ‘typedef struct _GstStructure GstTagList’

Reproducible: Always
Comment 1 Dennis Schridde 2012-12-30 12:39:17 UTC
Created attachment 333754 [details]
build.log
Comment 2 Dennis Schridde 2012-12-30 12:47:48 UTC
The issue appears to be that net-libs/farstream-0.2.2 and net-libs/telepathy-farstream-0.6.0 have DEPEND="media-libs/gstreamer:1.0" while media-libs/qt-gstreamer-0.10.2 has DEPEND="media-libs/gstreamer:0.10".

So the parts of ktp-call-ui that depend on *farstream add the gstreamer-1.0 headers into the include path, which makes the qt-gstreamer related stuff fail.
Hence ktp-call-ui-0.5.1 has to block telepathy-farstream-0.6 and/or farstream-0.2.
Comment 3 Dennis Schridde 2012-12-30 12:52:10 UTC
(In reply to comment #2)
> Hence ktp-call-ui-0.5.1 has to block telepathy-farstream-0.6 and/or
> farstream-0.2.
... until a qt-gstreamer version compatible with gstreamer-1.0 is available.
Comment 4 Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2013-01-01 15:34:33 UTC
https://bugs.kde.org/show_bug.cgi?id=312450
Comment 5 Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2013-01-01 15:39:44 UTC
btw, just emerged ktp-*-0.5.1 with farstream (!) and gstreamer-0.10 (with manually removed 1.0 and with emerge -O to prevent deps calculation) — seems to works fine.
Comment 6 Dennis Schridde 2013-01-12 22:20:00 UTC
Fixed in kde overlay by DEPEND=<net-libs/telepathy-farstream-0.6. Builds successfully.
Comment 7 Ulenrich 2013-01-12 23:54:15 UTC
I confirm this patch does work by downgrading telepathy-farstream:

--- net-im/ktp-call-ui/ktp-call-ui-0.5.1.ebuild       2012-11-22 02:19:14.000000000 +0100
+++ net-im/ktp-call-ui-0.5.1.ebuild    2013-01-13 00:48:00.403899673 +0100
@@ -25,7 +25,7 @@
 DEPEND="
        >=media-libs/qt-gstreamer-0.10.2
        >=net-im/ktp-common-internals-${PV}
-       net-libs/telepathy-farstream
+       <net-libs/telepathy-farstream-0.6
        >=net-libs/telepathy-qt-0.9.3[farstream]
 "
 RDEPEND="${DEPEND}
Comment 8 Dennis Schridde 2013-01-13 00:20:27 UTC
(In reply to comment #7)
> I confirm this patch does work by downgrading telepathy-farstream:
Have you tested video/audio chat afterwards? I am asking, because I myself have no possibility to compare, as it never worked before. Would be nice if you could test and report back.
Comment 9 Johannes Huber gentoo-dev 2013-04-20 20:24:39 UTC
*** Bug 464754 has been marked as a duplicate of this bug. ***
Comment 10 Johannes Huber gentoo-dev 2013-04-20 20:25:22 UTC
*** Bug 449742 has been marked as a duplicate of this bug. ***
Comment 12 Geoff Madden 2014-05-06 09:59:29 UTC
(In reply to Ulenrich from comment #7)
> I confirm this patch does work by downgrading telepathy-farstream:
> 
> --- net-im/ktp-call-ui/ktp-call-ui-0.5.1.ebuild       2012-11-22
> 02:19:14.000000000 +0100
> +++ net-im/ktp-call-ui-0.5.1.ebuild    2013-01-13 00:48:00.403899673 +0100
> @@ -25,7 +25,7 @@
>  DEPEND="
>         >=media-libs/qt-gstreamer-0.10.2
>         >=net-im/ktp-common-internals-${PV}
> -       net-libs/telepathy-farstream
> +       <net-libs/telepathy-farstream-0.6
>         >=net-libs/telepathy-qt-0.9.3[farstream]
>  "
>  RDEPEND="${DEPEND}

The problem with this patch is it stops telepathy-farstream from ever being updated
Comment 13 Geoff Madden 2014-05-06 10:01:29 UTC
As an addition it would be better to fix ktp-call so farstream can be updated
Comment 14 Johannes Huber gentoo-dev 2014-05-06 10:59:40 UTC
(In reply to Geoff Madden from comment #13)
> As an addition it would be better to fix ktp-call so farstream can be updated

Yes you are right, but this is upstream work. You can follow the work here http://community.kde.org/KTp/Tasks/NewCallUI
Comment 15 Pacho Ramos gentoo-dev 2014-07-15 11:14:23 UTC
Fedora is using this patch for this:
http://pkgs.fedoraproject.org/cgit/ktp-call-ui.git/tree/ktp-call-ui-0.5.2-farstream_compat.patch
Comment 16 Johannes Huber gentoo-dev 2014-07-23 17:05:27 UTC
(In reply to Pacho Ramos from comment #15)
> Fedora is using this patch for this:
> http://pkgs.fedoraproject.org/cgit/ktp-call-ui.git/tree/ktp-call-ui-0.5.2-
> farstream_compat.patch

A simple build fix doesn't help here. See comment #13.
Comment 17 Pacho Ramos gentoo-dev 2014-07-23 18:28:20 UTC
But, is that fixing feasible taking care even upstream looks to not be able to do it?
Comment 18 Johannes Huber gentoo-dev 2014-07-23 18:34:44 UTC
(In reply to Pacho Ramos from comment #17)
> But, is that fixing feasible taking care even upstream looks to not be able
> to do it?

"fixing" means to allow not working version...
Comment 19 Reuben Martin 2014-07-30 00:17:44 UTC
media-libs/qt-gstreamer-1.2.0 has been released for a few days now. net-libs/telepathy-farstream-0.6.1 and net-im/ktp-call-ui now both build fine. Is there a reason this bug isn't closed yet, and the dependency on net-libs/telepathy-farstream-0.4.0 removed?
Comment 20 Johannes Huber gentoo-dev 2014-07-30 06:16:06 UTC
(In reply to Reuben Martin from comment #19)
> media-libs/qt-gstreamer-1.2.0 has been released for a few days now.
> net-libs/telepathy-farstream-0.6.1 and net-im/ktp-call-ui now both build
> fine. Is there a reason this bug isn't closed yet, and the dependency on
> net-libs/telepathy-farstream-0.4.0 removed?

There is no released version of net-im/ktp-call-ui which builds with media-libs/qt-gstreamer-1.2.0.
Comment 21 Reuben Martin 2014-07-30 14:07:08 UTC
(In reply to Johannes Huber from comment #20)
> There is no released version of net-im/ktp-call-ui which builds with
> media-libs/qt-gstreamer-1.2.0.

# equery files ktp-call-ui | grep lib
/usr/lib64
/usr/lib64/kde4
/usr/lib64/kde4/libexec
/usr/lib64/kde4/libexec/ktp-call-ui

# readelf -d /usr/lib64/kde4/libexec/ktp-call-ui | grep libQtGStreamer
 0x0000000000000001 (NEEDED)             Shared library: [libQtGStreamerUi-1.0.so.0]
 0x0000000000000001 (NEEDED)             Shared library: [libQtGStreamer-1.0.so.0]

# locate libQtGStreamer-1.0.so.0
/usr/lib64/libQtGStreamer-1.0.so.0

# equery belongs /usr/lib64/libQtGStreamer-1.0.so.0
 * Searching for /usr/lib64/libQtGStreamer-1.0.so.0 ... 
media-libs/qt-gstreamer-1.2.0 (/usr/lib64/libQtGStreamer-1.0.so.1.2.0)
media-libs/qt-gstreamer-1.2.0 (/usr/lib64/libQtGStreamer-1.0.so.0 -> libQtGStreamer-1.0.so.1.2.0)
Comment 22 Johannes Huber gentoo-dev 2014-07-30 14:10:20 UTC
(In reply to Reuben Martin from comment #21)
> # equery files ktp-call-ui | grep lib

[snip]

git master i guess...
Comment 23 Reuben Martin 2014-07-30 15:43:41 UTC
(In reply to Johannes Huber from comment #22)
> (In reply to Reuben Martin from comment #21)
> > # equery files ktp-call-ui | grep lib
> 
> [snip]
> 
> git master i guess...

# equery list ktp-call-ui
 * Searching for ktp-call-ui ...
[IP-] [  ] net-im/ktp-call-ui-0.8.1:4

I'm not entirely sure it's 100% functional, but it builds and links without any complaints.
Comment 24 Johannes Huber gentoo-dev 2014-07-30 16:38:48 UTC
(In reply to Reuben Martin from comment #23)
> [IP-] [  ] net-im/ktp-call-ui-0.8.1:4
> 
> I'm not entirely sure it's 100% functional, but it builds and links without
> any complaints.

Upstream git history shows that the qt-gstreamer-1.0 port was merged just some days ago. I don't know what you are emerging but not the tree ebuild, compare to bug #518508
Comment 25 Reuben Martin 2014-07-30 18:38:47 UTC
(In reply to Johannes Huber from comment #24)
> (In reply to Reuben Martin from comment #23)
> > [IP-] [  ] net-im/ktp-call-ui-0.8.1:4
> > 
> > I'm not entirely sure it's 100% functional, but it builds and links without
> > any complaints.
> 
> Upstream git history shows that the qt-gstreamer-1.0 port was merged just
> some days ago. I don't know what you are emerging but not the tree ebuild,
> compare to bug #518508

I was suspending dependency checking to see if it would work. (--nodeps) Don't worry about it. I've tested it out a bit and it doesn't work correctly.
Comment 26 Reuben Martin 2014-07-30 18:52:33 UTC
(In reply to Johannes Huber from comment #24)
> compare to bug #518508

It wasn't building because it requires net-libs/telepathy-farstream-0.6.1 to be built first. With telepathy-farstream-0.6.1 it will build and link, but then connections to sip servers don't always work correctly.
Comment 27 Michael Palimaka (kensington) gentoo-dev 2014-10-31 13:53:42 UTC
0.9.0 is in the tree now