Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 464650 - =dev-tcltk/blt-2.4z-r12 fails with tcl-8.6
Summary: =dev-tcltk/blt-2.4z-r12 fails with tcl-8.6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: TCL/TK Project
URL:
Whiteboard:
Keywords: PATCH
: 464694 484148 (view as bug list)
Depends on:
Blocks: tcltk-8.6
  Show dependency tree
 
Reported: 2013-04-04 21:23 UTC by Jimmy.Jazz
Modified: 2013-09-08 00:15 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-tcltk:blt-2.4z-r12:20130404-203915.log (file_464650.txt,19.13 KB, text/plain)
2013-04-04 21:48 UTC, Tom Wijsman (TomWij) (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy.Jazz 2013-04-04 21:23:25 UTC
unable to compile with gcc 4.7.2 because of deprecated api
Direct access to the result field is discouraged in Tcl 8.0
CFLAGS needs '-DUSE_INTERP_ERRORLINE -DUSE_INTERP_RESULT' because of 'result' is a TCL_DEPRECATED_API

--- /usr/portage/dev-tcltk/blt/blt-2.4z-r12.ebuild	2013-04-04 20:24:39.000000000 +0200
+++ blt-2.4z-r12.ebuild	2013-04-04 23:07:05.530710246 +0200
@@ -69,6 +69,8 @@
 }
 
 src_configure() {
+	append-cflags '-DUSE_INTERP_ERRORLINE -DUSE_INTERP_RESULT'
+
 	LC_ALL=C \
 	econf \
 		--x-includes="${EPREFIX}/usr/include" \


Reproducible: Always
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-04-04 21:48:57 UTC
Created attachment 344452 [details]
dev-tcltk:blt-2.4z-r12:20130404-203915.log

Stumbled across this as well in my world upgrade, build log attached.
Comment 2 Justin Lecher gentoo-dev 2013-04-05 07:02:07 UTC
+  05 Apr 2013; Justin Lecher <jlec@gentoo.org> blt-2.4z-r12.ebuild,
+  +files/blt-2.4z-tcl8.6.patch:
+  Add correct fix for compatibility to tcl-8.6, 464650
+
Comment 3 Justin Lecher gentoo-dev 2013-04-05 17:06:32 UTC
*** Bug 464694 has been marked as a duplicate of this bug. ***
Comment 4 Rafał Mużyło 2013-09-08 00:15:40 UTC
*** Bug 484148 has been marked as a duplicate of this bug. ***