Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458672 - net-misc/connman-1.11 version bump request
Summary: net-misc/connman-1.11 version bump request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-22 02:25 UTC by Yixun Lan
Modified: 2013-03-14 12:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
connman-1.12.ebuild (connman-1.12.ebuild,2.07 KB, text/plain)
2013-03-05 04:48 UTC, Yixun Lan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yixun Lan gentoo-dev 2013-02-22 02:25:33 UTC
current in tree version is 1.9, upstream most latest released version is 1.11

ConnMan 1.11 was released Friday, February 1st, 2013.
ConnMan 1.10 was released Saturday, December 22nd, 2012.

http://connman.net/blogs/patrik/2013/connman-111 ( for version 1.11)
http://connman.net/blogs/patrik/2013/connman-110 ( for version 1.10)

The new feature in this release is Bluez 5.x PAN support.

ConnMan will at run-time detect whether Bluez 4.x or Bluez 5.x is running and create a ConnMan service for each Bluetooth device that supports PAN NAP. Tethering using Bluez 5 is also supported, ConnMan will enable PAN NAP on each Bluetooth adapter in the device when Bluetooth tethering is enabled.

WiMAX and service migration code have both been removed in this release.

Thanks for all the hard work and bugfixes go to Anderson Lizardo, Forest Bond, Jukka Rissanen, Julien Massot, Lucas De Marchi, Luiz Augusto von Dentz, Marcel Holtmann, Patrik Flykt, Tomasz Bursztyka, Aldebaran Robotics, Intel and ProFUSION.




Reproducible: Always
Comment 1 teidakankan 2013-03-03 02:03:01 UTC
https://www.kernel.org/pub/linux/network/connman/connman-1.12.tar.xz

ConnMan 1.12 was released Tuesday, February 26th, 2013.

This release enhances network provisioning by adding ethernet, VPN and NFC provisioning support. There are a few important bugfixes included in the release, please consider upgrading from older versions.

New user visible features in this release are:

    VPN network configurations can now be provisioned via configuration files (Jukka Rissanen). See vpn-config-format.txt for provisioning file location and syntax.
    A 'GetProperties' method call has been added to net.connman.vpn.Connection (Jukka Rissanen).
    Ethernet networks can now be provisioned (Jukka Rissanen). As some of the items are applicable also to WiFi networks, WiFi provisioning support was enhanced at the same time. As ethernet networks are automatically enabled by plugging in the network cable, no provisioning files need to be written for normal day-to-day use.
    NFC WiFi provisioning (Tomasz Bursztyka). The features needed from neard are at the time of writing available only in the neard git repository, but will be available in upcoming neard versions newer than 0.9. With neard support we seem to have hit a minor glitch, libdbus version 1.4.12 or later is actually needed when compiling the neard NFC plugin. If it is not possible to install a newer libdbus version than the currently required version 1.4, one can for the time being disable NFC support by adding option --disable-neard to the configure script. More information about neard can be found at https://01.org/linux-nfc/. 

In addition to the features above, especially iptables, VPN and command line client code have seen a number of fixes and refactoring.
Comment 2 Yixun Lan gentoo-dev 2013-03-05 04:48:11 UTC
Created attachment 341000 [details]
connman-1.12.ebuild

em, my attempt to bump the ebuild to version 1.12...

people who are interested in may have a test or review..
Comment 3 Tony Vroon gentoo-dev 2013-03-14 12:50:59 UTC
+*connman-1.11 (14 Mar 2013)
+
+  14 Mar 2013; Tony Vroon <chainsaw@gentoo.org> -connman-1.4.ebuild,
+  -connman-1.5.ebuild, -connman-1.6.ebuild, -connman-1.7.ebuild,
+  -connman-1.8.ebuild, +connman-1.11.ebuild,
+  +files/connman-1.11-ip6-incomplete-type.patch, +files/connman.initd2:
+  Drop dependency on libnl as requested by Gustavo Sverzut Barbieri in bug
+  #415773. Init script now includes "provide net" as requested by José Romildo
+  Malaquias in bug #438142. Fix up incomplete ip6 type as described by Amadeusz
+  Sławiński in bug #460550. Version bump as requested by Dennis "dlan" Lan in
+  bug #458672. Dropped deprecated wimax support USE-flag.