Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 438142 - net-misc/connman-1.4 init script should "provide net"
Summary: net-misc/connman-1.4 init script should "provide net"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-12 15:58 UTC by José Romildo Malaquias
Modified: 2013-03-14 12:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description José Romildo Malaquias 2012-10-12 15:58:41 UTC
I want to use connman to manage network connections on my gentoo system. I have added its init script to the default runlevel and it is doing well.

The problem is that the connman init script does not provide "net", therefore the init system tries other alternatives installed on the system.

The init system was starting net.eth0 automatically. To stop that I removed all /etc/init.d/net.* symlinks (but /etc/init.d/net.lo is kept).

Then the init system choose to start NetworkManager automatically, which I do not want either.

In order to connman to be an option, it should provide the "net" service.
Comment 1 Tony Vroon gentoo-dev 2013-03-14 12:50:50 UTC
+*connman-1.11 (14 Mar 2013)
+
+  14 Mar 2013; Tony Vroon <chainsaw@gentoo.org> -connman-1.4.ebuild,
+  -connman-1.5.ebuild, -connman-1.6.ebuild, -connman-1.7.ebuild,
+  -connman-1.8.ebuild, +connman-1.11.ebuild,
+  +files/connman-1.11-ip6-incomplete-type.patch, +files/connman.initd2:
+  Drop dependency on libnl as requested by Gustavo Sverzut Barbieri in bug
+  #415773. Init script now includes "provide net" as requested by José Romildo
+  Malaquias in bug #438142. Fix up incomplete ip6 type as described by Amadeusz
+  Sławiński in bug #460550. Version bump as requested by Dennis "dlan" Lan in
+  bug #458672. Dropped deprecated wimax support USE-flag.