Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458246 - x11-drivers/nvidia-drivers-313.18 fail to build with vanilla-sources-3.8.0
Summary: x11-drivers/nvidia-drivers-313.18 fail to build with vanilla-sources-3.8.0
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 08:42 UTC by Dmitry Suloev
Modified: 2013-02-20 16:49 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,54.97 KB, text/plain)
2013-02-19 08:45 UTC, Dmitry Suloev
Details
English build.log (build.log,30.01 KB, text/plain)
2013-02-19 10:06 UTC, Axel Gembe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Suloev 2013-02-19 08:42:50 UTC
Subj.

Reproducible: Always

Steps to Reproduce:
1. emerge nvidia-drivers
Actual Results:  
nvidia-drivers fail to build

Expected Results:  
Successfull installation.
Comment 1 Dmitry Suloev 2013-02-19 08:44:31 UTC
emerge --info '=x11-drivers/nvidia-drivers-313.18'
Portage 2.1.11.52 (default/linux/amd64/13.0, gcc-4.7.2, glibc-2.16.0, 3.8.0 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.8.0-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:     4048372 total,   2566384 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Tue, 19 Feb 2013 04:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-lang/python:          2.7.3-r3
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x skype-4.0.0.7-copyright Intel-SDP Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 apng auto-hinter bash-completion berkdb bzip2 cairo cli consolekit cracklib cups cxx dbus dga djvu dri enca encode exif extras fontconfig fuse g3dvl gdbm git gles1 gles2 graphite gtk gtk3 gtkstyle gudev hal hotkeys iconv icu idle ipv6 jpeg jpeg2k lastfm libkms libsamplerate mad minizip mmx mmxext modules mp3 mpg123 mudflap multilib ncurses nls nptl nsplugin ogg opencl opengl openmp openvg openxml osmesa pam pcre png policykit radio rar readline samba savedconfig secure-delete session smp sqlite srv sse sse2 sse3 ssl ssse3 svg system-sqlite threads tiff truetype udev unicode unlock-notify usb utp v4l v4l2 vdpau vorbis xa xcb xft xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

x11-drivers/nvidia-drivers-313.18 was built with the following:
USE="X acpi (multilib) tools -pax_kernel"
Comment 2 Dmitry Suloev 2013-02-19 08:44:59 UTC
emerge -pqv '=x11-drivers/nvidia-drivers-313.18'
[ebuild   R   ] x11-drivers/nvidia-drivers-313.18  USE="X acpi (multilib) tools -pax_kernel"
Comment 3 Dmitry Suloev 2013-02-19 08:45:19 UTC
Created attachment 339348 [details]
build.log
Comment 4 Axel Gembe 2013-02-19 10:06:08 UTC
Created attachment 339356 [details]
English build.log
Comment 5 Axel Gembe 2013-02-19 10:06:19 UTC
Same here, added english build.log
Comment 6 Jeroen Roovers gentoo-dev 2013-02-19 20:26:12 UTC

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 7 Constantin Baranov 2013-02-19 23:05:51 UTC
(In reply to comment #6)
> 
> *** This bug has been marked as a duplicate of bug 447566 ***

I think this issue is distinct. Current drivers are built well for 3.7.8, but not for 3.8.0. And errors look different from those which was with 3.7.
Comment 8 root 2013-02-19 23:58:49 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > 
> > *** This bug has been marked as a duplicate of bug 447566 ***
> 
> I think this issue is distinct. Current drivers are built well for 3.7.8,
> but not for 3.8.0. And errors look different from those which was with 3.7.

Yeah it is distinct, this shouldn't be a duplicate. The above ticket patch does not fix it for 3.8.x kernels.

Check out https://bugs.gentoo.org/show_bug.cgi?id=458382 - those patches worked for me on 3.8.0.