Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458382 - x11-drivers/nvidia-drivers-313.18 failed at compile with linux-3.8.0-gentoo
Summary: x11-drivers/nvidia-drivers-313.18 failed at compile with linux-3.8.0-gentoo
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 23:45 UTC by tman
Modified: 2013-02-20 14:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nvidia-drivers-313.18-linux-3.8+.patch (nvidia-drivers-313.18-linux-3.8+.patch,430 bytes, patch)
2013-02-19 23:54 UTC, root
Details | Diff
nvidia-drivers-313.18.ebuild (nvidia-drivers-313.18.ebuild,12.21 KB, text/plain)
2013-02-19 23:55 UTC, root
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2013-02-19 23:45:08 UTC
x11-drivers/nvidia-drivers-313.18 failed at compile with  linux-3.8.0-gentoo

>>> Emerging (1 of 3) x11-drivers/nvidia-drivers-313.18
 * NVIDIA-Linux-x86_64-313.18.run SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                  [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.8.0-gentoo/build
 * Found sources for kernel version:
 *     3.8.0-gentoo
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-313.18.run to /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
 * Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...                                                                                 [ ok ]
 * Applying nvidia-drivers-313.18-builddir-config.patch ...                                                                                             [ ok ]
 * Applying nvidia-drivers-313.18-linux-3.7+.patch ...                                                                                                  [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
 * Preparing nvidia module
make -j9 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/3.8.0-gentoo/build CC=x86_64-pc-linux-gnu-gcc clean module 
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1
 * ERROR: x11-drivers/nvidia-drivers-313.18 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-313.18'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-313.18'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers:nvidia-drivers-313.18:20130220-001616.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/'

>>> Failed to emerge x11-drivers/nvidia-drivers-313.18, Log file:

>>>  '/var/tmp/portage/x11-drivers:nvidia-drivers-313.18:20130220-001616.log'

 * Messages for package x11-drivers/nvidia-drivers-313.18:

 * Package:    x11-drivers/nvidia-drivers-313.18
 * Repository: gentoo
 * Maintainer: cardoe@gentoo.org jer@gentoo.org,xarthisius@gentoo.org


Reproducible: Always
Comment 1 root 2013-02-19 23:54:24 UTC
Created attachment 339464 [details, diff]
nvidia-drivers-313.18-linux-3.8+.patch

Patch to fix issues with kernel >=3.8.0
Comment 2 root 2013-02-19 23:55:32 UTC
Created attachment 339466 [details]
nvidia-drivers-313.18.ebuild

ebuild to apply patch nvidia-drivers-313.18-linux-3.8+.patch (issues with kernel >= 3.8.0)
Comment 3 root 2013-02-19 23:56:10 UTC
Had the same issues. Attached a patch and an ebuild. Worked on a couple PC's i tried it out on. To note this is not the same issue that 3.7x was having the other week, afaict both patches still need to be applied.
Comment 4 Marc Grondin 2013-02-20 00:42:21 UTC
thank you for fast response. Patch works great.
Comment 5 hal 2013-02-20 00:54:25 UTC
Can confirm the patch works fine over here.
Comment 6 Jeroen Roovers gentoo-dev 2013-02-20 02:10:32 UTC

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 7 tman 2013-02-20 06:59:43 UTC
i got this erro but using in a local overlay:

 ebuild nvidia-drivers-313.18.ebuild digest
/usr/portage/local/local-overlay/x11-drivers/nvidia-drivers/nvidia-drivers-313.18.ebuild: line 4: $'\r': command not found
/usr/portage/local/local-overlay/x11-drivers/nvidia-drivers/nvidia-drivers-313.18.ebuild: line 6: $'\r': command not found
 * ERROR: x11-drivers/nvidia-drivers-313.18 failed (depend phase):
.eclass could not be found by inherit()
Comment 8 root 2013-02-20 08:01:15 UTC
(In reply to comment #7)
> i got this erro but using in a local overlay:
> 
>  ebuild nvidia-drivers-313.18.ebuild digest
> /usr/portage/local/local-overlay/x11-drivers/nvidia-drivers/nvidia-drivers-
> 313.18.ebuild: line 4: $'\r': command not found
> /usr/portage/local/local-overlay/x11-drivers/nvidia-drivers/nvidia-drivers-
> 313.18.ebuild: line 6: $'\r': command not found
>  * ERROR: x11-drivers/nvidia-drivers-313.18 failed (depend phase):
> .eclass could not be found by inherit()

Did you download the file directly from the attachment in this thread? Or pastebin raw download link (if you saw it in the forum)? Or did you open it up in any editor and save it (esp on windows)? For all I know just downloading and saving it on windows will do it :-P.

/r is the return character for windows editors.
/n is the return character on linux editors.

Just guessing.. I downloaded the above two files attached and copied to a local overlay - worked for me on two different systems (note i added the -r1 to the end of the ebuild when copying).

alpha-centauri nvidia-drivers # ebuild /usr/local/portage/x11-drivers/nvidia-drivers/nvidia-drivers-313.18-r1.ebuild digest
>>> Creating Manifest for /usr/local/portage/x11-drivers/nvidia-drivers
Comment 9 tman 2013-02-20 14:36:34 UTC
oh that the solution

thanks your very much @root :)