Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457574 - net-print/cups-1.6.1 - Brother USB Laser Printer no longer prints anything
Summary: net-print/cups-1.6.1 - Brother USB Laser Printer no longer prints anything
Status: RESOLVED DUPLICATE of bug 445278
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: cups-1.6-stable
  Show dependency tree
 
Reported: 2013-02-14 18:45 UTC by Joerg Schaible
Modified: 2013-06-26 22:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Schaible 2013-02-14 18:45:48 UTC
CUPS manages a Brother DCP-9010CN (USB Color Laser Printer/Scanner/Copier) with the GPL driver for this printer in version 3.2. However, the printer no longer prints anything. When a print job is sent, the printer starts to warm up, suddenly displays "reset" in its small display, stops completely and CUPS handles the job as successfully completed.


Reproducible: Always

Steps to Reproduce:
1. Connect a Brother DCP-9010CN ;-)
2. Emerge CUPS 1.6.1
3. Print something (even CUPS test page)
Actual Results:  
Printer warms up, but nothing happens although CUPS states a successful job

Expected Results:  
A printed sheet of paper

Looking through the logs I can see after the log entries for CUPS following line: "kernel: usb 1-3: reset high-speed USB device number 4 using ehci_hcd".

This reset is a new behavior starting with CUPS 1.5.4 according to http://cups.org/str.php?L4155+Qversion:1.6 and is required for some printers. However, for a lot printers this reset causes trouble either by canceling the print job completely or in the middle of printing.

I've created locally an ebuild version 1.6.1-r1 that applies patch #3 of that upstream issue and now only USB printers by Samsung will be reseted. With the patch I get proper paper output again.
Comment 1 Andreas K. Hüttel gentoo-dev 2013-06-26 22:39:59 UTC

*** This bug has been marked as a duplicate of bug 445278 ***