Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 445278 - >=net-print/cups-1.5.3 - Broken for some printer models [prints half last page]
Summary: >=net-print/cups-1.5.3 - Broken for some printer models [prints half last page]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords: EBUILD, PATCH
: 457574 (view as bug list)
Depends on:
Blocks: cups-1.6-stable
  Show dependency tree
 
Reported: 2012-11-30 00:19 UTC by Marios Andreopoulos
Modified: 2013-06-28 21:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to be applied 1st (usb-backend-reset-after-job-only-for-specific-devices-3.patch,2.98 KB, text/plain)
2012-11-30 00:20 UTC, Marios Andreopoulos
Details
patch to be applied 2nd (usb-backend-more-quirk-rules.patch,2.03 KB, text/plain)
2012-11-30 00:21 UTC, Marios Andreopoulos
Details
patch to be applied 3rd (usb-backend-xerox-3124.patch,722 bytes, text/plain)
2012-11-30 00:21 UTC, Marios Andreopoulos
Details
updated ebuild for cups 1.6.1 (cups-1.6.1-r1.ebuild,8.26 KB, text/plain)
2012-11-30 00:22 UTC, Marios Andreopoulos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marios Andreopoulos 2012-11-30 00:19:22 UTC
CUPS 1.5.3 introduced some code to sent a usb reset command at the end of a print.
While this solved problems for some printers, it created problems for some others.
Specifically, when the usb reset command is sent, affected printers cancel the print and thus print the last page partially.

Affected printers until now:
PIXMA iP4200, PIXMA iP4300, MP500, MP510, MP550, MP560, HL-1430, Okipage 14ex, Oki B410d, all Zebra printers.

I am surprised no one reported it yet.

Links to CUPS bug tracker (with appropriate patches):
http://www.cups.org/str.php?L4191
http://www.cups.org/str.php?L4155

One of the many reports on launchpad:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1032456

The patches from the above sources work with =net-print/cups-1.6.1.
I attach them, as well as an updated ebuild.

Reproducible: Always
Comment 1 Marios Andreopoulos 2012-11-30 00:20:39 UTC
Created attachment 330992 [details]
patch to be applied 1st
Comment 2 Marios Andreopoulos 2012-11-30 00:21:08 UTC
Created attachment 330994 [details]
patch to be applied 2nd
Comment 3 Marios Andreopoulos 2012-11-30 00:21:28 UTC
Created attachment 330996 [details]
patch to be applied 3rd
Comment 4 Marios Andreopoulos 2012-11-30 00:22:32 UTC
Created attachment 330998 [details]
updated ebuild for cups 1.6.1
Comment 5 barrie backhurst 2013-02-19 10:48:00 UTC
Works for me
Canon ip4000 and ip4300
Comment 6 Cristian Onet 2013-03-17 11:49:42 UTC
After emerging cups 1.6.1 I was also hit by this bug (using a BJC-2100 usb printer) and can confirm that applying the attached patches fixes the problem.
Comment 7 Andreas K. Hüttel gentoo-dev 2013-06-26 22:39:59 UTC
*** Bug 457574 has been marked as a duplicate of this bug. ***
Comment 8 Andreas K. Hüttel gentoo-dev 2013-06-28 21:37:24 UTC
Comment on attachment 330994 [details]
patch to be applied 2nd

This patch is already in net-print/cups-1.6.2
Comment 9 Andreas K. Hüttel gentoo-dev 2013-06-28 21:39:05 UTC
Comment on attachment 330992 [details]
patch to be applied 1st

This patch is already in net-print/cups-1.6.2
Comment 10 Andreas K. Hüttel gentoo-dev 2013-06-28 21:43:10 UTC
The last patch is also already in 1.6.2. Nothing to do here anymore after 1.6 goes stable.